* Tue Jan 31 2023 Tomas Bzatek <tbzatek@redhat.com> - 1.3-1
- Upstream v1.3 release
This commit is contained in:
parent
7d15b2ad0f
commit
351c1becda
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/libnvme-1.1-rc0.tar.gz
|
||||
/libnvme-1.1.tar.gz
|
||||
/libnvme-1.2.tar.gz
|
||||
/libnvme-1.3.tar.gz
|
||||
|
38
libnvme-1.3-meson_nss_includes.patch
Normal file
38
libnvme-1.3-meson_nss_includes.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From ddfb3ba036f9df2737c165b27f9b458dd83a7df8 Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Bzatek <tbzatek@redhat.com>
|
||||
Date: Tue, 31 Jan 2023 23:27:53 +0100
|
||||
Subject: [PATCH 2/2] build: Fix nss code snippet includes
|
||||
|
||||
With hardened distribution CFLAGS the meson code snippet wouldn't compile:
|
||||
|
||||
Compiler stderr:
|
||||
.build/meson-private/tmpy2z1t5q4/testfile.c: In function 'main':
|
||||
.build/meson-private/tmpy2z1t5q4/testfile.c:2:30: error: storage size of 'hints' isn't known
|
||||
2 | struct addrinfo hints, *result;
|
||||
| ^~~~~
|
||||
.build/meson-private/tmpy2z1t5q4/testfile.c:3:21: warning: implicit declaration of function 'getaddrinfo' [-Wimplicit-function-declaration]
|
||||
3 | return getaddrinfo(argv[1], argv[2], &hints, &result);
|
||||
| ^~~~~~~~~~~
|
||||
---
|
||||
meson.build | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index d389cbf..cf72d6d 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -199,7 +199,10 @@ conf.set10(
|
||||
conf.set(
|
||||
'HAVE_LIBNSS',
|
||||
cc.links(
|
||||
- '''int main(int argc, char **argv) {
|
||||
+ '''#include <sys/types.h>
|
||||
+ #include <sys/socket.h>
|
||||
+ #include <netdb.h>
|
||||
+ int main(int argc, char **argv) {
|
||||
struct addrinfo hints, *result;
|
||||
return getaddrinfo(argv[1], argv[2], &hints, &result);
|
||||
}
|
||||
--
|
||||
2.39.0
|
||||
|
17
libnvme.spec
17
libnvme.spec
@ -3,21 +3,23 @@
|
||||
|
||||
Name: libnvme
|
||||
Summary: Linux-native nvme device management library
|
||||
Version: 1.2
|
||||
Release: 2%{?dist}
|
||||
Version: 1.3
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/linux-nvme/libnvme
|
||||
Source0: %{url}/archive/v%{version_no_tilde}/%{name}-%{version_no_tilde}.tar.gz
|
||||
|
||||
Patch0: libnvme-1.3-meson_nss_includes.patch
|
||||
|
||||
BuildRequires: gcc gcc-c++
|
||||
BuildRequires: swig
|
||||
BuildRequires: python3-devel
|
||||
|
||||
BuildRequires: meson >= 0.48.0
|
||||
BuildRequires: meson >= 0.50
|
||||
BuildRequires: json-c-devel >= 0.13
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: dbus-devel
|
||||
%if (0%{?rhel} == 0)
|
||||
BuildRequires: systemd-devel > 219
|
||||
BuildRequires: kernel-headers >= 5.15
|
||||
%endif
|
||||
|
||||
@ -74,9 +76,9 @@ mv %{buildroot}/usr/*.rst %{buildroot}%{_pkgdocdir}/
|
||||
%files
|
||||
%license COPYING ccan/licenses/*
|
||||
%{_libdir}/libnvme.so.1
|
||||
%{_libdir}/libnvme.so.1.2.0
|
||||
%{_libdir}/libnvme.so.1.3.0
|
||||
%{_libdir}/libnvme-mi.so.1
|
||||
%{_libdir}/libnvme-mi.so.1.2.0
|
||||
%{_libdir}/libnvme-mi.so.1.3.0
|
||||
|
||||
%files devel
|
||||
%{_libdir}/libnvme.so
|
||||
@ -96,6 +98,9 @@ mv %{buildroot}/usr/*.rst %{buildroot}%{_pkgdocdir}/
|
||||
%{python3_sitearch}/libnvme/*
|
||||
|
||||
%changelog
|
||||
* Tue Jan 31 2023 Tomas Bzatek <tbzatek@redhat.com> - 1.3-1
|
||||
- Upstream v1.3 release
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libnvme-1.2.tar.gz) = f50517838cd1df3cdd123afdb67870633e9e484bf84dba70b784d7e86ecb355b96ba9d6a1cffb96b35444da7870dfe21c54b69701b5fe5b515319280db4a84e4
|
||||
SHA512 (libnvme-1.3.tar.gz) = c874b29b73e55be842f71e74a226a76fcd50dfa72e2be100f0437bc83e740cd146b6d2f2cdaa940c11c3d8c48ff2c065ac0e8a83d4d0dde743edf4179f328670
|
||||
|
Loading…
Reference in New Issue
Block a user