Rebase to upstream 2.0.0 release
Resolves: rhbz#2039220 Signed-off-by: Alexander Bokovoy <abokovoy@redhat.com>
This commit is contained in:
parent
c1ca879fa1
commit
e7fa67405d
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
|||||||
/libnsl-1.2.0.tar.gz
|
/libnsl-1.2.0.tar.gz
|
||||||
/libnsl-4a062cf4180d99371198951e4ea5b4550efd58a3.tar.gz
|
/libnsl-4a062cf4180d99371198951e4ea5b4550efd58a3.tar.gz
|
||||||
/v1.3.0.tar.gz
|
/v1.3.0.tar.gz
|
||||||
|
/v2.0.0.tar.gz
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
--- libnsl-libnsl-1.0.5/src/nisplus/nis_call.c.include_stdint 2017-06-12 16:05:36.864341686 +0200
|
|
||||||
+++ libnsl-libnsl-1.0.5/src/nisplus/nis_call.c 2017-06-12 16:05:56.745337017 +0200
|
|
||||||
@@ -31,6 +31,7 @@
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <netinet/in.h>
|
|
||||||
#include <arpa/inet.h>
|
|
||||||
+#include <stdint.h>
|
|
||||||
|
|
||||||
#include "libc-lock.h"
|
|
||||||
#include "nis_intern.h"
|
|
49
libnsl2.spec
49
libnsl2.spec
@ -1,26 +1,32 @@
|
|||||||
%global commit0 4a062cf4180d99371198951e4ea5b4550efd58a3
|
# Uncomment on initial build for soname bump.
|
||||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
#global bump_soname 1
|
||||||
|
%global sover 3
|
||||||
|
|
||||||
|
%if 0%{?bump_soname}
|
||||||
|
%global relsuffix ~sonamebump
|
||||||
|
%global old_sover %(echo $((%{sover}-1)))
|
||||||
|
%endif
|
||||||
|
|
||||||
Name: libnsl2
|
Name: libnsl2
|
||||||
Version: 1.3.0
|
Version: 2.0.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?relsuffix}%{?dist}
|
||||||
Summary: Public client interface library for NIS(YP) and NIS+
|
Summary: Public client interface library for NIS(YP) and NIS+
|
||||||
|
|
||||||
License: BSD and LGPLv2+
|
License: BSD and LGPLv2+
|
||||||
URL: https://github.com/thkukuk/libnsl
|
URL: https://github.com/thkukuk/libnsl
|
||||||
|
|
||||||
|
|
||||||
Source0: https://github.com/thkukuk/libnsl/archive/v%{version}.tar.gz
|
Source0: https://github.com/thkukuk/libnsl/archive/v%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: libnsl2-1.0.5-include_stdint.patch
|
|
||||||
|
|
||||||
BuildRequires: autoconf, automake, gettext-devel, libtool, libtirpc-devel
|
BuildRequires: autoconf, automake, gettext-devel, libtool, libtirpc-devel
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
|
BuildRequires: gcc
|
||||||
|
%if 0%{?bump_soname}
|
||||||
|
BuildRequires: libnsl2 < %{version}
|
||||||
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This package contains the libnsl library. This library contains
|
This package contains the libnsl library. This library contains
|
||||||
the public client interface for NIS(YP) and NIS+.
|
the public client interface for NIS(YP).
|
||||||
This code was formerly part of glibc, but is now standalone to
|
This code was formerly part of glibc, but is now standalone to
|
||||||
be able to link against TI-RPC for IPv6 support.
|
be able to link against TI-RPC for IPv6 support.
|
||||||
|
|
||||||
@ -36,32 +42,31 @@ Development files for libnsl2
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n libnsl-%{version}
|
%setup -q -n libnsl-%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .include_stdint
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
export CFLAGS="%{optflags}"
|
|
||||||
|
|
||||||
autoreconf -fiv
|
autoreconf -fiv
|
||||||
|
|
||||||
%configure\
|
%configure \
|
||||||
--libdir=%{_libdir}\
|
--libdir=%{_libdir} \
|
||||||
--includedir=%{_includedir}
|
--includedir=%{_includedir}
|
||||||
|
|
||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
|
|
||||||
%make_install
|
%make_install
|
||||||
|
|
||||||
rm %{buildroot}/%{_libdir}/libnsl.a
|
rm %{buildroot}%{_libdir}/libnsl.{a,la}
|
||||||
rm %{buildroot}/%{_libdir}/libnsl.la
|
|
||||||
|
%if 0%{?bump_soname}
|
||||||
|
cp -p %{_libdir}/libnsl.so.%{old_sover}* %{buildroot}%{_libdir}
|
||||||
|
%endif
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%{_libdir}/libnsl.so.*
|
|
||||||
|
|
||||||
%license COPYING
|
%license COPYING
|
||||||
|
%{_libdir}/libnsl.so.%{sover}*
|
||||||
|
%if 0%{?bump_soname}
|
||||||
|
%{_libdir}/libnsl.so.%{old_sover}*
|
||||||
|
%endif
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/libnsl.so
|
%{_libdir}/libnsl.so
|
||||||
@ -69,6 +74,10 @@ rm %{buildroot}/%{_libdir}/libnsl.la
|
|||||||
%{_libdir}/pkgconfig/libnsl.pc
|
%{_libdir}/pkgconfig/libnsl.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 20 2022 Alexander Bokovoy <abokovoy@redhat.com> - 2.0.0-1
|
||||||
|
- Rebase to upstream 2.0.0 release
|
||||||
|
- Resolves: rhbz#2039220
|
||||||
|
|
||||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.3.0-4
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.3.0-4
|
||||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
Related: rhbz#1991688
|
Related: rhbz#1991688
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (v1.3.0.tar.gz) = ce75ee9e54f1bdd2b31886e8157ff5f654511c3da017e0d9f8d0da6a2a9f9a78ff2e5f72cfb7ce3a23065f57337db51e3c8842a7e990350a62612018f4960342
|
SHA512 (v2.0.0.tar.gz) = 86a7738707a3e4e56b60c8de0445fb576e66148bc12fa2a6aab422ea81eb4b42be3287a12f78384acd2b8bfb3885e9a0ce4f7328f078da3a5099acb66a35a935
|
||||||
|
Loading…
Reference in New Issue
Block a user