diff --git a/.gitignore b/.gitignore
index c88080d..8330663 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
/libnma-1.8.26.tar.xz
+/libnma-1.8.28.tar.xz
diff --git a/0001-nm-applet-no-notifications.patch b/0001-nm-applet-no-notifications.patch
new file mode 100644
index 0000000..be6b6bf
--- /dev/null
+++ b/0001-nm-applet-no-notifications.patch
@@ -0,0 +1,13 @@
+diff --git a/org.gnome.nm-applet.gschema.xml.in b/org.gnome.nm-applet.gschema.xml.in
+index 9e2887e..4f8c16a 100644
+--- a/org.gnome.nm-applet.gschema.xml.in
++++ b/org.gnome.nm-applet.gschema.xml.in
+@@ -17,7 +17,7 @@
+ Set this to true to disable notifications when connecting to or disconnecting from a VPN.
+
+
+- false
++ true
+ Suppress networks available notifications
+ Set this to true to disable notifications when Wi-Fi networks are available.
+
diff --git a/libnma.spec b/libnma.spec
index 5acae80..4ca81e0 100644
--- a/libnma.spec
+++ b/libnma.spec
@@ -1,27 +1,33 @@
-%global gtk3_version %(pkg-config --modversion gtk+-3.0 2>/dev/null || echo bad)
-%global gtk4_version %(pkg-config --modversion gtk4 2>/dev/null || echo bad)
-%global glib2_version %(pkg-config --modversion glib-2.0 2>/dev/null || echo bad)
-%global glib2_version %(pkg-config --modversion glib-2.0 2>/dev/null || echo bad)
-%global nm_version 1:1.8.0
-%global mbp_version 0.20090602
+%global gtk3_version %(pkg-config --modversion gtk+-3.0 2>/dev/null || echo bad)
+%global gtk4_version %(pkg-config --modversion gtk4 2>/dev/null || echo bad)
+%global glib2_version %(pkg-config --modversion glib-2.0 2>/dev/null || echo bad)
+%global nm_version 1:1.8.0
+%global mbp_version 0.20090602
+%global old_libnma_version 1.8.27
+
+%global rpm_version 1.8.28
+%global real_version 1.8.28
+%global release_version 1
+
+%global real_version_major %(printf '%s' '%{real_version}' | sed -n 's/^\\([1-9][0-9]*\\.[1-9][0-9]*\\)\\.[1-9][0-9]*$/\\1/p')
-%if 0%{?fedora} > 31 || 0%{?rhel} > 8
-%bcond_without libnma_gtk4
-%else
%bcond_with libnma_gtk4
-%endif
Name: libnma
Summary: NetworkManager GUI library
-Version: 1.8.26
-Release: 4%{?dist}
+Version: %{rpm_version}
+Release: %{release_version}%{?dist}
# The entire source code is GPLv2+ except some files in shared/ which are LGPLv2+
License: GPLv2+ and LGPLv2+
URL: https://gitlab.gnome.org/GNOME/libnma/
-Source0: https://download.gnome.org/sources/libnma/1.8/%{name}-%{version}.tar.xz
+Source0: https://download.gnome.org/sources/libnma/%{real_version_major}/%{name}-%{real_version}.tar.xz
+
+Patch1: 0001-nm-applet-no-notifications.patch
Requires: mobile-broadband-provider-info >= %{mbp_version}
+Conflicts: libnma < %{old_libnma_version}
+
BuildRequires: gcc
BuildRequires: NetworkManager-libnm-devel >= %{nm_version}
BuildRequires: ModemManager-glib-devel >= 1.0
@@ -51,6 +57,7 @@ Obsoletes: NetworkManager-gtk-devel < 1:0.9.7
Requires: libnma%{?_isa} = %{version}-%{release}
Requires: gtk3-devel%{?_isa}
Requires: pkgconfig
+Conflicts: libnma < %{old_libnma_version}
%description devel
This package contains header and pkg-config files to be used for integrating
@@ -61,6 +68,7 @@ GUI tools with NetworkManager.
Summary: Experimental GTK 4 version of NetworkManager GUI library
Requires: gtk4%{?_isa} >= %{gtk4_version}
Requires: mobile-broadband-provider-info >= %{mbp_version}
+Conflicts: libnma < %{old_libnma_version}
%description gtk4
This package contains the experimental GTK4 version of library used for
@@ -73,6 +81,7 @@ Requires: NetworkManager-libnm-devel >= %{nm_version}
Requires: libnma-gtk4%{?_isa} = %{version}-%{release}
Requires: gtk4-devel%{?_isa}
Requires: pkgconfig
+Conflicts: libnma < %{old_libnma_version}
%description gtk4-devel
This package contains the experimental GTK4 version of header and pkg-config
@@ -80,13 +89,14 @@ files to be used for integrating GUI tools with NetworkManager.
%prep
-%autosetup -p1
+%autosetup -p1 -n "%{name}-%{real_version}"
%build
%meson \
-Dgcr=true \
-Ddisable-static=true \
+ -Dvapi=false \
%if %{with libnma_gtk4}
-Dlibnma_gtk4=true
%else
@@ -107,6 +117,7 @@ files to be used for integrating GUI tools with NetworkManager.
%files -f %{name}.lang
%{_libdir}/libnma.so.*
%{_libdir}/girepository-1.0/NMA-1.0.typelib
+%{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
%doc NEWS CONTRIBUTING
%license COPYING
@@ -135,6 +146,11 @@ files to be used for integrating GUI tools with NetworkManager.
%changelog
+* Fri Mar 6 2020 Thomas Haller - 1.8.28-1
+- Update to 1.8.28 release
+- move org.gnome.nm-applet.gschema.xml from network-manager-applet to here.
+- introduce wireless security dialogs
+
* Wed Jan 29 2020 Fedora Release Engineering - 1.8.26-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
diff --git a/sources b/sources
index c36ee59..62364b1 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (libnma-1.8.26.tar.xz) = ea9b1ce9e5ca771d9d998da269e815fe3eafa08515edffc7fffe0e41efc28b373d731040b3c1a5144f720d19e7da746578d2d4994bfd162eb310696cf997f3b6
+SHA512 (libnma-1.8.28.tar.xz) = d3996da3433493149edf0743b7f2280a83db2efc2228f04eddb773bbcb08ea2efcb640f781cb1d0a5cbabd8b25b1c612387682ff5239151d8ce249568e877f5b