libnice/libnice-0.1.14-tests-koji.patch
Kamil Dudka 35231eb713 reintroduce autoreconf in %prep
... and fix a misleading comment in libnice-0.1.14-tests-koji.patch

If autoreconf does not run before the configure script, the subsequent
`make` command runs the configure script once again.  Moreover the build
fails in the fedora-28-x86_64 mock profile because aclocal-1.16 is not
available:

[...]
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ make -j8 V=1
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /builddir/build/BUILD/libnice-0.1.16/missing aclocal-1.16 -I m4
/builddir/build/BUILD/libnice-0.1.16/missing: line 81: aclocal-1.16: command not found
WARNING: 'aclocal-1.16' is missing on your system.
         You should only need it if you modified 'acinclude.m4' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'aclocal' program is part of the GNU Automake package:
         <https://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <https://www.gnu.org/software/autoconf>
         <https://www.gnu.org/software/m4/>
         <https://www.perl.org/>
make: *** [Makefile:455: aclocal.m4] Error 127
error: Bad exit status from /var/tmp/rpm-tmp.jpPP9q (%build)
2019-05-10 10:14:21 +02:00

37 lines
1.2 KiB
Diff

From 527c30ba453753e75d3d31be29a277ea6adc17c0 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Fri, 9 Feb 2018 19:10:20 +0100
Subject: [PATCH] tests: make the test-suite more verbose
... and skip test-gstreamer if user's home is /builddir (a heuristic
to detect mock) because multicast traffic is blocked on Koji buildhosts.
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 16988ad..b7b74fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ AC_CANONICAL_TARGET
AC_CONFIG_SRCDIR([agent/agent.c])
AC_CONFIG_HEADERS([config.h])
-AM_INIT_AUTOMAKE([1.12 -Wall -Wno-portability subdir-objects])
+AM_INIT_AUTOMAKE([1.12 -Wall -Wno-portability subdir-objects serial-tests])
AC_CONFIG_FILES([
Makefile
@@ -263,7 +263,7 @@ AC_SUBST(gstplugindir)
AC_SUBST(gstplugin010dir)
AM_CONDITIONAL(WITH_GSTREAMER, test "$with_gstreamer" = yes)
-AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
+AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes -a "$HOME" != /builddir)
AM_CONDITIONAL(WITH_GSTREAMER010, test "$with_gstreamer010" = yes)
GUPNP_IGD_REQUIRED=0.2.4
--
2.13.6