- Update to 0.0.9.
- Drop sha1 patch. Fixed upstream.
This commit is contained in:
parent
fc8e345e3e
commit
d5500f2b90
@ -1 +1 @@
|
||||
libnice-0.0.8.tar.gz
|
||||
libnice-0.0.9.tar.gz
|
||||
|
@ -1,22 +0,0 @@
|
||||
http://bugs.archlinux.org/task/15189
|
||||
|
||||
X-Git-Url: http://git.collabora.co.uk/?p=user%2Fkakaroto%2Flibnice.git;a=blobdiff_plain;f=stun%2Fsha1.c;h=d0e75d5047766c11fd5c37166e29d9a73e6e0d61;hp=94b2b4b096114d20ee0e12c3a688a10769eb678e;hb=e571e13fb03d217d27c1164379760f9d0c13d3ca;hpb=52f330873715fea4198c1450bd9bf3ff6bdd2f6d
|
||||
|
||||
diff --git a/stun/sha1.c b/stun/sha1.c
|
||||
index 94b2b4b..d0e75d5 100644
|
||||
--- a/stun/sha1.c
|
||||
+++ b/stun/sha1.c
|
||||
@@ -143,11 +143,11 @@ static void SHA1Transform(uint32_t state[5], const unsigned char buffer[64])
|
||||
{
|
||||
uint32_t a, b, c, d, e;
|
||||
typedef union {
|
||||
- unsigned char c[64];
|
||||
+ uint8_t c[64];
|
||||
uint32_t l[16];
|
||||
} CHAR64LONG16;
|
||||
CHAR64LONG16* block;
|
||||
- uint32_t workspace[16];
|
||||
+ uint8_t workspace[64];
|
||||
block = (CHAR64LONG16 *) workspace;
|
||||
memcpy(block, buffer, 64);
|
||||
|
10
libnice.spec
10
libnice.spec
@ -1,13 +1,12 @@
|
||||
Name: libnice
|
||||
Version: 0.0.8
|
||||
Release: 3%{?dist}
|
||||
Version: 0.0.9
|
||||
Release: 1%{?dist}
|
||||
Summary: GLib ICE implementation
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2 and MPLv1.1
|
||||
URL: http://nice.freedesktop.org/wiki/
|
||||
Source0: http://nice.freedesktop.org/releases/%{name}-%{version}.tar.gz
|
||||
Patch0: libnice-0.0.8-sha1.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: glib2-devel
|
||||
@ -40,7 +39,6 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -84,6 +82,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Aug 2 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.9-1
|
||||
- Update to 0.0.9.
|
||||
- Drop sha1 patch. Fixed upstream.
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user