Update to 0.1.18
This commit is contained in:
parent
ce6f0027fc
commit
2727ef26cb
@ -1,36 +0,0 @@
|
||||
From 527c30ba453753e75d3d31be29a277ea6adc17c0 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Fri, 9 Feb 2018 19:10:20 +0100
|
||||
Subject: [PATCH] tests: make the test-suite more verbose
|
||||
|
||||
... and skip test-gstreamer if user's home is /builddir (a heuristic
|
||||
to detect mock) because multicast traffic is blocked on Koji buildhosts.
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 16988ad..b7b74fa 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -12,7 +12,7 @@ AC_CANONICAL_TARGET
|
||||
|
||||
AC_CONFIG_SRCDIR([agent/agent.c])
|
||||
AC_CONFIG_HEADERS([config.h])
|
||||
-AM_INIT_AUTOMAKE([1.12 -Wall -Wno-portability subdir-objects])
|
||||
+AM_INIT_AUTOMAKE([1.12 -Wall -Wno-portability subdir-objects serial-tests])
|
||||
|
||||
AC_CONFIG_FILES([
|
||||
Makefile
|
||||
@@ -263,7 +263,7 @@ AC_SUBST(gstplugindir)
|
||||
AC_SUBST(gstplugin010dir)
|
||||
|
||||
AM_CONDITIONAL(WITH_GSTREAMER, test "$with_gstreamer" = yes)
|
||||
-AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
|
||||
+AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes -a "$HOME" != /builddir)
|
||||
AM_CONDITIONAL(WITH_GSTREAMER010, test "$with_gstreamer010" = yes)
|
||||
|
||||
GUPNP_IGD_REQUIRED=0.2.4
|
||||
--
|
||||
2.13.6
|
||||
|
75
libnice.spec
75
libnice.spec
@ -1,32 +1,21 @@
|
||||
# disable building of plugin for gstreamer 0.10
|
||||
%bcond_with gst010
|
||||
|
||||
Name: libnice
|
||||
Version: 0.1.17
|
||||
Release: 5%{?dist}
|
||||
Version: 0.1.18
|
||||
Release: 1%{?dist}
|
||||
Summary: GLib ICE implementation
|
||||
|
||||
License: LGPLv2 and MPLv1.1
|
||||
URL: https://nice.freedesktop.org/wiki/
|
||||
Source0: https://nice.freedesktop.org/releases/%{name}-%{version}.tar.gz
|
||||
|
||||
# make tests pass in Koji
|
||||
Patch1: libnice-0.1.14-tests-koji.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: gnutls-devel >= 2.12.0
|
||||
BuildRequires: gobject-introspection-devel
|
||||
%if %{with gst010}
|
||||
BuildRequires: gstreamer-devel
|
||||
BuildRequires: gstreamer-plugins-base-devel
|
||||
%endif
|
||||
BuildRequires: gstreamer1-devel >= 0.11.91
|
||||
BuildRequires: gstreamer1-plugins-base-devel >= 0.11.91
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: gupnp-igd-devel >= 0.1.2
|
||||
BuildRequires: make
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: graphviz
|
||||
BuildRequires: meson
|
||||
|
||||
|
||||
%description
|
||||
@ -38,16 +27,6 @@ ICE include the Session Initiation Protocol (SIP) and Jingle, XMPP extension
|
||||
for audio/video calls.
|
||||
|
||||
|
||||
%if %{with gst010}
|
||||
%package gstreamer
|
||||
Summary: GStreamer plugin for %{name}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description gstreamer
|
||||
The %{name}-gstreamer package contains a gstreamer 0.10 plugin for %{name}.
|
||||
%endif
|
||||
|
||||
|
||||
%package gstreamer1
|
||||
Summary: GStreamer plugin for %{name}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
@ -69,37 +48,19 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
chmod 0755 scripts/valgrind-test-driver
|
||||
|
||||
# disable test-new-trickle, which sometimes hangs indefinitely, and
|
||||
# test-send-recv, which fails in Koji due to insufficiently configured network
|
||||
sed -e 's/test-new-trickle/#&/' \
|
||||
-e 's/test-send-recv/#&/' \
|
||||
-i tests/Makefile.am
|
||||
|
||||
# needed for libnice-0.1.14-tests-koji.patch
|
||||
autoreconf -fiv
|
||||
|
||||
# disable tests that don't work in koji environment
|
||||
sed \
|
||||
-e "s/^ 'test-set-port-range'/#&/" \
|
||||
-i tests/meson.build
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-compile-warnings=yes \
|
||||
--disable-static \
|
||||
--with-ignored-network-interface-prefix=br-,docker,veth,virbr,vnet \
|
||||
%if %{with gst010}
|
||||
--with-gstreamer-0.10
|
||||
%else
|
||||
--without-gstreamer-0.10
|
||||
%endif
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make %{?_smp_mflags} V=1
|
||||
%meson -D gtk_doc=enabled
|
||||
%meson_build
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
%meson_install
|
||||
|
||||
|
||||
%check
|
||||
@ -107,8 +68,7 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
# are getting random crashes in Koji on secondary arches but I have not been
|
||||
# able to reproduce them locally so far.
|
||||
%ifarch x86_64 %{ix86}
|
||||
export LD_LIBRARY_PATH="$PWD/nice/.libs"
|
||||
make check
|
||||
%meson_test
|
||||
%endif
|
||||
|
||||
|
||||
@ -124,12 +84,6 @@ make check
|
||||
%{_libdir}/girepository-1.0/Nice-0.1.typelib
|
||||
|
||||
|
||||
%if %{with gst010}
|
||||
%files gstreamer
|
||||
%{_libdir}/gstreamer-0.10/libgstnice010.so
|
||||
%endif
|
||||
|
||||
|
||||
%files gstreamer1
|
||||
%{_libdir}/gstreamer-1.0/libgstnice.so
|
||||
|
||||
@ -143,6 +97,9 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 08 2021 Stefan Becker <chemobejk@gmail.com> - 0.1.18-1
|
||||
- Update to 0.1.18 (#1980120)
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.17-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libnice-0.1.17.tar.gz) = 177ee47712233af379f422cbe24befaa1b744444241723a6575f17db30f7032aa8a34b1c6e160f6f406545fc42c1e7e3ca36c274bea5adb169b02434712c908e
|
||||
SHA512 (libnice-0.1.18.tar.gz) = 08bac05874708f7e7a669d28727d8951a10c464b22dd6fada1a4644850bcf5c4cc022cce46bb24c806086a7869b274c4c7d3d6ddaa9ed0ce0bc2c47f72933227
|
||||
|
Loading…
Reference in New Issue
Block a user