import libnice-0.1.14-7.20180504git34d6044.el8

This commit is contained in:
CentOS Sources 2020-09-29 14:08:44 +00:00 committed by Andrew Lukoshko
commit 27273c2710
7 changed files with 12429 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/libnice-0.1.14.tar.gz

1
.libnice.metadata Normal file
View File

@ -0,0 +1 @@
bc33999b547c14d40be42e67aa813b0d87bbd98f SOURCES/libnice-0.1.14.tar.gz

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,48 @@
From 3f8364b41207d8c26d3d3be518a7d9ebf4243b92 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Fri, 9 Feb 2018 18:01:57 +0100
Subject: [PATCH] tests: make them compile on i686
---
tests/test-pseudotcp-fuzzy.c | 4 ++--
tests/test-pseudotcp.c | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/tests/test-pseudotcp-fuzzy.c b/tests/test-pseudotcp-fuzzy.c
index 4a714e6..030c03f 100644
--- a/tests/test-pseudotcp-fuzzy.c
+++ b/tests/test-pseudotcp-fuzzy.c
@@ -129,7 +129,7 @@ write_to_sock (PseudoTcpSocket *sock)
total += wlen;
total_read += wlen;
if (wlen < (gint) len) {
- g_debug ("seeking %ld from %lu", wlen - len, ftell (in));
+ g_debug ("seeking %ld from %lu", (long) wlen - len, ftell (in));
fseek (in, wlen - len, SEEK_CUR);
g_assert (!feof (in));
g_debug ("Socket queue full after %d bytes written", total);
@@ -355,7 +355,7 @@ static void adjust_clock (PseudoTcpSocket *sock)
if (pseudo_tcp_socket_get_next_clock (sock, &timeout)) {
timeout -= g_get_monotonic_time () / 1000;
- g_debug ("Socket %p: Adjusting clock to %ld ms", sock, timeout);
+ g_debug ("Socket %p: Adjusting clock to %ld ms", sock, (long) timeout);
if (sock == left) {
if (left_clock != 0)
g_source_remove (left_clock);
diff --git a/tests/test-pseudotcp.c b/tests/test-pseudotcp.c
index 1a8391a..584a0d0 100644
--- a/tests/test-pseudotcp.c
+++ b/tests/test-pseudotcp.c
@@ -81,7 +81,7 @@ static void write_to_sock (PseudoTcpSocket *sock)
total += wlen;
total_read += wlen;
if (wlen < (gint) len) {
- g_debug ("seeking %ld from %lu", wlen - len, ftell (in));
+ g_debug ("seeking %ld from %lu", (long) wlen - len, ftell (in));
fseek (in, wlen - len, SEEK_CUR);
g_assert (!feof (in));
g_debug ("Socket queue full after %d bytes written", total);
--
2.13.6

View File

@ -0,0 +1,36 @@
From 527c30ba453753e75d3d31be29a277ea6adc17c0 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Fri, 9 Feb 2018 19:10:20 +0100
Subject: [PATCH] tests: make the test-suite more verbose
... and skip test-gstreamer if user's home is not /builddir (a heuristic
to detect mock) because multicast traffic is blocked on Koji buildhosts.
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 16988ad..b7b74fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ AC_CANONICAL_TARGET
AC_CONFIG_SRCDIR([agent/agent.c])
AC_CONFIG_HEADERS([config.h])
-AM_INIT_AUTOMAKE([1.12 -Wall -Wno-portability subdir-objects])
+AM_INIT_AUTOMAKE([1.12 -Wall -Wno-portability subdir-objects serial-tests])
AC_CONFIG_FILES([
Makefile
@@ -263,7 +263,7 @@ AC_SUBST(gstplugindir)
AC_SUBST(gstplugin010dir)
AM_CONDITIONAL(WITH_GSTREAMER, test "$with_gstreamer" = yes)
-AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
+AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes -a "$HOME" != /builddir)
AM_CONDITIONAL(WITH_GSTREAMER010, test "$with_gstreamer010" = yes)
GUPNP_IGD_REQUIRED=0.2.4
--
2.13.6

View File

@ -0,0 +1,32 @@
From e4d92bf96d0bb64df35790e5b49c58bfa6e9fbcc Mon Sep 17 00:00:00 2001
From: Jakub Adam <jakub.adam@ktknet.cz>
Date: Thu, 20 Apr 2017 06:47:00 +0200
Subject: [PATCH] component: accept TURN in
nice_component_verify_remote_candidate()
When TURN is in operation, agent_recv_message_unlocked() may receive from
NiceSocket with type = NICE_SOCKET_TYPE_UDP_TURN. Such messages were always
dropped due to failed nice_component_verify_remote_candidate().
Bug: https://phabricator.freedesktop.org/D1727
---
agent/component.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/agent/component.c b/agent/component.c
index 6eee90e..3e8a7a6 100644
--- a/agent/component.c
+++ b/agent/component.c
@@ -1510,7 +1510,8 @@ nice_component_verify_remote_candidate (NiceComponent *component,
(cand->transport == NICE_CANDIDATE_TRANSPORT_TCP_ACTIVE ||
cand->transport == NICE_CANDIDATE_TRANSPORT_TCP_PASSIVE ||
cand->transport == NICE_CANDIDATE_TRANSPORT_TCP_SO)) ||
- cand->transport == NICE_CANDIDATE_TRANSPORT_UDP) &&
+ cand->transport == NICE_CANDIDATE_TRANSPORT_UDP ||
+ nicesock->type == NICE_SOCKET_TYPE_UDP_TURN) &&
nice_address_equal (address, &cand->addr)) {
/* fast return if it's already the first */
if (item == component->valid_candidates)
--
2.14.3

348
SPECS/libnice.spec Normal file
View File

@ -0,0 +1,348 @@
# disable building of plugin for gstreamer 0.10
%bcond_with gst010
%global upstream_date 20180504
%global upstream_rnum 85
%global upstream_hash 34d6044
Name: libnice
Version: 0.1.14
Release: 7.%{upstream_date}git%{upstream_hash}%{?dist}
Summary: GLib ICE implementation
Group: System Environment/Libraries
License: LGPLv2 and MPLv1.1
URL: https://nice.freedesktop.org/wiki/
Source0: https://nice.freedesktop.org/releases/%{name}-%{version}.tar.gz
Patch1: libnice-0.1.14-%{upstream_rnum}-g%{upstream_hash}.patch
# make tests compile on i686
Patch2: libnice-0.1.14-tests-i686.patch
# make tests pass in Koji
Patch3: libnice-0.1.14-tests-koji.patch
# component: accept TURN in nice_component_verify_remote_candidate() (#1541646)
Patch4: libnice-0.1.14-turn-verify.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: glib2-devel
BuildRequires: gnutls-devel >= 2.12.0
BuildRequires: gobject-introspection-devel
%if %{with gst010}
BuildRequires: gstreamer-devel
BuildRequires: gstreamer-plugins-base-devel
%endif
BuildRequires: gstreamer1-devel >= 0.11.91
BuildRequires: gstreamer1-plugins-base-devel >= 0.11.91
BuildRequires: gupnp-igd-devel >= 0.1.2
%description
%{name} is an implementation of the IETF draft Interactive Connectivity
Establishment standard (ICE). ICE is useful for applications that want to
establish peer-to-peer UDP data streams. It automates the process of traversing
NATs and provides security against some attacks. Existing standards that use
ICE include the Session Initiation Protocol (SIP) and Jingle, XMPP extension
for audio/video calls.
%if %{with gst010}
%package gstreamer
Summary: GStreamer plugin for %{name}
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description gstreamer
The %{name}-gstreamer package contains a gstreamer 0.10 plugin for %{name}.
%endif
%package gstreamer1
Summary: GStreamer plugin for %{name}
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description gstreamer1
The %{name}-gstreamer1 package contains a gstreamer 1.0 plugin for %{name}.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: glib2-devel
Requires: pkgconfig
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
chmod 0755 scripts/valgrind-test-driver
# disable test-new-dribble, which sometimes hangs indefinitely, and
# test-send-recv, which fails in Koji due to insufficiently configured network
sed -e 's/test-new-dribble/#&/' \
-e 's/test-send-recv/#&/' \
-i tests/Makefile.am
autoreconf -fiv
%build
%configure --enable-compile-warnings=yes --disable-static \
%if %{with gst010}
--with-gstreamer-0.10
%else
--without-gstreamer-0.10
%endif
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags} V=1
%install
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%check
# Temporarily make the upstream test-suite run on Intel arches only because we
# are getting random crashes in Koji on secondary arches but I have not been
# able to reproduce them locally so far.
%ifarch x86_64 %{ix86}
export LD_LIBRARY_PATH="$PWD/nice/.libs"
make check
%endif
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc NEWS README
%license COPYING COPYING.LGPL COPYING.MPL
%{_bindir}/stunbdc
%{_bindir}/stund
%{_libdir}/*.so.*
%{_libdir}/girepository-1.0/Nice-0.1.typelib
%if %{with gst010}
%files gstreamer
%{_libdir}/gstreamer-0.10/libgstnice010.so
%endif
%files gstreamer1
%{_libdir}/gstreamer-1.0/libgstnice.so
%files devel
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/nice.pc
%{_datadir}/gtk-doc/html/%{name}/
%{_datadir}/gir-1.0/Nice-0.1.gir
%changelog
* Mon May 07 2018 Kamil Dudka <kdudka@redhat.com> - 0.1.14-7.20180504git34d6044
- component: accept TURN in nice_component_verify_remote_candidate() (#1541646)
- update to 0.1.14-85-g34d6044 (#1541646)
* Mon Apr 16 2018 Kamil Dudka <kdudka@redhat.com> - 0.1.14-6.20171128gitfb2f1f7
- temporarily make the upstream test-suite run on Intel arches only
- disable test-send-recv, which fails in Koji
* Fri Mar 16 2018 Kamil Dudka <kdudka@redhat.com> - 0.1.14-5.20171128gitfb2f1f7
- do not build with -Werror by default
- make the build more verbose
* Fri Feb 09 2018 Kamil Dudka <kdudka@redhat.com> - 0.1.14-4.20171128gitfb2f1f7
- enable make check again
- make tests pass in Koji
- disable test-new-dribble that sometimes hangs indefinitely
- make tests compile on i686
- make the package build on armv7hl
- make the package build on Fedora 28
- avoid build failure if gstreamer-plugins-base-devel is installed
- move autoreconf invocation to %%prep
- use Name Version Release that explicitly identifies an SCM snapshot (#1541646)
* Fri Feb 09 2018 Stefan Becker <chemobejk@gmail.com> - 0.1.14-3
- update to 0.1.14-70-gfb2f1f7 with alternate server fixes for SIPE
- add autoreconf build step
- remove examples subpackage as examples are no longer installed
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.14-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Mon Jan 29 2018 Stefan Becker <chemobejk@gmail.com> - 0.1.14-1
- Update to 0.1.14
* Wed Jan 24 2018 Tomas Hoger <thoger@redhat.com> - 0.1.13-11
- Add conditional for building with(out) gst010 / GStreamer 0.10 support.
- Disable gst010 plugin by default.
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.13-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.13-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.13-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Jul 21 2016 Than Ngo <than@redhat.com> - 0.1.13-7
- Rebuilt for glibc: Revert sendmsg/recvmsg ABI changes
* Fri Jun 10 2016 David Woodhouse <dwmw2@infradead.org> - 0.1.13-6
- More updates from libnice git; use-after-free fixes
* Mon Jun 06 2016 David Woodhouse <dwmw2@infradead.org> - 0.1.13-5
- Wholesale update to git HEAD, which fixes SIPE again.
* Fri May 20 2016 David Woodhouse <dwmw2@infradead.org> - 0.1.13-4
- Backport patch to fix SIPE audio disconnections (#1337051)
- Fix candidate gathering with IPV6 tentative addresses (#1337412)
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.13-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed Apr 29 2015 Kalev Lember <kalevlember@gmail.com> - 0.1.13-1
- Update to 0.1.13
- Tighten dependencies with the _isa macro
* Tue Apr 21 2015 Kalev Lember <kalevlember@gmail.com> - 0.1.11-1
- Update to 0.1.11
- Use license macro for COPYING files
* Mon Mar 02 2015 David Woodhouse <dwmw2@infradead.org> - 0.1.10-1
- Update to 0.1.10
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.1.8-2
- Rebuilt for Fedora 23 Change
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
* Sun Oct 26 2014 Kalev Lember <kalevlember@gmail.com> - 0.1.8-1
- Update to 0.1.8
- Build with gobject introspection support
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.4-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon May 13 2013 Brian Pepple <bpepple@fedoraproject.org> - 0.1.4-1
- Update to 0.1.4.
- Add examples subpackage.
* Fri May 10 2013 Matthias Clasen <mclasen@redhat.com> - 0.1.3-3
- Split the gstreamer plugins off in subpackages
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Fri Sep 14 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.1.3-1
- Update to 0.1.3.
- Add BR on gstreamer1 packages.
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Mon Apr 23 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.1.2-1
- Update to 0.1.2.
* Mon Jan 16 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.1.1-3
- Rebuild for new gupnp-idg.
* Sun Jan 08 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.1.1-2
- Rebuild for new gcc.
* Wed Dec 7 2011 Brian Pepple <bpepple@fedoraproject.org> - 0.1.1-1
- Update to 0.1.1.
- Drop ppc64 patch. Fixed upstream.
* Tue Aug 16 2011 David Woodhouse <dwmw2@infradead.org> - 0.1.0-5
- Apply portability patch to nice/Makefile.in too. I hate autocrap.
* Tue Aug 16 2011 David Woodhouse <dwmw2@infradead.org> - 0.1.0-4
- Fix non-portable symbol checks in nice/Makefile.am
* Fri Jun 17 2011 Peter Robinson <pbrobinson@gmail.com> - 0.1.0-3
- rebuild for new gupnp/gssdp
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Wed Jan 26 2011 Brian Pepple <bpepple@fedoraproject.org> - 0.1.0-1
- Update to 0.1.0.
- Enable make check.
- Drop buildroot and clean section. No longer needed.
* Wed Aug 4 2010 Brian Pepple <bpepple@fedoraproject.org> - 0.0.13-1
- Update to 0.0.13.
* Wed May 19 2010 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-1
- Update to 0.0.12.
* Fri Mar 19 2010 Brian Pepple <bpepple@fedoraproject.org> - 0.0.11-1
- Update to 0.0.11.
* Wed Dec 16 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.10-2
- Rebuild for new gupnp-igd.
* Mon Nov 9 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.10-1
- Update to 0.0.10.
* Thu Sep 17 2009 Bastien Nocera <bnocera@redhat.com> 0.0.9-2
- Rebuild for new gupnp
* Sun Aug 2 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.9-1
- Update to 0.0.9.
- Drop sha1 patch. Fixed upstream.
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Tue Jul 21 2009 Warren Togami <wtogami@redhat.com> - 0.0.8-2
- stun sha1 patch from upstream to make it work at all
* Sun Jun 21 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.8-1
- Update to 0.0.8.
* Sun Jun 14 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-1
- Update to 0.0.7.
- Add BR on gupnp-igd-devel.
* Mon Apr 13 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-1
- Update to 0.0.6.
* Wed Mar 18 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.5-1
- Update to 0.0.5.
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Sat Dec 27 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.0.4-1
- Initial Fedora spec.