add upstream patches for incorrectly ignored interfaces (#1808410)
This commit is contained in:
parent
eb1814d25c
commit
26683da103
@ -0,0 +1,26 @@
|
|||||||
|
From 4c41bf52ab63c82a29e5b43dbc60c1fd1cf0cba6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jakub Adam <jakub.adam@collabora.com>
|
||||||
|
Date: Fri, 12 Jul 2019 12:15:14 +0200
|
||||||
|
Subject: [PATCH 1/2] interfaces: ignore only interfaces we really want to
|
||||||
|
|
||||||
|
Once an interface got ignored, ALL interfaces coming after it were
|
||||||
|
dropped too.
|
||||||
|
---
|
||||||
|
agent/interfaces.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/agent/interfaces.c b/agent/interfaces.c
|
||||||
|
index 3a3b39c..993c660 100644
|
||||||
|
--- a/agent/interfaces.c
|
||||||
|
+++ b/agent/interfaces.c
|
||||||
|
@@ -304,6 +304,7 @@ nice_interfaces_get_local_ips (gboolean include_loopback)
|
||||||
|
}
|
||||||
|
|
||||||
|
#ifdef IGNORED_IFACE_PREFIX
|
||||||
|
+ ignored = FALSE;
|
||||||
|
for (prefix = ignored_iface_prefix_list; *prefix; prefix++) {
|
||||||
|
if (g_str_has_prefix (ifa->ifa_name, *prefix)) {
|
||||||
|
nice_debug ("Ignoring interface %s as it matches prefix %s",
|
||||||
|
--
|
||||||
|
2.24.1
|
||||||
|
|
@ -0,0 +1,60 @@
|
|||||||
|
From 8f41e9027aea265de019f448e94f9b5c94ab9274 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stefan Becker <chemobejk@gmail.com>
|
||||||
|
Date: Fri, 28 Feb 2020 20:49:21 +0200
|
||||||
|
Subject: [PATCH 2/2] interfaces: ignore only interfaces we really want to (II)
|
||||||
|
|
||||||
|
This improves commit bd4b47813844aa0e68e9074b3ac516c383ca8bab
|
||||||
|
|
||||||
|
There is a second place where this fix is needed.
|
||||||
|
---
|
||||||
|
agent/interfaces.c | 9 +++++----
|
||||||
|
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/agent/interfaces.c b/agent/interfaces.c
|
||||||
|
index 993c660..c0e4a04 100644
|
||||||
|
--- a/agent/interfaces.c
|
||||||
|
+++ b/agent/interfaces.c
|
||||||
|
@@ -262,7 +262,7 @@ nice_interfaces_get_local_ips (gboolean include_loopback)
|
||||||
|
GList *loopbacks = NULL;
|
||||||
|
#ifdef IGNORED_IFACE_PREFIX
|
||||||
|
const gchar **prefix;
|
||||||
|
- gboolean ignored = FALSE;
|
||||||
|
+ gboolean ignored;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
if (getifaddrs (&results) < 0)
|
||||||
|
@@ -310,7 +310,7 @@ nice_interfaces_get_local_ips (gboolean include_loopback)
|
||||||
|
nice_debug ("Ignoring interface %s as it matches prefix %s",
|
||||||
|
ifa->ifa_name, *prefix);
|
||||||
|
g_free (addr_string);
|
||||||
|
- ignored = true;
|
||||||
|
+ ignored = TRUE;
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
@@ -347,7 +347,7 @@ nice_interfaces_get_local_ips (gboolean include_loopback)
|
||||||
|
GList *loopbacks = NULL;
|
||||||
|
#ifdef IGNORED_IFACE_PREFIX
|
||||||
|
const gchar **prefix;
|
||||||
|
- gboolean ignored = FALSE;
|
||||||
|
+ gboolean ignored;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
if ((sockfd = socket (AF_INET, SOCK_DGRAM, IPPROTO_IP)) < 0) {
|
||||||
|
@@ -410,11 +410,12 @@ nice_interfaces_get_local_ips (gboolean include_loopback)
|
||||||
|
}
|
||||||
|
|
||||||
|
#ifdef IGNORED_IFACE_PREFIX
|
||||||
|
+ ignored = FALSE;
|
||||||
|
for (prefix = ignored_iface_prefix_list; *prefix; prefix++) {
|
||||||
|
if (g_str_has_prefix (ifr->ifr_name, *prefix)) {
|
||||||
|
nice_debug ("Ignoring interface %s as it matches prefix %s",
|
||||||
|
ifr->ifr_name, *prefix);
|
||||||
|
- ignored = true;
|
||||||
|
+ ignored = TRUE;
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.24.1
|
||||||
|
|
12
libnice.spec
12
libnice.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: libnice
|
Name: libnice
|
||||||
Version: 0.1.16
|
Version: 0.1.16
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: GLib ICE implementation
|
Summary: GLib ICE implementation
|
||||||
|
|
||||||
License: LGPLv2 and MPLv1.1
|
License: LGPLv2 and MPLv1.1
|
||||||
@ -18,6 +18,11 @@ Patch1: libnice-0.1.14-tests-koji.patch
|
|||||||
# - issues #64 & #87
|
# - issues #64 & #87
|
||||||
Patch2: libnice-0.1.16-16-gb998547.patch
|
Patch2: libnice-0.1.16-16-gb998547.patch
|
||||||
|
|
||||||
|
# upstream https://gitlab.freedesktop.org/libnice/libnice/-/merge_requests/66
|
||||||
|
# upstream https://gitlab.freedesktop.org/libnice/libnice/-/merge_requests/107
|
||||||
|
Patch3: 0001-interfaces-ignore-only-interfaces-we-really-want-to.patch
|
||||||
|
Patch4: 0002-interfaces-ignore-only-interfaces-we-really-want-to.patch
|
||||||
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
@ -74,6 +79,8 @@ developing applications that use %{name}.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
chmod 0755 scripts/valgrind-test-driver
|
chmod 0755 scripts/valgrind-test-driver
|
||||||
|
|
||||||
# disable test-new-trickle, which sometimes hangs indefinitely, and
|
# disable test-new-trickle, which sometimes hangs indefinitely, and
|
||||||
@ -147,6 +154,9 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 28 2020 Stefan Becker <chemobejk@gmail.com> - 0.1.16-8
|
||||||
|
- add upstream patches for incorrectly ignored interfaces (#1808410)
|
||||||
|
|
||||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.16-7
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.16-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user