Fix file conflicts with libnet-devel

Trying to install libnet-devel.x86_64 and libnet-devel.i686 fails with

  file /usr/bin/libnet-config conflicts between attempted installs of libnet-devel-1.2-2.fc34.x86_64 and libnet-devel-1.2-2.fc34.i686

The file libnet-config contains for x86_64 the string 'lib64' and for
i686 'lib' which makes the devel packages not installable at the same
time.

Running 'libnet-config --libs' returns '-L/usr/lib64 -lnet' for x86_64
and without '64' for i686. As that is both the default location for
libraries it can be omitted which this patch does.

With this patch applied 'libnet-config --libs' returns just '-lnet'.

Resolves: rhbz#1915836

Signed-off-by: Adrian Reber <adrian@lisas.de>
This commit is contained in:
Adrian Reber 2021-04-08 14:32:05 +02:00
parent 61bdfaafe9
commit c49cf2653a
No known key found for this signature in database
GPG Key ID: 82C9378ED3C4906A
2 changed files with 22 additions and 1 deletions

16
libnet-config.patch Normal file
View File

@ -0,0 +1,16 @@
--- libnet-1.2/libnet-config.in.orig 2021-04-08 14:13:20.095564421 +0200
+++ libnet-1.2/libnet-config.in 2021-04-08 14:13:42.038730961 +0200
@@ -12,12 +12,11 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
-libdir=@libdir@
includedir=@includedir@
libnet_defines="@PKG_CONFIG_DEFINES@"
libnet_cflags="-I${includedir} @PKG_CONFIG_CFLAGS@"
-libnet_libs="-L${libdir} @PKG_CONFIG_LIBS@ -lnet"
+libnet_libs="@PKG_CONFIG_LIBS@ -lnet"
usage()
{

View File

@ -1,10 +1,11 @@
Summary: C library for portable packet creation and injection Summary: C library for portable packet creation and injection
Name: libnet Name: libnet
Version: 1.2 Version: 1.2
Release: 2%{?dist} Release: 3%{?dist}
License: BSD License: BSD
URL: https://github.com/libnet/libnet URL: https://github.com/libnet/libnet
Source0: https://github.com/libnet/libnet/releases/download/v%{version}/%{name}-%{version}.tar.gz Source0: https://github.com/libnet/libnet/releases/download/v%{version}/%{name}-%{version}.tar.gz
Patch0: libnet-config.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: make BuildRequires: make
BuildRequires: %{_bindir}/pod2man BuildRequires: %{_bindir}/pod2man
@ -44,6 +45,7 @@ developing applications that use libnet.
%prep %prep
%setup -q %setup -q
%patch0 -p1
# Avoid library soname bump (https://github.com/libnet/libnet/issues/115) # Avoid library soname bump (https://github.com/libnet/libnet/issues/115)
sed -e 's/-version-info 9:0:0/-version-info 9:0:8/' -i src/Makefile.{am,in} sed -e 's/-version-info 9:0:0/-version-info 9:0:8/' -i src/Makefile.{am,in}
@ -93,6 +95,9 @@ done
%endif %endif
%changelog %changelog
* Thu Apr 08 2021 Adrian Reber <adrian@lisas.de> - 1.2-3
- Fix file conflicts with libnet-devel
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-2 * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild