Upgrade to 1.1.4

This commit is contained in:
Robert Scheck 2009-06-11 11:58:59 +00:00
parent f1f0b27b66
commit 5d341294f3
4 changed files with 7 additions and 139 deletions

View File

@ -1 +1 @@
libnet-1.1.3.tar.gz
libnet-1.1.4.tar.gz

View File

@ -1,126 +0,0 @@
Backport by Robert Scheck <robert@fedoraproject.org> for libnet <= 1.1.3, which merges the
upstream fix for the HAVE_CONFIG_H issue from the not-yet released libnet 1.1.4 back.
--- libnet-1.1.3/doc/html/libnet_8h-source.html 2009-05-12 02:22:06.000000000 +0200
+++ libnet-1.1.4/doc/html/libnet_8h-source.html 2009-06-05 02:34:53.000000000 +0200
@@ -80,7 +80,7 @@
<a name="l00090"></a>00090 <span class="preprocessor">#include &lt;winsock2.h&gt;</span>
<a name="l00091"></a>00091 <span class="preprocessor">#include &lt;win32/in_systm.h&gt;</span>
<a name="l00092"></a>00092 <span class="preprocessor">#endif </span><span class="comment">/* __WIN32__ */</span>
-<a name="l00093"></a>00093 <span class="preprocessor">#if !(__linux__) &amp;&amp; !(__WIN32__) &amp;&amp; !(__APPLE__) &amp;&amp; !(__CYGWIN__)</span>
+<a name="l00093"></a>00093 <span class="preprocessor">#if !(__linux__) &amp;&amp; !(__WIN32__) &amp;&amp; !(__APPLE__) &amp;&amp; !(__CYGWIN__) &amp;&amp; !(__GNU__)</span>
<a name="l00094"></a>00094 <span class="preprocessor"></span><span class="preprocessor">#include &lt;netinet/ip_var.h&gt;</span>
<a name="l00095"></a>00095 <span class="preprocessor">#else </span><span class="comment">/* __linux__ */</span>
<a name="l00096"></a>00096 <span class="preprocessor">#if (HAVE_NET_ETHERNET_H)</span>
--- libnet-1.1.3/doc/html/libnet-types_8h-source.html 2009-05-12 02:22:06.000000000 +0200
+++ libnet-1.1.4/doc/html/libnet-types_8h-source.html 2009-06-05 02:34:53.000000000 +0200
@@ -45,28 +45,21 @@
<a name="l00032"></a>00032 <span class="preprocessor">#ifndef __LIBNET_TYPES_H</span>
<a name="l00033"></a>00033 <span class="preprocessor"></span><span class="preprocessor">#define __LIBNET_TYPES_H</span>
<a name="l00034"></a>00034 <span class="preprocessor"></span>
-<a name="l00035"></a>00035 <span class="preprocessor">#ifdef HAVE_CONFIG_H</span>
-<a name="l00036"></a>00036 <span class="preprocessor"></span><span class="preprocessor">#include "../config.h"</span>
-<a name="l00037"></a>00037 <span class="preprocessor">#endif</span>
-<a name="l00038"></a>00038 <span class="preprocessor"></span>
-<a name="l00039"></a>00039 <span class="comment">/* Solaris has messed up POSIX nomenclature for int types */</span>
-<a name="l00040"></a>00040 <span class="preprocessor">#if HAVE_SOLARIS</span>
-<a name="l00041"></a>00041 <span class="preprocessor"></span><span class="preprocessor">#include &lt;inttypes.h&gt;</span>
-<a name="l00042"></a>00042 <span class="preprocessor">#else</span>
-<a name="l00043"></a>00043 <span class="preprocessor"></span><span class="preprocessor">#include &lt;stdint.h&gt;</span>
+<a name="l00035"></a>00035 <span class="preprocessor">#if (__sun__ &amp;&amp; __svr4__)</span>
+<a name="l00036"></a>00036 <span class="preprocessor"></span><span class="comment">/* libnet should be using the standard type names, but in the short term</span>
+<a name="l00037"></a>00037 <span class="comment"> * define our non-standard type names in terms of the standard names.</span>
+<a name="l00038"></a>00038 <span class="comment"> */</span>
+<a name="l00039"></a>00039 <span class="preprocessor">#include &lt;inttypes.h&gt;</span>
+<a name="l00040"></a>00040 <span class="keyword">typedef</span> uint8_t u_int8_t;
+<a name="l00041"></a>00041 <span class="keyword">typedef</span> uint16_t u_int16_t;
+<a name="l00042"></a>00042 <span class="keyword">typedef</span> uint32_t u_int32_t;
+<a name="l00043"></a>00043 <span class="keyword">typedef</span> uint64_t u_int64_t;
<a name="l00044"></a>00044 <span class="preprocessor">#endif</span>
<a name="l00045"></a>00045 <span class="preprocessor"></span>
-<a name="l00046"></a>00046 <span class="comment">/*</span>
-<a name="l00047"></a>00047 <span class="comment">typedef uint8_t u_int8_t;</span>
-<a name="l00048"></a>00048 <span class="comment">typedef uint16_t u_int16_t;</span>
-<a name="l00049"></a>00049 <span class="comment">typedef uint32_t u_int32_t;</span>
-<a name="l00050"></a>00050 <span class="comment">typedef uint64_t u_int64_t;</span>
-<a name="l00051"></a>00051 <span class="comment">*/</span>
-<a name="l00052"></a>00052
-<a name="l00053"></a>00053 <span class="preprocessor">#endif </span><span class="comment">/* __LIBNET_TYPES_H */</span>
-<a name="l00054"></a>00054
-<a name="l00055"></a>00055 <span class="comment">/* EOF */</span>
-</pre></div><hr size="1"><address style="text-align: right;"><small>Generated on Mon May 11 17:22:06 2009 for libnet by&nbsp;
+<a name="l00046"></a>00046 <span class="preprocessor">#endif </span><span class="comment">/* __LIBNET_TYPES_H */</span>
+<a name="l00047"></a>00047
+<a name="l00048"></a>00048 <span class="comment">/* EOF */</span>
+</pre></div><hr size="1"><address style="text-align: right;"><small>Generated on Thu Jun 4 17:34:53 2009 for libnet by&nbsp;
<a href="http://www.doxygen.org/index.html">
<img src="doxygen.png" alt="doxygen" align="middle" border="0"></a> 1.5.3 </small></address>
</body>
--- libnet-1.1.3/include/libnet/libnet-types.h 2009-04-29 00:53:25.000000000 +0200
+++ libnet-1.1.4/include/libnet/libnet-types.h 2009-06-05 02:31:36.000000000 +0200
@@ -32,23 +32,16 @@
#ifndef __LIBNET_TYPES_H
#define __LIBNET_TYPES_H
-#ifdef HAVE_CONFIG_H
-#include "../config.h"
-#endif
-
-/* Solaris has messed up POSIX nomenclature for int types */
-#if HAVE_SOLARIS
+#if (__sun__ && __svr4__)
+/* libnet should be using the standard type names, but in the short term
+ * define our non-standard type names in terms of the standard names.
+ */
#include <inttypes.h>
-#else
-#include <stdint.h>
-#endif
-
-/*
typedef uint8_t u_int8_t;
typedef uint16_t u_int16_t;
typedef uint32_t u_int32_t;
typedef uint64_t u_int64_t;
-*/
+#endif
#endif /* __LIBNET_TYPES_H */
--- libnet-1.1.3/include/libnet.h 2009-05-12 02:21:33.000000000 +0200
+++ libnet-1.1.4/include/libnet.h 2009-06-05 02:31:36.000000000 +0200
@@ -90,7 +90,7 @@
#include <winsock2.h>
#include <win32/in_systm.h>
#endif /* __WIN32__ */
-#if !(__linux__) && !(__WIN32__) && !(__APPLE__) && !(__CYGWIN__)
+#if !(__linux__) && !(__WIN32__) && !(__APPLE__) && !(__CYGWIN__) && !(__GNU__)
#include <netinet/ip_var.h>
#else /* __linux__ */
#if (HAVE_NET_ETHERNET_H)
--- libnet-1.1.3/include/libnet.h.in 2009-03-31 02:39:14.000000000 +0200
+++ libnet-1.1.4/include/libnet.h.in 2009-06-05 02:09:18.000000000 +0200
@@ -90,7 +90,7 @@
#include <winsock2.h>
#include <win32/in_systm.h>
#endif /* __WIN32__ */
-#if !(__linux__) && !(__WIN32__) && !(__APPLE__) && !(__CYGWIN__)
+#if !(__linux__) && !(__WIN32__) && !(__APPLE__) && !(__CYGWIN__) && !(__GNU__)
#include <netinet/ip_var.h>
#else /* __linux__ */
#if (HAVE_NET_ETHERNET_H)
--- libnet-1.1.3/README 2009-05-01 02:12:24.000000000 +0200
+++ libnet-1.1.4/README 2009-05-12 21:26:09.000000000 +0200
@@ -5,9 +5,10 @@
===============================================================================
-libnet has become unmaintained at packetfactory, and it's maintainer is unreachable.
+libnet has become unmaintained at packetfactory.net, and it's author is unreachable.
-This fork is a release of the 1.1.3 release candidate, bug fixed.
+This version was forked from the 1.1.3 release candidate, then bug fixed,
+actively maintained, and rereleased.
Home page and more info is available at:

View File

@ -1,12 +1,11 @@
Summary: C library for portable packet creation and injection
Name: libnet
Version: 1.1.3
Release: 2%{?dist}
Version: 1.1.4
Release: 1%{?dist}
License: BSD
Group: System Environment/Libraries
URL: http://www.sourceforge.net/projects/libnet-dev/
Source: http://downloads.sourceforge.net/libnet-dev/%{name}-%{version}.tar.gz
Patch0: libnet-1.1.3-backport.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
@ -30,7 +29,6 @@ and sample test code for more detailed information.
%prep
%setup -q
%patch0 -p1
# Keep the sample directory untouched by make
rm -rf __dist_sample
@ -59,13 +57,6 @@ mv -f __dist_sample/sample/libnet_test.h{.new,}
# Remove makefile relics from documentation
rm -f doc/html/Makefile*
# Correct wrong line endings at CHANGELOG and CONTRIB
for file in CHANGELOG CONTRIB; do
sed -e 's/\r$//' doc/$file > doc/$file.new
touch -c -r doc/$file doc/$file.new
mv -f doc/$file.new doc/$file
done
%clean
rm -rf $RPM_BUILD_ROOT
@ -89,6 +80,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/%{name}*.3*
%changelog
* Thu Jun 11 2009 Robert Scheck <robert@fedoraproject.org> 1.1.4-1
- Upgrade to 1.1.4
* Sat Jun 06 2009 Robert Scheck <robert@fedoraproject.org> 1.1.3-2
- Added upstream patch to solve HAVE_CONFIG_H (#501633, #502400)

View File

@ -1 +1 @@
314e1b15286200d8601ad98333be14f4 libnet-1.1.3.tar.gz
c5e06418a89cc4209f677a776a798fd9 libnet-1.1.4.tar.gz