Fix pc file path and ndptool -v argument
This commit is contained in:
parent
0555a02a9c
commit
bd20f7bbf6
27
0001-ndptool-fix-v-argument.patch
Normal file
27
0001-ndptool-fix-v-argument.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 776fb96b15a2c0c2b6fc5398939dce10630e1256 Mon Sep 17 00:00:00 2001
|
||||
From: Yanko Kaneti <yaneti@declera.com>
|
||||
Date: Thu, 8 Aug 2013 12:40:42 +0300
|
||||
Subject: [PATCH 1/2] ndptool: fix -v argument
|
||||
|
||||
Signed-off-by: Yanko Kaneti <yaneti@declera.com>
|
||||
Signed-off-by: Jiri Pirko <jiri@resnulli.us>
|
||||
---
|
||||
utils/ndptool.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/utils/ndptool.c b/utils/ndptool.c
|
||||
index d0764ce..120ffdc 100644
|
||||
--- a/utils/ndptool.c
|
||||
+++ b/utils/ndptool.c
|
||||
@@ -397,7 +397,7 @@ int main(int argc, char **argv)
|
||||
int err;
|
||||
int res = EXIT_FAILURE;
|
||||
|
||||
- while ((opt = getopt_long(argc, argv, "hp:i:t:",
|
||||
+ while ((opt = getopt_long(argc, argv, "hvt:i:",
|
||||
long_options, NULL)) >= 0) {
|
||||
|
||||
switch(opt) {
|
||||
--
|
||||
1.8.3.1
|
||||
|
23
0002-fix-cflags-path-in-pc-file.patch
Normal file
23
0002-fix-cflags-path-in-pc-file.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From d2247aae11c80a4e3c0084d9294c858bdcaf26c7 Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Pirko <jiri@resnulli.us>
|
||||
Date: Fri, 16 Aug 2013 11:21:14 +0200
|
||||
Subject: [PATCH 2/2] fix cflags path in pc file
|
||||
|
||||
Signed-off-by: Jiri Pirko <jiri@resnulli.us>
|
||||
---
|
||||
libndp/libndp.pc.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libndp/libndp.pc.in b/libndp/libndp.pc.in
|
||||
index f486edf..62d630d 100644
|
||||
--- a/libndp/libndp.pc.in
|
||||
+++ b/libndp/libndp.pc.in
|
||||
@@ -7,4 +7,4 @@ Name: libndp
|
||||
Description: Neighbour discovery library.
|
||||
Version: @PACKAGE_VERSION@
|
||||
Libs: -L${libdir} -lndp
|
||||
-Cflags: -I${includedir}/ndp.h
|
||||
+Cflags: -I${includedir}
|
||||
--
|
||||
1.8.3.1
|
||||
|
11
libndp.spec
11
libndp.spec
@ -1,12 +1,15 @@
|
||||
Name: libndp
|
||||
Version: 1.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Library for Neighbor Discovery Protocol
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://www.libndp.org/
|
||||
Source: http://www.libndp.org/files/libndp-%{version}.tar.gz
|
||||
|
||||
Patch0: 0001-ndptool-fix-v-argument.patch
|
||||
Patch1: 0002-fix-cflags-path-in-pc-file.patch
|
||||
|
||||
%description
|
||||
This package contains a library which provides a wrapper
|
||||
for IPv6 Neighbor Discovery Protocol. It also provides a tool
|
||||
@ -23,6 +26,8 @@ necessary for developing programs using libndp.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .ndptool-v
|
||||
%patch1 -p1 -b .fix-pc-file
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
@ -48,6 +53,10 @@ find $RPM_BUILD_ROOT -name \*.la -delete
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
%changelog
|
||||
* Fri Sep 13 2013 Dan Williams <dcbw@redhat.com> - 1.0-2
|
||||
- Fix .pc file includes path
|
||||
- Fix ndptool -v argument
|
||||
|
||||
* Thu Aug 08 2013 Jiri Pirko <jpirko@redhat.com> - 1.0-1
|
||||
- Update to 1.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user