Merge branch 'master' into f20

Signed-off-by: Jiri Pirko <jiri@resnulli.us>

Conflicts:
	libndp.spec
This commit is contained in:
Jiri Pirko 2013-10-15 14:54:35 +02:00
commit 8a5d78c10b
5 changed files with 13 additions and 53 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/libndp-20130504gitca3c399.tar.gz /libndp-20130504gitca3c399.tar.gz
/libndp-20130607git39e1f53.tar.gz /libndp-20130607git39e1f53.tar.gz
/libndp-1.0.tar.gz /libndp-1.0.tar.gz
/libndp-1.2.tar.gz

View File

@ -1,27 +0,0 @@
From 776fb96b15a2c0c2b6fc5398939dce10630e1256 Mon Sep 17 00:00:00 2001
From: Yanko Kaneti <yaneti@declera.com>
Date: Thu, 8 Aug 2013 12:40:42 +0300
Subject: [PATCH 1/2] ndptool: fix -v argument
Signed-off-by: Yanko Kaneti <yaneti@declera.com>
Signed-off-by: Jiri Pirko <jiri@resnulli.us>
---
utils/ndptool.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/utils/ndptool.c b/utils/ndptool.c
index d0764ce..120ffdc 100644
--- a/utils/ndptool.c
+++ b/utils/ndptool.c
@@ -397,7 +397,7 @@ int main(int argc, char **argv)
int err;
int res = EXIT_FAILURE;
- while ((opt = getopt_long(argc, argv, "hp:i:t:",
+ while ((opt = getopt_long(argc, argv, "hvt:i:",
long_options, NULL)) >= 0) {
switch(opt) {
--
1.8.3.1

View File

@ -1,23 +0,0 @@
From d2247aae11c80a4e3c0084d9294c858bdcaf26c7 Mon Sep 17 00:00:00 2001
From: Jiri Pirko <jiri@resnulli.us>
Date: Fri, 16 Aug 2013 11:21:14 +0200
Subject: [PATCH 2/2] fix cflags path in pc file
Signed-off-by: Jiri Pirko <jiri@resnulli.us>
---
libndp/libndp.pc.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libndp/libndp.pc.in b/libndp/libndp.pc.in
index f486edf..62d630d 100644
--- a/libndp/libndp.pc.in
+++ b/libndp/libndp.pc.in
@@ -7,4 +7,4 @@ Name: libndp
Description: Neighbour discovery library.
Version: @PACKAGE_VERSION@
Libs: -L${libdir} -lndp
-Cflags: -I${includedir}/ndp.h
+Cflags: -I${includedir}
--
1.8.3.1

View File

@ -1,6 +1,6 @@
Name: libndp Name: libndp
Version: 1.0 Version: 1.2
Release: 2%{?dist} Release: 1%{?dist}
Summary: Library for Neighbor Discovery Protocol Summary: Library for Neighbor Discovery Protocol
Group: System Environment/Libraries Group: System Environment/Libraries
License: LGPLv2+ License: LGPLv2+
@ -53,6 +53,15 @@ find $RPM_BUILD_ROOT -name \*.la -delete
%{_libdir}/pkgconfig/*.pc %{_libdir}/pkgconfig/*.pc
%changelog %changelog
* Tue Oct 15 2013 Jiri Pirko <jpirko@redhat.com> - 1.2-1
- Update to 1.2
- libndp: silently ignore packets with optlen 0
- libndp: fix processing for larger options
- libndp: do not fail on receiving non-ndp packets
* Fri Oct 04 2013 Jiri Pirko <jpirko@redhat.com> - 1.1-1
- Update to 1.1
* Fri Sep 13 2013 Dan Williams <dcbw@redhat.com> - 1.0-2 * Fri Sep 13 2013 Dan Williams <dcbw@redhat.com> - 1.0-2
- Fix .pc file includes path - Fix .pc file includes path
- Fix ndptool -v argument - Fix ndptool -v argument

View File

@ -1 +1 @@
b79429fa6e26994c1aef33d7115f7b10 libndp-1.0.tar.gz f94d2a72bd3e2c58bf2dfd827c9681a8 libndp-1.2.tar.gz