- Update device list from CVS and fix the build
This commit is contained in:
parent
82813e354f
commit
ad5bba8dea
@ -1,11 +1,22 @@
|
|||||||
Index: src/music-players.h
|
--- libmtp-0.3.3/src/music-players.h.n82 2008-09-24 00:02:23.000000000 +0100
|
||||||
===================================================================
|
+++ libmtp-0.3.3/src/music-players.h 2008-10-25 15:38:13.000000000 +0100
|
||||||
RCS file: /cvsroot/libmtp/libmtp/src/music-players.h,v
|
@@ -438,7 +441,8 @@
|
||||||
retrieving revision 1.84
|
* This is actually a camera, but it has a Microsoft device descriptor
|
||||||
diff -u -p -u -p -r1.84 music-players.h
|
* and reports itself as supporting the MTP extension.
|
||||||
--- src/music-players.h 24 Oct 2008 20:52:48 -0000 1.84
|
*/
|
||||||
+++ src/music-players.h 25 Oct 2008 14:19:44 -0000
|
- { "Canon", 0x04a9, "PowerShot A640 (PTP/MTP mode)", 0x3139, DEVICE_FLAG_NONE },
|
||||||
@@ -468,6 +468,14 @@
|
+ { "Canon", 0x04a9, "PowerShot A640 (PTP/MTP mode)", 0x3139,
|
||||||
|
+ DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST_ALL },
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Nokia
|
||||||
|
@@ -458,10 +462,20 @@
|
||||||
|
{ "Nokia", 0x0421, "5310 XpressMusic", 0x006c, DEVICE_FLAG_NONE },
|
||||||
|
// From: robin (AT) headbank D0Tco DOTuk
|
||||||
|
{ "Nokia", 0x0421, "N95 Mobile Phone 8GB", 0x006e, DEVICE_FLAG_NONE },
|
||||||
|
+ // From Bastien Nocera <hadess@hadess.net>
|
||||||
|
+ { "Nokia", 0x0421, "N82 Mobile Phone", 0x0074, DEVICE_FLAG_NONE },
|
||||||
|
// From: danielw
|
||||||
{ "Nokia", 0x0421, "E71", 0x00e4, DEVICE_FLAG_NONE },
|
{ "Nokia", 0x0421, "E71", 0x00e4, DEVICE_FLAG_NONE },
|
||||||
// From: Laurent Bigonville <bigon@users.sourceforge.net>
|
// From: Laurent Bigonville <bigon@users.sourceforge.net>
|
||||||
{ "Nokia", 0x0421, "E66", 0x00e5, DEVICE_FLAG_NONE },
|
{ "Nokia", 0x0421, "E66", 0x00e5, DEVICE_FLAG_NONE },
|
||||||
@ -20,7 +31,7 @@ diff -u -p -u -p -r1.84 music-players.h
|
|||||||
// From: Christian Rusa <kristous@users.sourceforge.net>
|
// From: Christian Rusa <kristous@users.sourceforge.net>
|
||||||
{ "Nokia", 0x0421, "5700 XpressMusic Mobile Phone", 0x04b4, DEVICE_FLAG_NONE },
|
{ "Nokia", 0x0421, "5700 XpressMusic Mobile Phone", 0x04b4, DEVICE_FLAG_NONE },
|
||||||
// From: Mitchell Hicks <mitchix@yahoo.com>
|
// From: Mitchell Hicks <mitchix@yahoo.com>
|
||||||
@@ -476,6 +484,8 @@
|
@@ -470,6 +484,8 @@
|
||||||
{ "Nokia", 0x0421, "N73 Mobile Phone", 0x04d1, DEVICE_FLAG_UNLOAD_DRIVER },
|
{ "Nokia", 0x0421, "N73 Mobile Phone", 0x04d1, DEVICE_FLAG_UNLOAD_DRIVER },
|
||||||
// From Swapan <swapan@yahoo.com>
|
// From Swapan <swapan@yahoo.com>
|
||||||
{ "Nokia", 0x0421, "N75 Mobile Phone", 0x04e1, DEVICE_FLAG_NONE },
|
{ "Nokia", 0x0421, "N75 Mobile Phone", 0x04e1, DEVICE_FLAG_NONE },
|
||||||
@ -29,3 +40,46 @@ diff -u -p -u -p -r1.84 music-players.h
|
|||||||
// From Anonymous Sourceforge User
|
// From Anonymous Sourceforge User
|
||||||
{ "Nokia", 0x0421, "N95 Mobile Phone", 0x04ef, DEVICE_FLAG_NONE },
|
{ "Nokia", 0x0421, "N95 Mobile Phone", 0x04ef, DEVICE_FLAG_NONE },
|
||||||
// From: Pat Nicholls <pat@patandannie.co.uk>
|
// From: Pat Nicholls <pat@patandannie.co.uk>
|
||||||
|
@@ -584,25 +600,35 @@
|
||||||
|
// Reported by Jean-Marc Bourguet <jm@bourguet.org>
|
||||||
|
{ "Sony", 0x054c, "Walkman NWZ-S716F", 0x035a, DEVICE_FLAG_UNLOAD_DRIVER },
|
||||||
|
// Reported by Anon SF User / Anthon van der Neut <avanderneut@avid.com>
|
||||||
|
- { "Sony", 0x054c, "Walkman NWZ-A828/NWZ-A829", 0x035b, DEVICE_FLAG_UNLOAD_DRIVER },
|
||||||
|
+ { "Sony", 0x054c, "Walkman NWZ-A826/NWZ-A828/NWZ-A829", 0x035b, DEVICE_FLAG_UNLOAD_DRIVER },
|
||||||
|
// Reported by Niek Klaverstijn <niekez@users.sourceforge.net>
|
||||||
|
{ "Sony", 0x054c, "Walkman NWZ-A728B", 0x035c, DEVICE_FLAG_UNLOAD_DRIVER },
|
||||||
|
+ // Reported by Mehdi AMINI <mehdi.amini - at - ulp.u-strasbg.fr>
|
||||||
|
+ { "Sony", 0x054c, "Walkman NWZ-B135", 0x036e, DEVICE_FLAG_UNLOAD_DRIVER },
|
||||||
|
+ // Reported by Marco Filipe Nunes Soares Abrantes Pereira <marcopereira@ua.pt>
|
||||||
|
+ { "Sony", 0x054c, "Walkman NWZ-S638F", 0x038e, DEVICE_FLAG_UNLOAD_DRIVER },
|
||||||
|
+
|
||||||
|
|
||||||
|
/*
|
||||||
|
* SonyEricsson
|
||||||
|
+ * These initially seemed to support GetObjPropList but later revisions
|
||||||
|
+ * of the firmware seem to have broken it, so all are flagged as broken
|
||||||
|
+ * for now.
|
||||||
|
*/
|
||||||
|
// Reported by Øyvind Stegard <stegaro@users.sourceforge.net>
|
||||||
|
- { "SonyEricsson", 0x0fce, "K850i", 0x0075, DEVICE_FLAG_NONE },
|
||||||
|
+ { "SonyEricsson", 0x0fce, "K850i", 0x0075, DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST },
|
||||||
|
// Reported by Michael Eriksson
|
||||||
|
- { "SonyEricsson", 0x0fce, "W910", 0x0076, DEVICE_FLAG_NONE },
|
||||||
|
+ { "SonyEricsson", 0x0fce, "W910", 0x0076, DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST },
|
||||||
|
// Reported by Zack <zackdvd@users.sourceforge.net>
|
||||||
|
- { "SonyEricsson", 0x0fce, "W890i", 0x00b3, DEVICE_FLAG_NONE },
|
||||||
|
+ { "SonyEricsson", 0x0fce, "W890i", 0x00b3, DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST },
|
||||||
|
// Reported by robert dot ahlskog at gmail
|
||||||
|
- { "SonyEricsson", 0x0fce, "W760i", 0x00c6, DEVICE_FLAG_NONE },
|
||||||
|
+ { "SonyEricsson", 0x0fce, "W760i", 0x00c6, DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST },
|
||||||
|
// Reported by Linus Åkesson <linusakesson@users.sourceforge.net>
|
||||||
|
- { "SonyEricsson", 0x0fce, "C902", 0x00d4, DEVICE_FLAG_NONE },
|
||||||
|
+ { "SonyEricsson", 0x0fce, "C902", 0x00d4, DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST },
|
||||||
|
// Reported by an anonymous SourceForge user
|
||||||
|
- { "SonyEricsson", 0x0fce, "C702", 0x00d9, DEVICE_FLAG_NONE },
|
||||||
|
+ { "SonyEricsson", 0x0fce, "C702", 0x00d9, DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST },
|
||||||
|
+ // Reported by Christian Zuckschwerdt <christian@zuckschwerdt.org>
|
||||||
|
+ { "SonyEricsson", 0x0fce, "W980", 0x00da, DEVICE_FLAG_BROKEN_MTPGETOBJPROPLIST },
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Motorola
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
Index: src/music-players.h
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/libmtp/libmtp/src/music-players.h,v
|
|
||||||
retrieving revision 1.83
|
|
||||||
diff -u -p -u -p -r1.83 music-players.h
|
|
||||||
--- src/music-players.h 21 Oct 2008 14:24:24 -0000 1.83
|
|
||||||
+++ src/music-players.h 24 Oct 2008 19:57:02 -0000
|
|
||||||
@@ -474,6 +474,8 @@
|
|
||||||
{ "Nokia", 0x0421, "N73 Mobile Phone", 0x04d1, DEVICE_FLAG_UNLOAD_DRIVER },
|
|
||||||
// From Swapan <swapan@yahoo.com>
|
|
||||||
{ "Nokia", 0x0421, "N75 Mobile Phone", 0x04e1, DEVICE_FLAG_NONE },
|
|
||||||
+ // From Bastien Nocera <hadess@hadess.net>
|
|
||||||
+ { "Nokia", 0x0421, "N82 Mobile Phone", 0x0074, DEVICE_FLAG_NONE },
|
|
||||||
// From Anonymous Sourceforge User
|
|
||||||
{ "Nokia", 0x0421, "N95 Mobile Phone", 0x04ef, DEVICE_FLAG_NONE },
|
|
||||||
// From: Pat Nicholls <pat@patandannie.co.uk>
|
|
11
libmtp.spec
11
libmtp.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: libmtp
|
Name: libmtp
|
||||||
Version: 0.3.3
|
Version: 0.3.3
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: A software library for MTP media players
|
Summary: A software library for MTP media players
|
||||||
URL: http://libmtp.sourceforge.net/
|
URL: http://libmtp.sourceforge.net/
|
||||||
|
|
||||||
@ -17,8 +17,7 @@ BuildRequires: libusb-devel
|
|||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
|
|
||||||
Patch0: libmtp-0.2.6.1-simpler-rules.patch
|
Patch0: libmtp-0.2.6.1-simpler-rules.patch
|
||||||
Patch1: libmtp-nokia-n82.patch
|
Patch1: libmtp-add-more-nokia-phones.patch
|
||||||
Patch2: libmtp-add-more-nokia-phones.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This package provides a software library for communicating with MTP
|
This package provides a software library for communicating with MTP
|
||||||
@ -48,8 +47,7 @@ library for MTP media players.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .rules
|
%patch0 -p1 -b .rules
|
||||||
%patch1 -p0 -b .n82
|
%patch1 -p1 -b .more-nokia
|
||||||
%patch2 -p0 -b .more-nokia
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static --program-prefix=mtp-
|
%configure --disable-static --program-prefix=mtp-
|
||||||
@ -103,6 +101,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 25 2008 - Bastien Nocera <bnocera@redhat.com> - 0.3.3-4
|
||||||
|
- Update device list from CVS and fix the build
|
||||||
|
|
||||||
* Sat Oct 25 2008 - Bastien Nocera <bnocera@redhat.com> - 0.3.3-3
|
* Sat Oct 25 2008 - Bastien Nocera <bnocera@redhat.com> - 0.3.3-3
|
||||||
- Add support for more Nokia phones from their WMP10 drivers
|
- Add support for more Nokia phones from their WMP10 drivers
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user