New upstream version fixing the patched issues too.
This commit is contained in:
parent
8188950807
commit
32a1f40a98
@ -1 +1 @@
|
|||||||
libmtp-0.1.5.tar.gz
|
libmtp-0.2.0.tar.gz
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
--- libmtp-0.1.5/examples/hotplug.c.udevrules 2007-07-30 09:40:11.000000000 +0200
|
|
||||||
+++ libmtp-0.1.5/examples/hotplug.c 2007-07-30 09:44:32.000000000 +0200
|
|
||||||
@@ -76,7 +76,11 @@
|
|
||||||
case style_udev:
|
|
||||||
printf("# UDEV-style hotplug map for libmtp\n");
|
|
||||||
printf("# Put this file in /etc/udev/rules.d\n\n");
|
|
||||||
- printf("SUBSYSTEM!=\"usb_device\", ACTION!=\"add\", GOTO=\"libmtp_rules_end\"\n\n");
|
|
||||||
+ printf("ACTION!=\"add\", GOTO=\"libmtp_rules_end\"\n"
|
|
||||||
+ "SUBSYSTEM==\"usb\", GOTO=\"libmtp_rules\"\n"
|
|
||||||
+ "SUBSYSTEM==\"usb_device\", GOTO=\"libmtp_rules\"\n\n"
|
|
||||||
+ "GOTO=\"libmtp_rules_end\"\n\n"
|
|
||||||
+ "LABEL=\"libmtp_rules\"\n\n");
|
|
||||||
break;
|
|
||||||
case style_usbmap:
|
|
||||||
printf("# This usermap will call the script \"libmtp.sh\" whenever a known MTP device is attached.\n\n");
|
|
||||||
@@ -103,7 +107,7 @@
|
|
||||||
} else {
|
|
||||||
action = default_udev_action;
|
|
||||||
}
|
|
||||||
- printf("SYSFS{idVendor}==\"%04x\", SYSFS{idProduct}==\"%04x\", %s\n", entry->vendor_id, entry->product_id, action);
|
|
||||||
+ printf("ATTR{idVendor}==\"%04x\", ATTR{idProduct}==\"%04x\", %s\n", entry->vendor_id, entry->product_id, action);
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
case style_usbmap:
|
|
20
libmtp.spec
20
libmtp.spec
@ -1,25 +1,15 @@
|
|||||||
# SPEC file for libmtp, primary target is the Fedora Extras
|
# SPEC file for libmtp, primary target is the Fedora Extras
|
||||||
# RPM repository.
|
# RPM repository.
|
||||||
#
|
|
||||||
# For testing a certain distribution, rely on macros that
|
|
||||||
# you define in your ".rpmmacros" file. For example, for
|
|
||||||
# test building a Fedora Extras package, define the following
|
|
||||||
# two macros in .rpmmacros:
|
|
||||||
#
|
|
||||||
# %dist .fc6
|
|
||||||
# %fedora 6
|
|
||||||
#
|
|
||||||
|
|
||||||
Name: libmtp
|
Name: libmtp
|
||||||
Version: 0.1.5
|
Version: 0.2.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A software library for MTP media players
|
Summary: A software library for MTP media players
|
||||||
URL: http://libmtp.sourceforge.net/
|
URL: http://libmtp.sourceforge.net/
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
Source1: libmtp.perms
|
Source1: libmtp.perms
|
||||||
Patch: libmtp-0.1.5-udevrules.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
License: LGPL
|
License: LGPL
|
||||||
Requires: udev
|
Requires: udev
|
||||||
@ -55,7 +45,6 @@ library for MTP media players.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch -p1 -b .udevrules
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static --program-prefix=mtp-
|
%configure --disable-static --program-prefix=mtp-
|
||||||
@ -107,6 +96,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Aug 4 2007 Linus Walleij <triad@df.lth.se> 0.2.0-1
|
||||||
|
- New upstream release.
|
||||||
|
- Fixes (hopefully) the issues found by Harald.
|
||||||
|
- Dependent apps will need to recompile and patch some minor code.
|
||||||
|
|
||||||
* Mon Jul 30 2007 Harald Hoyer <harald@redhat.com> - 0.1.5-2
|
* Mon Jul 30 2007 Harald Hoyer <harald@redhat.com> - 0.1.5-2
|
||||||
- changed udev rules for new kernel and udev versions
|
- changed udev rules for new kernel and udev versions
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user