New upstream version.
This bumps soname so dependencies need to be rebuilt. Signed-off-by: Linus Walleij <triad@df.lth.se>
This commit is contained in:
parent
94725784cb
commit
0bff02e1f7
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ libmtp-1.0.3.tar.gz
|
||||
*.rpm
|
||||
i386
|
||||
/libmtp-1.0.6.tar.gz
|
||||
/libmtp-1.1.0.tar.gz
|
||||
|
13
libmtp.spec
13
libmtp.spec
@ -2,14 +2,13 @@
|
||||
# RPM repository.
|
||||
|
||||
Name: libmtp
|
||||
Version: 1.0.6
|
||||
Release: 3%{?dist}
|
||||
Version: 1.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A software library for MTP media players
|
||||
URL: http://libmtp.sourceforge.net/
|
||||
|
||||
Group: System Environment/Libraries
|
||||
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Patch0: probe-3-ep-only.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
License: LGPLv2+
|
||||
Requires: udev
|
||||
@ -43,7 +42,6 @@ library for MTP media players.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure --disable-static \
|
||||
@ -103,6 +101,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 08 2011 Linus Walleij <triad@df.lth.se> 1.1.0-1
|
||||
- New upstream version including fixed bugs and the patch we
|
||||
used to carry. Dependecies need to be rebuilt. (New
|
||||
soversion)
|
||||
|
||||
* Tue Jun 07 2011 Linus Walleij <triad@df.lth.se> 1.0.6-3
|
||||
- Nuke HAL dependency.
|
||||
|
||||
@ -247,7 +250,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
* Wed Oct 24 2007 Linus Walleij <triad@df.lth.se> 0.2.2-2
|
||||
- Flat out KILL the Doxygen HTML docs to resolve multiarch conflicts.
|
||||
Either upstream (that's me!) needs to work around the HTML files being
|
||||
Either upstream (that's me!) needs to work around the HTML files being
|
||||
different each time OR Doxygen must stop generating anchors that
|
||||
hash the system time, creating different files with each generation.
|
||||
Pre-generating the docs is deemed silly. (Someone will disagree.)
|
||||
|
@ -1,18 +0,0 @@
|
||||
diff --git a/src/libusb-glue.c b/src/libusb-glue.c
|
||||
index 5d7889b..3c0a124 100644
|
||||
--- a/src/libusb-glue.c
|
||||
+++ b/src/libusb-glue.c
|
||||
@@ -284,6 +284,13 @@ static int probe_device_descriptor(struct usb_device *dev, FILE *dumpfile)
|
||||
&dev->config[i].interface[j].altsetting[k];
|
||||
|
||||
/*
|
||||
+ * MTP interfaces have three endpoints, two bulk and one
|
||||
+ * interrupt. Don't probe anything else.
|
||||
+ */
|
||||
+ if (intf->bNumEndpoints != 3)
|
||||
+ continue;
|
||||
+
|
||||
+ /*
|
||||
* We only want to probe for the OS descriptor if the
|
||||
* device is USB_CLASS_VENDOR_SPEC or one of the interfaces
|
||||
* in it is, so flag if we find an interface like this.
|
Loading…
Reference in New Issue
Block a user