libmodulemd/SOURCES/0001-Double-valgrind-timeout.patch
2021-10-08 12:49:50 +00:00

30 lines
928 B
Diff

From 1a7bf143761ff8e3f4f6585b82c0be4dbd511fca Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Thu, 23 May 2019 14:00:36 -0400
Subject: [PATCH 1/3] Double valgrind timeout
On some architectures under heavy load, the valgrind check on v2
is taking a long time.
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
---
modulemd/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/modulemd/meson.build b/modulemd/meson.build
index 47bd1f58e6401d2634d8ff737c2b347f5ebc6bf5..e49c7a9df76dcf37a18ddeba3150d6c914aa4e25 100644
--- a/modulemd/meson.build
+++ b/modulemd/meson.build
@@ -313,7 +313,7 @@ endif
if valgrind.found()
modulemd_valgrind_scripts = files('common/tests/test-valgrind.py')
test ('valgrind', python3,
env : test_env,
args : modulemd_valgrind_scripts,
- timeout : 600)
+ timeout : 1200)
endif
--
2.21.0