import libmemcached-awesome-1.1.0-12.el9

This commit is contained in:
CentOS Sources 2021-12-07 14:29:48 -05:00 committed by Stepan Oksanichenko
parent edd196d4ec
commit 5205c37106
3 changed files with 65 additions and 1 deletions

View File

@ -0,0 +1,24 @@
diff --git a/src/libhashkit/CMakeLists.txt b/src/libhashkit/CMakeLists.txt
index b820d27b..fb732fcf 100644
--- a/src/libhashkit/CMakeLists.txt
+++ b/src/libhashkit/CMakeLists.txt
@@ -17,7 +17,6 @@ set(libhashkit_sources
murmur3.cc
murmur3_api.cc
one_at_a_time.cc
- rijndael.cc
str_algorithm.cc
strerror.cc
string.cc
@@ -53,6 +52,10 @@ if(ENABLE_OPENSSL_CRYPTO)
endif()
endif()
+if (NOT OPENSSL_CRYPTO_LIBRARY)
+ set (libhashkit_sources ${libhashkit_sources} rijndael.cc)
+endif()
+
configure_file(hashkitcon.h.in hashkitcon.h @ONLY)
install(TARGETS libhashkit EXPORT libhashkit-targets

View File

@ -0,0 +1,21 @@
commit 6651fe2eaded59f1657c21a2ea3880807f8c7bb1
Author: Tomas Korbar <tkorbar@redhat.com>
Date: Fri Nov 12 15:53:25 2021 +0100
Fix rpath
diff --git a/CMakeConfig.txt b/CMakeConfig.txt
index d8afcae..d2acf8f 100644
--- a/CMakeConfig.txt
+++ b/CMakeConfig.txt
@@ -11,10 +11,6 @@ set(CMAKE_INSTALL_PREFIX /usr/local
if(APPLE)
set(CMAKE_INSTALL_RPATH @loader_path
CACHE STRING "set relative rpath")
-elseif(UNIX)
- # FIXME
- set(CMAKE_INSTALL_RPATH "\$ORIGIN"
- CACHE STRING "set relative rpath")
endif()
if(${CMAKE_VERSION} VERSION_LESS "3.12")

View File

@ -24,7 +24,7 @@
Name: %{libname}-awesome Name: %{libname}-awesome
Summary: Client library and command line tools for memcached server Summary: Client library and command line tools for memcached server
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}} Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 9%{?dist} Release: 12%{?dist}
License: BSD License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project} URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
@ -35,6 +35,9 @@ Patch2: %{name}-config.patch
Patch3: %{name}-macro.patch Patch3: %{name}-macro.patch
Patch4: %{name}-testing.patch Patch4: %{name}-testing.patch
Patch5: %{name}-udp-test.patch Patch5: %{name}-udp-test.patch
# rhbz#1995795
Patch6: %{name}-aes2.patch
Patch7: %{name}-rpath.patch
BuildRequires: cmake >= 3.9 BuildRequires: cmake >= 3.9
BuildRequires: gcc BuildRequires: gcc
@ -117,6 +120,8 @@ memtouch Touches a key
%patch3 -p1 %patch3 -p1
%patch4 -p1 %patch4 -p1
%patch5 -p1 %patch5 -p1
%patch6 -p1
%patch7 -p1
# drop test hanging in mock # drop test hanging in mock
# and requiring some memcached build options # and requiring some memcached build options
@ -128,6 +133,8 @@ rm test/tests/memcached/udp.cpp
%build %build
%set_build_flags
LDFLAGS="${LDFLAGS} -Wl,--enable-new-dtags"
%cmake \ %cmake \
-DBUILD_TESTING:BOOL=ON \ -DBUILD_TESTING:BOOL=ON \
-DBUILD_DOCS_MAN:BOOL=ON \ -DBUILD_DOCS_MAN:BOOL=ON \
@ -196,6 +203,18 @@ rm -r %{buildroot}%{_datadir}/doc/%{name}/
%changelog %changelog
* Fri Nov 12 2021 Tomas Korbar <tkorbar@redhat.com> - 1.1.0-12
- Fix rpath
- Related: rhbz#1995795
* Fri Nov 12 2021 Tomas Korbar <tkorbar@redhat.com> - 1.1.0-11
- Add flag to linker flags
- Related: rhbz#1995795
* Thu Nov 11 2021 Tomas Korbar <tkorbar@redhat.com> - 1.1.0-10
- Remove aes implementation from the sources completely
- Resolves: rhbz#1995795
* Fri Aug 06 2021 Tomas Korbar <tkorbar@redhat.com> - 1.1.0-9 * Fri Aug 06 2021 Tomas Korbar <tkorbar@redhat.com> - 1.1.0-9
- Disable unstable test for udp - Disable unstable test for udp
- Related: rhbz#1981785 - Related: rhbz#1981785