diff --git a/libloader-1.1.3-remove-antcontrib-support.patch b/libloader-1.1.3-remove-antcontrib-support.patch
new file mode 100644
index 0000000..8c59e37
--- /dev/null
+++ b/libloader-1.1.3-remove-antcontrib-support.patch
@@ -0,0 +1,240 @@
+diff --git a/common_build.xml b/common_build.xml
+index d9fe4b6..4eb9f28 100644
+--- a/common_build.xml
++++ b/common_build.xml
+@@ -152,9 +152,6 @@ TYPICAL TARGET SEQUENCE
+
+-
+
+@@ -324,69 +321,6 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+
++ depends="svnant.download-check">
+
+
+
+@@ -491,58 +425,13 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+
++ depends="ivy.download-check">
+
+
+
+@@ -602,7 +491,7 @@ TYPICAL TARGET SEQUENCE
+ Verifies that there are no SNAPSHOT dependencies defined in the ivy xml.
+ If there are SNAPSHOTS, fail the release build.
+ ====================================================================-->
+-
++
+
+
+
+@@ -769,7 +658,7 @@ TYPICAL TARGET SEQUENCE
+ Publishes the jar file for this project to a Maven2 repository.
+ ====================================================================-->
+
++ depends="create-pom,ivy.deliver">
+
+
+
+@@ -1038,12 +927,11 @@ TYPICAL TARGET SEQUENCE
+ - compile.pre : anything needed to prep for compile
+ - compile.compile : the actual compilation step
+ - compile.src_copy : copying the source into the bin directory
+- - compile.res_copy : copying the resources into the bin directory
+ - compile.lic_copy : copying the license information into the bin directory
+ - compile.post : anything needed after the compile is done
+ ====================================================================-->
+
+
+
+@@ -1076,36 +964,6 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+-
++
+
+
+
+@@ -1165,7 +1023,7 @@ TYPICAL TARGET SEQUENCE
+ Creates a new manifest file if one is not specified, or updates
+ an existing manifest file if one is specified.
+ ====================================================================-->
+-
++
+
+
+
diff --git a/libloader.spec b/libloader.spec
index e386d38..5bef6ae 100644
--- a/libloader.spec
+++ b/libloader.spec
@@ -1,6 +1,6 @@
Name: libloader
Version: 1.1.3
-Release: 27%{?dist}
+Release: 28%{?dist}
Summary: Resource Loading Framework
License: LGPLv2
#Original source: http://downloads.sourceforge.net/jfreereport/%%{name}-%%{version}.zip
@@ -8,12 +8,13 @@ License: LGPLv2
#to simplify the licensing
Source: %{name}-%{version}-jarsdeleted.zip
URL: http://reporting.pentaho.org/
-BuildRequires: ant, ant-contrib, java-devel, jpackage-utils
+BuildRequires: ant, java-devel, jpackage-utils
BuildRequires: libbase >= 1.1.3
Requires: java-headless, jpackage-utils, libbase >= 1.1.3
BuildArch: noarch
Patch0: libloader-1.1.2.build.patch
Patch1: libloader-1.1.2.java11.patch
+Patch2: libloader-1.1.3-remove-antcontrib-support.patch
%description
LibLoader is a general purpose resource loading framework. It has been
@@ -33,6 +34,8 @@ Javadoc for %{name}.
%setup -q -c
%patch0 -p1 -b .build
%patch1 -p1 -b .java11
+%patch2 -p1 -b .no_antcontrib
+
find . -name "*.jar" -exec rm -f {} \;
mkdir -p lib
build-jar-repository -s -p lib libbase commons-logging-api
@@ -61,6 +64,9 @@ cp -rp bin/javadoc/docs/api $RPM_BUILD_ROOT%{_javadocdir}/%{name}
%{_javadocdir}/%{name}
%changelog
+* Fri Jan 15 2021 Nicolas Lécureuil - 1.1.3-28
+- Remove ant-contrib support
+
* Tue Jul 28 2020 Fedora Release Engineering - 1.1.3-27
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild