- New upstream release 1.0.0
- SOname bump to account for module loading changes - Rename libldb-tools to ldb-tools to make upgrades easier
This commit is contained in:
parent
1ba86b56a2
commit
fd922ff5d1
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/ldb-0.9.22.tar.gz
|
/ldb-0.9.22.tar.gz
|
||||||
|
/ldb-1.0.0.tar.gz
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
From feff3aad50304450248aa66aed59d09439699234 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Date: Wed, 12 Jan 2011 15:01:52 -0500
|
|
||||||
Subject: [PATCH] Install python bindings in the arch-specific location
|
|
||||||
|
|
||||||
---
|
|
||||||
buildtools/wafsamba/samba_python.py | 5 ++++-
|
|
||||||
1 files changed, 4 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/buildtools/wafsamba/samba_python.py b/buildtools/wafsamba/samba_python.py
|
|
||||||
index a663b1910d063336c1340142ae8855d7e176ecdb..9b72f3fd112288a022a2de0701594814616f202f 100644
|
|
||||||
--- a/buildtools/wafsamba/samba_python.py
|
|
||||||
+++ b/buildtools/wafsamba/samba_python.py
|
|
||||||
@@ -51,6 +51,9 @@ def SAMBA_PYTHON(bld, name,
|
|
||||||
|
|
||||||
link_name = 'python/%s' % realname
|
|
||||||
|
|
||||||
+ from distutils.sysconfig import get_python_lib
|
|
||||||
+ arch_install_dir = get_python_lib(1)
|
|
||||||
+
|
|
||||||
bld.SAMBA_LIBRARY(name,
|
|
||||||
source=source,
|
|
||||||
deps=deps,
|
|
||||||
@@ -63,7 +66,7 @@ def SAMBA_PYTHON(bld, name,
|
|
||||||
link_name=link_name,
|
|
||||||
pyembed=True,
|
|
||||||
target_type='PYTHON',
|
|
||||||
- install_path='${PYTHONDIR}',
|
|
||||||
+ install_path=arch_install_dir,
|
|
||||||
enabled=enabled)
|
|
||||||
|
|
||||||
Build.BuildContext.SAMBA_PYTHON = SAMBA_PYTHON
|
|
||||||
--
|
|
||||||
1.7.3.4
|
|
||||||
|
|
32
libldb.spec
32
libldb.spec
@ -8,8 +8,8 @@
|
|||||||
%define tevent_version 0.9.10
|
%define tevent_version 0.9.10
|
||||||
|
|
||||||
Name: libldb
|
Name: libldb
|
||||||
Version: 0.9.22
|
Version: 1.0.0
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: A schema-less, ldap like, API and database
|
Summary: A schema-less, ldap like, API and database
|
||||||
Requires: libtalloc >= %{talloc_version}
|
Requires: libtalloc >= %{talloc_version}
|
||||||
@ -37,18 +37,17 @@ BuildRequires: python-tdb
|
|||||||
BuildRequires: pytalloc-devel
|
BuildRequires: pytalloc-devel
|
||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
Patch0001: 0001-Install-python-bindings-in-the-arch-specific-locatio.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
An extensible library that implements an LDAP like API to access remote LDAP
|
An extensible library that implements an LDAP like API to access remote LDAP
|
||||||
servers, or use local tdb databases.
|
servers, or use local tdb databases.
|
||||||
|
|
||||||
%package tools
|
%package -n ldb-tools
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: Tools to manage LDB files
|
Summary: Tools to manage LDB files
|
||||||
Requires: libldb = %{version}-%{release}
|
Requires: libldb = %{version}-%{release}
|
||||||
|
|
||||||
%description tools
|
%description -n ldb-tools
|
||||||
Tools to manage LDB files
|
Tools to manage LDB files
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
@ -83,18 +82,17 @@ Development files for the Python bindings for the LDB library
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n ldb-%{version}
|
%setup -q -n ldb-%{version}
|
||||||
|
|
||||||
%patch0001 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
%configure --disable-rpath-install \
|
||||||
%configure --disable-rpath \
|
|
||||||
--disable-rpath-install \
|
|
||||||
--bundled-libraries=NONE \
|
--bundled-libraries=NONE \
|
||||||
--with-modulesdir=%{_libdir}/ldb/modules \
|
--with-modulesdir=%{_libdir}/ldb/modules \
|
||||||
--with-privatelibdir=%{_libdir}/ldb
|
--with-privatelibdir=%{_libdir}/ldb
|
||||||
|
|
||||||
make V=1 %{?_smp_mflags}
|
make V=1 %{?_smp_mflags}
|
||||||
|
|
||||||
|
%check
|
||||||
|
make V=1 %{?_smp_mflags} check
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install DESTDIR=%{buildroot}
|
make install DESTDIR=%{buildroot}
|
||||||
|
|
||||||
@ -118,9 +116,11 @@ rm -rf %{buildroot}
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%dir %{_libdir}/ldb
|
%dir %{_libdir}/ldb
|
||||||
%{_libdir}/libldb.so.*
|
%{_libdir}/libldb.so.*
|
||||||
|
%dir %{_libdir}/ldb/modules
|
||||||
|
%dir %{_libdir}/ldb/modules/ldb
|
||||||
%{_libdir}/ldb/modules/ldb/*.so
|
%{_libdir}/ldb/modules/ldb/*.so
|
||||||
|
|
||||||
%files tools
|
%files -n ldb-tools
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/ldbadd
|
%{_bindir}/ldbadd
|
||||||
%{_bindir}/ldbdel
|
%{_bindir}/ldbdel
|
||||||
@ -128,7 +128,7 @@ rm -rf %{buildroot}
|
|||||||
%{_bindir}/ldbmodify
|
%{_bindir}/ldbmodify
|
||||||
%{_bindir}/ldbrename
|
%{_bindir}/ldbrename
|
||||||
%{_bindir}/ldbsearch
|
%{_bindir}/ldbsearch
|
||||||
%{_libdir}/ldb/libldb-cmdline-ldb.so
|
%{_libdir}/ldb/libldb-cmdline.so
|
||||||
%{_mandir}/man1/ldbadd.1.*
|
%{_mandir}/man1/ldbadd.1.*
|
||||||
%{_mandir}/man1/ldbdel.1.*
|
%{_mandir}/man1/ldbdel.1.*
|
||||||
%{_mandir}/man1/ldbedit.1.*
|
%{_mandir}/man1/ldbedit.1.*
|
||||||
@ -141,6 +141,7 @@ rm -rf %{buildroot}
|
|||||||
%{_includedir}/ldb_module.h
|
%{_includedir}/ldb_module.h
|
||||||
%{_includedir}/ldb_handlers.h
|
%{_includedir}/ldb_handlers.h
|
||||||
%{_includedir}/ldb_errors.h
|
%{_includedir}/ldb_errors.h
|
||||||
|
%{_includedir}/ldb_version.h
|
||||||
%{_includedir}/ldb.h
|
%{_includedir}/ldb.h
|
||||||
%{_libdir}/libldb.so
|
%{_libdir}/libldb.so
|
||||||
|
|
||||||
@ -150,7 +151,7 @@ rm -rf %{buildroot}
|
|||||||
%files -n pyldb
|
%files -n pyldb
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{python_sitearch}/ldb.so
|
%{python_sitearch}/ldb.so
|
||||||
%{_libdir}/libpyldb-util.so.*
|
%{_libdir}/libpyldb-util.so.1*
|
||||||
|
|
||||||
%files -n pyldb-devel
|
%files -n pyldb-devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -162,6 +163,11 @@ rm -rf %{buildroot}
|
|||||||
%postun -n pyldb -p /sbin/ldconfig
|
%postun -n pyldb -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
|
||||||
|
- New upstream release 1.0.0
|
||||||
|
- SOname bump to account for module loading changes
|
||||||
|
- Rename libldb-tools to ldb-tools to make upgrades easier
|
||||||
|
|
||||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user