New upstream release
Add ldb_module_error() routine Fedora: work around unreliable configure check for pytevent Drop patch to ignore --disable-silent-rules (included in tarball)
This commit is contained in:
parent
408cd3a77a
commit
e94d5d7b38
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/ldb-1.0.2.tar.gz
|
/ldb-1.0.2.tar.gz
|
||||||
/ldb-1.1.0.tar.gz
|
/ldb-1.1.0.tar.gz
|
||||||
/ldb-1.1.3.tar.gz
|
/ldb-1.1.3.tar.gz
|
||||||
|
/ldb-1.1.4.tar.gz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From 6af702bdc9ea36a1f33232a818a819afde9bc4d2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sumit Bose <sbose@redhat.com>
|
|
||||||
Date: Thu, 6 Oct 2011 10:32:58 +0200
|
|
||||||
Subject: [PATCH] build: added autoconf --disable-silent-rules option
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Signed-off-by: Günther Deschner <gd@samba.org>
|
|
||||||
---
|
|
||||||
buildtools/wafsamba/wscript | 3 +++
|
|
||||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/buildtools/wafsamba/wscript b/buildtools/wafsamba/wscript
|
|
||||||
index 1a7f3eb69974625e903f314c6c7b92547063e884..5c5e249758c36a64083499b9050c0c4e77c87b6d 100755
|
|
||||||
--- a/buildtools/wafsamba/wscript
|
|
||||||
+++ b/buildtools/wafsamba/wscript
|
|
||||||
@@ -162,6 +162,9 @@ def set_options(opt):
|
|
||||||
opt.add_option('--disable-dependency-tracking',
|
|
||||||
help=SUPPRESS_HELP,
|
|
||||||
action='store_true', dest='AUTOCONF_DISABLE_DEPENDENCY_TRACKING', default=False)
|
|
||||||
+ opt.add_option('--disable-silent-rules',
|
|
||||||
+ help=SUPPRESS_HELP,
|
|
||||||
+ action='store_true', dest='AUTOCONF_DISABLE_SILENT_RULES', default=False)
|
|
||||||
|
|
||||||
gr = opt.option_group('dist options')
|
|
||||||
gr.add_option('--sign-release',
|
|
||||||
--
|
|
||||||
1.7.7.3
|
|
||||||
|
|
13
FED01-fix-tevent-check.patch
Normal file
13
FED01-fix-tevent-check.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -ruN ldb-1.1.4.orig/buildtools/wafsamba/samba_bundled.py ldb-1.1.4/buildtools/wafsamba/samba_bundled.py
|
||||||
|
--- ldb-1.1.4.orig/buildtools/wafsamba/samba_bundled.py 2011-11-14 12:01:10.000000000 -0500
|
||||||
|
+++ ldb-1.1.4/buildtools/wafsamba/samba_bundled.py 2011-12-07 07:33:40.685193659 -0500
|
||||||
|
@@ -228,7 +228,8 @@
|
||||||
|
try:
|
||||||
|
version = m.__version__
|
||||||
|
except AttributeError:
|
||||||
|
- found = False
|
||||||
|
+ Logs.warn('WARNING: Could not determine if %s is of version %s or later. Assuming it is.' % (libname, minversion))
|
||||||
|
+ found = True
|
||||||
|
else:
|
||||||
|
found = tuple(version.split(".")) >= tuple(minversion.split("."))
|
||||||
|
if not found and not conf.LIB_MAY_BE_BUNDLED(libname):
|
17
libldb.spec
17
libldb.spec
@ -8,8 +8,8 @@
|
|||||||
%define tevent_version 0.9.14
|
%define tevent_version 0.9.14
|
||||||
|
|
||||||
Name: libldb
|
Name: libldb
|
||||||
Version: 1.1.3
|
Version: 1.1.4
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Summary: A schema-less, ldap like, API and database
|
Summary: A schema-less, ldap like, API and database
|
||||||
Requires: libtalloc >= %{talloc_version}
|
Requires: libtalloc >= %{talloc_version}
|
||||||
@ -35,6 +35,7 @@ BuildRequires: docbook-style-xsl
|
|||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
BuildRequires: python-tdb
|
BuildRequires: python-tdb
|
||||||
BuildRequires: pytalloc-devel
|
BuildRequires: pytalloc-devel
|
||||||
|
BuildRequires: python-tevent
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
|
|
||||||
Provides: bundled(libreplace)
|
Provides: bundled(libreplace)
|
||||||
@ -42,7 +43,8 @@ Provides: bundled(libtdb_compat)
|
|||||||
Provides: bundled(libccan)
|
Provides: bundled(libccan)
|
||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
Patch1001: 0001-build-added-autoconf-disable-silent-rules-option.patch
|
|
||||||
|
Patch1001: FED01-fix-tevent-check.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
An extensible library that implements an LDAP like API to access remote LDAP
|
An extensible library that implements an LDAP like API to access remote LDAP
|
||||||
@ -87,6 +89,7 @@ Development files for the Python bindings for the LDB library
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n ldb-%{version}
|
%setup -q -n ldb-%{version}
|
||||||
|
|
||||||
%patch1001 -p1
|
%patch1001 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -109,7 +112,7 @@ make install DESTDIR=%{buildroot}
|
|||||||
rm -f %{buildroot}%{_libdir}/libldb.a
|
rm -f %{buildroot}%{_libdir}/libldb.a
|
||||||
|
|
||||||
# Remove _tevent.so (it's managed by python-tevent)
|
# Remove _tevent.so (it's managed by python-tevent)
|
||||||
rm -f %{buildroot}/%{python_sitearch}/_tevent.so
|
#rm -f %{buildroot}/%{python_sitearch}/_tevent.so
|
||||||
|
|
||||||
# Shared libraries need to be marked executable for
|
# Shared libraries need to be marked executable for
|
||||||
# rpmbuild to strip them and include them in debuginfo
|
# rpmbuild to strip them and include them in debuginfo
|
||||||
@ -177,6 +180,12 @@ rm -rf %{buildroot}
|
|||||||
%postun -n pyldb -p /sbin/ldconfig
|
%postun -n pyldb -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
|
||||||
|
- New upstream release
|
||||||
|
- Add ldb_module_error() routine
|
||||||
|
- Fedora: work around unreliable configure check for pytevent
|
||||||
|
- Drop patch to ignore --disable-silent-rules (included in tarball)
|
||||||
|
|
||||||
* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
|
* Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
|
||||||
- Add patch to ignore --disable-silent-rules
|
- Add patch to ignore --disable-silent-rules
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user