rhbz#1837364 - libldb-2.4.0 is available
This commit is contained in:
parent
68e44acf55
commit
d82199568e
2
.gitignore
vendored
2
.gitignore
vendored
@ -62,3 +62,5 @@
|
|||||||
/ldb-2.2.0.tar.gz
|
/ldb-2.2.0.tar.gz
|
||||||
/ldb-2.3.0.tar.asc
|
/ldb-2.3.0.tar.asc
|
||||||
/ldb-2.3.0.tar.gz
|
/ldb-2.3.0.tar.gz
|
||||||
|
/ldb-2.4.0.tar.gz
|
||||||
|
/ldb-2.4.0.tar.asc
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
From e90817629f1f7049cc0fe48f1003f5fb1103acc3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Gary Lockyer <gary@catalyst.net.nz>
|
|
||||||
Date: Thu, 22 Apr 2021 10:03:53 +0200
|
|
||||||
Subject: [PATCH 1/2] lib:ldb: Use a 1MiB lmdb so the test also passes on
|
|
||||||
aarch64 CentOS stream
|
|
||||||
|
|
||||||
Signed-off-by: Gary Lockyer <gary@catalyst.net.nz>
|
|
||||||
Reviewed-by: Andreas Schneider <asn@samba.org>
|
|
||||||
---
|
|
||||||
lib/ldb/tests/ldb_lmdb_free_list_test.c | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/ldb/tests/ldb_lmdb_free_list_test.c b/lib/ldb/tests/ldb_lmdb_free_list_test.c
|
|
||||||
index 9b295460730..c87620e7a87 100644
|
|
||||||
--- a/tests/ldb_lmdb_free_list_test.c
|
|
||||||
+++ b/tests/ldb_lmdb_free_list_test.c
|
|
||||||
@@ -77,7 +77,7 @@
|
|
||||||
#endif /* TEST_BE */
|
|
||||||
|
|
||||||
const int RECORD_SIZE = 6144;
|
|
||||||
-const int ITERATIONS = 3;
|
|
||||||
+const int ITERATIONS = 192;
|
|
||||||
|
|
||||||
struct test_ctx {
|
|
||||||
struct tevent_context *ev;
|
|
||||||
@@ -155,9 +155,9 @@ static int setup(void **state)
|
|
||||||
"@IDX_DN_GUID: GUID\n"
|
|
||||||
"\n";
|
|
||||||
/*
|
|
||||||
- * Use a 64KiB DB for this test
|
|
||||||
+ * Use a 1MiB DB for this test
|
|
||||||
*/
|
|
||||||
- const char *options[] = {"lmdb_env_size:65536", NULL};
|
|
||||||
+ const char *options[] = {"lmdb_env_size:1048576", NULL};
|
|
||||||
|
|
||||||
noconn_setup((void **)&test_ctx);
|
|
||||||
|
|
||||||
--
|
|
||||||
2.31.1
|
|
15
libldb.spec
15
libldb.spec
@ -19,13 +19,13 @@
|
|||||||
%bcond_with python3
|
%bcond_with python3
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global talloc_version 2.3.1
|
%global talloc_version 2.4.0
|
||||||
%global tdb_version 1.4.3
|
%global tdb_version 1.4.4
|
||||||
%global tevent_version 0.10.2
|
%global tevent_version 0.11.0
|
||||||
|
|
||||||
Name: libldb
|
Name: libldb
|
||||||
Version: 2.3.0
|
Version: 2.4.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A schema-less, ldap like, API and database
|
Summary: A schema-less, ldap like, API and database
|
||||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||||
Requires: libtdb%{?_isa} >= %{tdb_version}
|
Requires: libtdb%{?_isa} >= %{tdb_version}
|
||||||
@ -42,8 +42,6 @@ Source3: fixed-guidindexpackv1.ldb
|
|||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
Patch0001: 0001-PATCH-wafsamba-Fix-few-SyntaxWarnings-caused-by-regu.patch
|
Patch0001: 0001-PATCH-wafsamba-Fix-few-SyntaxWarnings-caused-by-regu.patch
|
||||||
# https://gitlab.com/samba-team/samba/-/merge_requests/1920
|
|
||||||
Patch0002: ldb-2.3.0-fix-tests-on-aarch64.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libtalloc-devel >= %{talloc_version}
|
BuildRequires: libtalloc-devel >= %{talloc_version}
|
||||||
@ -230,6 +228,9 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 15 2021 Guenther Deschner <gdeschne@redhat.com> - 2.4.0-1
|
||||||
|
- rhbz#1837364 - libldb-2.4.0 is available
|
||||||
|
|
||||||
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 2.3.0-3
|
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 2.3.0-3
|
||||||
- Rebuilt for Python 3.10
|
- Rebuilt for Python 3.10
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
|
SHA512 (ldb-2.4.0.tar.gz) = 6c500b723c081488bc0717b6a5b0e8966c5d8a751232f8856281a6fe4d358ae6b5878c8400a82fa666379066105fbb9259b2967313e73efabef0e1386095e2ee
|
||||||
|
SHA512 (ldb-2.4.0.tar.asc) = b2c146d71b153259cace3698f5e65d0a3325ebe305c1205c632f537958a2c44bc67422a4286b8453284f086d60c38842426f7a8e01c3577da81bd3f5d64947fd
|
||||||
SHA512 (ldb.keyring) = dab8c56fad6555885ee05f26f1e6da8d4c95c0cd7bdba114422b31d33b95ce46e763946a4be17c651e2626c0511f087bc223773f74b4d43ffc3010528b270093
|
SHA512 (ldb.keyring) = dab8c56fad6555885ee05f26f1e6da8d4c95c0cd7bdba114422b31d33b95ce46e763946a4be17c651e2626c0511f087bc223773f74b4d43ffc3010528b270093
|
||||||
SHA512 (ldb-2.3.0.tar.asc) = c903363bcc58c1c192a88588aa2a510374864c3c1bc7e96a82663028ee00de9379122012ad05a141dc892454b797f007aca855a02b0ad3e99f6d353a612605bc
|
|
||||||
SHA512 (ldb-2.3.0.tar.gz) = 7e389c0b4700a809893276d69216436ebd6d30e1f52407e4a08a1113cf14e151aed74300d8c36765c91c8f3195d8054b13a28cbdfcab031f88fd1d353e415348
|
|
||||||
|
Loading…
Reference in New Issue
Block a user