Rebase to version 2.4.1
resolves: rhbz#2013588
This commit is contained in:
parent
3e82bc3c01
commit
d7226f5b80
2
.gitignore
vendored
2
.gitignore
vendored
@ -62,3 +62,5 @@
|
||||
/ldb-2.2.0.tar.gz
|
||||
/ldb-2.3.0.tar.asc
|
||||
/ldb-2.3.0.tar.gz
|
||||
/ldb-2.4.1.tar.asc
|
||||
/ldb-2.4.1.tar.gz
|
||||
|
Binary file not shown.
@ -1,39 +0,0 @@
|
||||
From e90817629f1f7049cc0fe48f1003f5fb1103acc3 Mon Sep 17 00:00:00 2001
|
||||
From: Gary Lockyer <gary@catalyst.net.nz>
|
||||
Date: Thu, 22 Apr 2021 10:03:53 +0200
|
||||
Subject: [PATCH 1/2] lib:ldb: Use a 1MiB lmdb so the test also passes on
|
||||
aarch64 CentOS stream
|
||||
|
||||
Signed-off-by: Gary Lockyer <gary@catalyst.net.nz>
|
||||
Reviewed-by: Andreas Schneider <asn@samba.org>
|
||||
---
|
||||
lib/ldb/tests/ldb_lmdb_free_list_test.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/ldb/tests/ldb_lmdb_free_list_test.c b/lib/ldb/tests/ldb_lmdb_free_list_test.c
|
||||
index 9b295460730..c87620e7a87 100644
|
||||
--- a/tests/ldb_lmdb_free_list_test.c
|
||||
+++ b/tests/ldb_lmdb_free_list_test.c
|
||||
@@ -77,7 +77,7 @@
|
||||
#endif /* TEST_BE */
|
||||
|
||||
const int RECORD_SIZE = 6144;
|
||||
-const int ITERATIONS = 3;
|
||||
+const int ITERATIONS = 192;
|
||||
|
||||
struct test_ctx {
|
||||
struct tevent_context *ev;
|
||||
@@ -155,9 +155,9 @@ static int setup(void **state)
|
||||
"@IDX_DN_GUID: GUID\n"
|
||||
"\n";
|
||||
/*
|
||||
- * Use a 64KiB DB for this test
|
||||
+ * Use a 1MiB DB for this test
|
||||
*/
|
||||
- const char *options[] = {"lmdb_env_size:65536", NULL};
|
||||
+ const char *options[] = {"lmdb_env_size:1048576", NULL};
|
||||
|
||||
noconn_setup((void **)&test_ctx);
|
||||
|
||||
--
|
||||
2.31.1
|
BIN
ldb.keyring
Normal file
BIN
ldb.keyring
Normal file
Binary file not shown.
21
libldb.spec
21
libldb.spec
@ -19,13 +19,13 @@
|
||||
%bcond_with python3
|
||||
%endif
|
||||
|
||||
%global talloc_version 2.3.1
|
||||
%global tdb_version 1.4.3
|
||||
%global tevent_version 0.10.2
|
||||
%global talloc_version 2.3.3
|
||||
%global tdb_version 1.4.4
|
||||
%global tevent_version 0.11.0
|
||||
|
||||
Name: libldb
|
||||
Version: 2.3.0
|
||||
Release: 6%{?dist}
|
||||
Version: 2.4.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A schema-less, ldap like, API and database
|
||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||
Requires: libtdb%{?_isa} >= %{tdb_version}
|
||||
@ -36,14 +36,9 @@ Source0: https://www.samba.org/ftp/ldb/ldb-%{version}.tar.gz
|
||||
Source1: https://www.samba.org/ftp/ldb/ldb-%{version}.tar.asc
|
||||
# gpg2 --no-default-keyring --keyring ./ldb.keyring --recv-keys 9147A339719518EE9011BCB54793916113084025
|
||||
Source2: ldb.keyring
|
||||
# binary diffs are not supported
|
||||
# https://gitlab.com/samba-team/samba/-/merge_requests/1920
|
||||
Source3: fixed-guidindexpackv1.ldb
|
||||
|
||||
# Patches
|
||||
Patch0001: 0001-PATCH-wafsamba-Fix-few-SyntaxWarnings-caused-by-regu.patch
|
||||
# https://gitlab.com/samba-team/samba/-/merge_requests/1920
|
||||
Patch0002: ldb-2.3.0-fix-tests-on-aarch64.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libtalloc-devel >= %{talloc_version}
|
||||
@ -132,9 +127,6 @@ Development files for the Python bindings for the LDB library
|
||||
zcat %{SOURCE0} | gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} -
|
||||
%autosetup -n ldb-%{version} -p1
|
||||
|
||||
# binary diffs are not supported
|
||||
cp -f %{SOURCE3} tests/guidindexpackv1.ldb
|
||||
|
||||
%build
|
||||
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1217376
|
||||
export python_LDFLAGS=""
|
||||
@ -230,6 +222,9 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Nov 29 2021 Pavel Filipenský <pfilipen@redhat.com> - 2.4.1-1
|
||||
- resolves: rhbz#2013588 - Rebase to version 2.4.1
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.3.0-6
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
5
sources
5
sources
@ -1,3 +1,2 @@
|
||||
SHA512 (ldb.keyring) = dab8c56fad6555885ee05f26f1e6da8d4c95c0cd7bdba114422b31d33b95ce46e763946a4be17c651e2626c0511f087bc223773f74b4d43ffc3010528b270093
|
||||
SHA512 (ldb-2.3.0.tar.asc) = c903363bcc58c1c192a88588aa2a510374864c3c1bc7e96a82663028ee00de9379122012ad05a141dc892454b797f007aca855a02b0ad3e99f6d353a612605bc
|
||||
SHA512 (ldb-2.3.0.tar.gz) = 7e389c0b4700a809893276d69216436ebd6d30e1f52407e4a08a1113cf14e151aed74300d8c36765c91c8f3195d8054b13a28cbdfcab031f88fd1d353e415348
|
||||
SHA512 (ldb-2.4.1.tar.asc) = 3aa7a3cd5481668f8764f093856893dd3737a3d71092dc15bbeb88da9baf8c194843cc35eda543d3511c5cbec1ce03c6c16b3da87db53570fd18fc80d2c4273b
|
||||
SHA512 (ldb-2.4.1.tar.gz) = 14ab5397d28c369142b2ccf55a2ab4e678a3fe6e018541cfce46241f8226400bc169360bbef254fae4410a6e15024ae986f02298d3d324e3d3a8b88801bf76d7
|
||||
|
Loading…
Reference in New Issue
Block a user