New upstream release 1.2.0
Resolves: rhbz#1467118 - libldb-1.2.0 is available * run unit-tests
This commit is contained in:
parent
de65afad2f
commit
d177bb91cc
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@
|
||||
/ldb-1.1.29.tar.gz
|
||||
/ldb-1.1.30.tar.gz
|
||||
/ldb-1.1.31.tar.gz
|
||||
/ldb-1.2.0.tar.gz
|
||||
|
56
0001-ldb-Use-libraries-from-build-dir-for-testsuite.patch
Normal file
56
0001-ldb-Use-libraries-from-build-dir-for-testsuite.patch
Normal file
@ -0,0 +1,56 @@
|
||||
From 5dd52177724f6546ffef09b9a8d07abde2adac15 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Slebodnik <lslebodn@redhat.com>
|
||||
Date: Tue, 4 Jul 2017 00:32:31 +0200
|
||||
Subject: [PATCH] ldb: Use libraries from build dir for testsuite
|
||||
|
||||
There was a failure when tests were executed after after extracting
|
||||
ldb tarball.
|
||||
|
||||
sh$ make -j8 check
|
||||
WAF_MAKE=1 PATH=buildtools/bin:../../buildtools/bin:$PATH waf test
|
||||
ldbadd: error while loading shared libraries: libldb.so.1: cannot open shared object file: No such file or directory
|
||||
cat: write error: Broken pipe
|
||||
Traceback (most recent call last):
|
||||
File "tests/python/api.py", line 10, in <module>
|
||||
import ldb
|
||||
ImportError: libldb.so.1: cannot open shared object file: No such file or directory
|
||||
Traceback (most recent call last):
|
||||
File "tests/python/api.py", line 10, in <module>
|
||||
import ldb
|
||||
ImportError: libpyldb-util.so.1: cannot open shared object file: No such file or directory
|
||||
bin/ldb_tdb_mod_op_test: error while loading shared libraries: libldb.so.1: cannot open shared object file: No such file or directory
|
||||
testsuite returned 1
|
||||
|
||||
Signed-off-by: Lukas Slebodnik <lslebodn@redhat.com>
|
||||
---
|
||||
lib/ldb/wscript | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/ldb/wscript b/lib/ldb/wscript
|
||||
index 58e4d4fea1021478242155e8e71c786563819abc..5189ea43fa77d732f606c06738c9ecacd9eb61fc 100644
|
||||
--- a/lib/ldb/wscript
|
||||
+++ b/lib/ldb/wscript
|
||||
@@ -358,7 +358,10 @@ def test(ctx):
|
||||
shutil.rmtree(test_prefix, ignore_errors=True)
|
||||
os.makedirs(test_prefix)
|
||||
os.environ['TEST_DATA_PREFIX'] = test_prefix
|
||||
- os.environ['LD_LIBRARY_PATH'] = Utils.g_module.blddir + '/bin/default/lib/ldb'
|
||||
+ os.environ['LDB_MODULES_PATH'] = Utils.g_module.blddir + "/modules/ldb"
|
||||
+ samba_utils.ADD_LD_LIBRARY_PATH('bin/shared')
|
||||
+ samba_utils.ADD_LD_LIBRARY_PATH('bin/shared/private')
|
||||
+
|
||||
cmd = 'tests/test-tdb.sh %s' % Utils.g_module.blddir
|
||||
ret = samba_utils.RUN_COMMAND(cmd)
|
||||
print("testsuite returned %d" % ret)
|
||||
@@ -371,8 +374,6 @@ def test(ctx):
|
||||
extra_env={'SELFTEST_PREFIX': test_prefix})
|
||||
print("Python testsuite returned %d" % pyret)
|
||||
|
||||
- os.environ['LDB_MODULES_PATH'] = Utils.g_module.blddir + '/modules/ldb'
|
||||
- os.environ['LD_LIBRARY_PATH'] = Utils.g_module.blddir + '/bin/default/lib/ldb'
|
||||
cmocka_ret = 0
|
||||
for test_exe in ['ldb_tdb_mod_op_test',
|
||||
'ldb_msg_test']:
|
||||
--
|
||||
2.13.0
|
||||
|
21
libldb.spec
21
libldb.spec
@ -9,11 +9,11 @@
|
||||
%endif
|
||||
|
||||
%global talloc_version 2.0.8
|
||||
%global tdb_version 1.3.3
|
||||
%global tdb_version 1.3.14
|
||||
%global tevent_version 0.9.17
|
||||
|
||||
Name: libldb
|
||||
Version: 1.1.31
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A schema-less, ldap like, API and database
|
||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||
@ -47,8 +47,9 @@ BuildRequires: python3-tevent
|
||||
%endif
|
||||
|
||||
# Patches
|
||||
Patch0001: 0001-Revert-waf-disable-python-align-talloc-s-wscript.patch
|
||||
Patch0002: 0002-Revert-talloc-use-the-system-pytalloc-util-for-pytho.patch
|
||||
Patch0001: 0001-ldb-Use-libraries-from-build-dir-for-testsuite.patch
|
||||
Patch0101: 0001-Revert-waf-disable-python-align-talloc-s-wscript.patch
|
||||
Patch0102: 0002-Revert-talloc-use-the-system-pytalloc-util-for-pytho.patch
|
||||
|
||||
%description
|
||||
An extensible library that implements an LDAP like API to access remote LDAP
|
||||
@ -134,8 +135,9 @@ Development files for the Python bindings for the LDB library
|
||||
|
||||
%prep
|
||||
%setup -q -n ldb-%{version}
|
||||
%patch0001 -p1
|
||||
%patch0002 -p1
|
||||
%patch0001 -p3
|
||||
%patch0101 -p1
|
||||
%patch0102 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -156,6 +158,9 @@ PY3_CONFIG_FLAGS=""
|
||||
make %{?_smp_mflags} V=1
|
||||
doxygen Doxyfile
|
||||
|
||||
%check
|
||||
make %{?_smp_mflags} check
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
@ -244,6 +249,10 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jul 4 2017 Lukas Slebodnik <lslebodn@redhat.com> - 1.2.0
|
||||
- New upstream release 1.2.0
|
||||
- Resolves: rhbz#1467118 - libldb-1.2.0 is available
|
||||
|
||||
* Fri Jun 16 2017 Lukas Slebodnik <lslebodn@redhat.com> - 1.1.31-1
|
||||
- New upstream release 1.1.31
|
||||
- Resolves: rhbz#1462041 - libldb-1.1.31 is available
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ldb-1.1.31.tar.gz) = 49ccd57000cbcc6d828160f4457236b28853d766d641841471f61226156b6103fe563c43c950577b038ea3c0a54506bca94c640d3d5f912a3b8af95eb9ef2824
|
||||
SHA512 (ldb-1.2.0.tar.gz) = 5c5124c7d4c648872e52eeebdc3f74a3b755e36fa7462df1784a2d6232ee4b8ce26169900c524c7f00f878a39beb3f8e5ad0565500377ee38fdaa0311463c583
|
||||
|
Loading…
Reference in New Issue
Block a user