New upstream release 1.4.1
- Apply a patch to hide local ABI symbols to avoid issues with new binutils - Patch the waf script to explicitly call python2 as "env python" doesn't yield py2 anymore
This commit is contained in:
parent
8dd3a89d7e
commit
7e000c9e8e
1
.gitignore
vendored
1
.gitignore
vendored
@ -36,3 +36,4 @@
|
|||||||
/ldb-1.3.2.tar.gz
|
/ldb-1.3.2.tar.gz
|
||||||
/ldb-1.3.3.tar.gz
|
/ldb-1.3.3.tar.gz
|
||||||
/ldb-1.4.0.tar.gz
|
/ldb-1.4.0.tar.gz
|
||||||
|
/ldb-1.4.1.tar.gz
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From 6c78935344a4f086fc209d0bd77feac0ea5894b3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
|
||||||
Date: Sat, 21 Oct 2017 15:09:01 +0200
|
|
||||||
Subject: [PATCH] ldb: Fix memory leak on module context
|
|
||||||
|
|
||||||
Introduced in e8cdacc509016d9273d63faf334d9f827585c3eb
|
|
||||||
---
|
|
||||||
lib/ldb/ldb_tdb/ldb_index.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/ldb/ldb_tdb/ldb_index.c b/lib/ldb/ldb_tdb/ldb_index.c
|
|
||||||
index c71e866037c5cccba151bcd2346460de0424fe18..1d69ab27f20e0a367c982134ff16a06b044a0c8e 100644
|
|
||||||
--- a/lib/ldb/ldb_tdb/ldb_index.c
|
|
||||||
+++ b/lib/ldb/ldb_tdb/ldb_index.c
|
|
||||||
@@ -516,9 +516,9 @@ static int ltdb_dn_list_store_full(struct ldb_module *module,
|
|
||||||
if (list->count == 0) {
|
|
||||||
ret = ltdb_delete_noindex(module, msg);
|
|
||||||
if (ret == LDB_ERR_NO_SUCH_OBJECT) {
|
|
||||||
- talloc_free(msg);
|
|
||||||
- return LDB_SUCCESS;
|
|
||||||
+ ret = LDB_SUCCESS;
|
|
||||||
}
|
|
||||||
+ talloc_free(msg);
|
|
||||||
return ret;
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
2.14.2
|
|
||||||
|
|
9
ldb-dont-use-usr-bin-env-python.patch
Normal file
9
ldb-dont-use-usr-bin-env-python.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
diff -up ldb-1.4.1/buildtools/bin/waf.envpy ldb-1.4.1/buildtools/bin/waf
|
||||||
|
--- ldb-1.4.1/buildtools/bin/waf.envpy 2018-07-12 15:49:36.583918103 +0200
|
||||||
|
+++ ldb-1.4.1/buildtools/bin/waf 2018-07-12 15:50:09.572115218 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
+#!/usr/bin/python2
|
||||||
|
# encoding: ISO-8859-1
|
||||||
|
# Thomas Nagy, 2005-2010
|
||||||
|
|
20
ldb-hide-local-ABI-symbols.patch
Normal file
20
ldb-hide-local-ABI-symbols.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -up ldb-1.4.1/buildtools/wafsamba/samba_abi.py.sym_hide ldb-1.4.1/buildtools/wafsamba/samba_abi.py
|
||||||
|
--- ldb-1.4.1/buildtools/wafsamba/samba_abi.py.sym_hide 2018-07-12 15:55:14.973747103 +0200
|
||||||
|
+++ ldb-1.4.1/buildtools/wafsamba/samba_abi.py 2018-07-12 15:55:42.205887380 +0200
|
||||||
|
@@ -192,10 +192,12 @@ def abi_write_vscript(f, libname, curren
|
||||||
|
f.write("\t\t%s;\n" % x)
|
||||||
|
else:
|
||||||
|
f.write("\t\t*;\n")
|
||||||
|
- if abi_match != ["*"]:
|
||||||
|
- f.write("\tlocal:\n")
|
||||||
|
- for x in local_abi:
|
||||||
|
- f.write("\t\t%s;\n" % x[1:])
|
||||||
|
+ # Always hide symbols that must be local if exist
|
||||||
|
+ local_abi.extend(["!_end", "!_bss_start", "!_edata"])
|
||||||
|
+ f.write("\tlocal:\n")
|
||||||
|
+ for x in local_abi:
|
||||||
|
+ f.write("\t\t%s;\n" % x[1:])
|
||||||
|
+ if global_abi != ["*"]:
|
||||||
|
if len(global_abi) > 0:
|
||||||
|
f.write("\t\t*;\n")
|
||||||
|
f.write("};\n")
|
16
libldb.spec
16
libldb.spec
@ -13,8 +13,8 @@
|
|||||||
%global tevent_version 0.9.36
|
%global tevent_version 0.9.36
|
||||||
|
|
||||||
Name: libldb
|
Name: libldb
|
||||||
Version: 1.4.0
|
Version: 1.4.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A schema-less, ldap like, API and database
|
Summary: A schema-less, ldap like, API and database
|
||||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||||
Requires: libtdb%{?_isa} >= %{tdb_version}
|
Requires: libtdb%{?_isa} >= %{tdb_version}
|
||||||
@ -49,8 +49,9 @@ BuildRequires: python3-tevent
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
Patch0001: 0001-ldb-Fix-memory-leak-on-module-context.patch
|
Patch0001: ldb-dont-use-usr-bin-env-python.patch
|
||||||
Patch0002: 0002-ldb-Run-at-least-some-tests-on-32-bit-machines.patch
|
Patch0002: 0002-ldb-Run-at-least-some-tests-on-32-bit-machines.patch
|
||||||
|
Patch0003: ldb-hide-local-ABI-symbols.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
An extensible library that implements an LDAP like API to access remote LDAP
|
An extensible library that implements an LDAP like API to access remote LDAP
|
||||||
@ -136,8 +137,9 @@ Development files for the Python bindings for the LDB library
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n ldb-%{version}
|
%setup -q -n ldb-%{version}
|
||||||
%patch0001 -p3
|
%patch0001 -p1
|
||||||
%patch0002 -p3
|
%patch0002 -p3
|
||||||
|
%patch0003 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -253,6 +255,12 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 12 2018 Jakub Hrozek <jhrozek@redhat.com> - 1.4.1-1
|
||||||
|
- New upstream release 1.4.1
|
||||||
|
- Apply a patch to hide local ABI symbols to avoid issues with new binutils
|
||||||
|
- Patch the waf script to explicitly call python2 as "env python" doesn't
|
||||||
|
yield py2 anymore
|
||||||
|
|
||||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.0-2
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.0-2
|
||||||
- Rebuilt for Python 3.7
|
- Rebuilt for Python 3.7
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (ldb-1.4.0.tar.gz) = 95b024b5aceac0d6360f3c98e70e1f649c53fa0e849b0f3dbb7c46cf47fac718fd13c73dd1531cefaec19d3e6b0f6751b372d1fc814dd58dd288a6cf1dc57a6c
|
SHA512 (ldb-1.4.1.tar.gz) = 0e5b3ad4fa49893c86ca422e44d53c0af062e85e5085de18cdcaf2f05f0769cb2ecb65bad20cf93c5c2e115116ac2e1ec7f2d767678a3fffc9591d9db25e6f61
|
||||||
|
Loading…
Reference in New Issue
Block a user