rhbz#1683147 - libldb-2.0.5 is available
This commit is contained in:
parent
f542d96b3e
commit
507e6988dd
1
.gitignore
vendored
1
.gitignore
vendored
@ -43,3 +43,4 @@
|
||||
/ldb-1.5.3.tar.gz
|
||||
/ldb-1.5.4.tar.gz
|
||||
/ldb-1.5.5.tar.gz
|
||||
/ldb-2.0.5.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 87dfb0ce329447625050771fd83dae1841ece1b8 Mon Sep 17 00:00:00 2001
|
||||
From d4e0a07a24c16b38de58c14a38b418c63106ad09 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
||||
Date: Wed, 12 Jun 2019 13:38:17 +0200
|
||||
Subject: [PATCH] wafsamba: Fix few SyntaxWarnings caused by regular
|
||||
Date: Sat, 24 Aug 2019 16:46:30 +0200
|
||||
Subject: [PATCH] [PATCH] wafsamba: Fix few SyntaxWarnings caused by regular
|
||||
expressions
|
||||
|
||||
./buildtools/wafsamba/samba_utils.py:258: SyntaxWarning: invalid escape sequence \$
|
||||
@ -178,17 +178,18 @@ diff --git a/buildtools/wafsamba/symbols.py b/buildtools/wafsamba/symbols.py
|
||||
index 3eca3d46bd71cf0780b3c8e36a26b96bd3aa3b83..73e8ca8ce53ef5d956ac58e14a2403dd49f01109 100644
|
||||
--- a/buildtools/wafsamba/symbols.py
|
||||
+++ b/buildtools/wafsamba/symbols.py
|
||||
@@ -119,8 +119,8 @@ def find_ldd_path(bld, libname, binary):
|
||||
@@ -119,9 +119,9 @@ def find_ldd_path(bld, libname, binary):
|
||||
|
||||
|
||||
# some regular expressions for parsing readelf output
|
||||
-re_sharedlib = re.compile(b'Shared library: \[(.*)\]')
|
||||
-re_rpath = re.compile(b'Library rpath: \[(.*)\]')
|
||||
+re_sharedlib = re.compile(r'Shared library: \[(.*)\]')
|
||||
+re_rpath = re.compile(r'Library rpath: \[(.*)\]')
|
||||
# output from readelf could be `Library rpath` or `Libray runpath`
|
||||
-re_rpath = re.compile(b'Library (rpath|runpath): \[(.*)\]')
|
||||
+re_rpath = re.compile(r'Library (rpath|runpath): \[(.*)\]')
|
||||
|
||||
def get_libs(bld, binname):
|
||||
'''find the list of linked libraries for any binary or library
|
||||
--
|
||||
2.22.0
|
||||
2.23.0.rc2
|
||||
|
@ -1,60 +0,0 @@
|
||||
From c161c5d4a3184c0ae9a33d977f061458337d4ca1 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
||||
Date: Wed, 30 May 2018 23:22:40 +0200
|
||||
Subject: [PATCH] ldb: Run at least some tests on 32 bit machines
|
||||
|
||||
lmdb is supported only on 64 bit machines. But there also
|
||||
unit tests which pass just with tdb on 32 bit architectures.
|
||||
|
||||
Signed-off-by: Lukas Slebodnik <lslebodn@fedoraproject.org>
|
||||
---
|
||||
wscript | 19 +++++++++++--------
|
||||
1 file changed, 11 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/wscript b/wscript
|
||||
index ca0bf410f1029f33bab9b71514935011d57b1dbc..851344733645f51186d0b568f2741ac888a52660 100644
|
||||
--- a/wscript
|
||||
+++ b/wscript
|
||||
@@ -540,10 +540,6 @@ def test(ctx):
|
||||
env = samba_utils.LOAD_ENVIRONMENT()
|
||||
ctx.env = env
|
||||
|
||||
- if not env.HAVE_LMDB:
|
||||
- raise Errors.WafError('make test called, but ldb was built '
|
||||
- '--without-ldb-lmdb')
|
||||
-
|
||||
test_prefix = "%s/st" % (Context.g_module.out)
|
||||
shutil.rmtree(test_prefix, ignore_errors=True)
|
||||
os.makedirs(test_prefix)
|
||||
@@ -559,9 +555,13 @@ def test(ctx):
|
||||
tmp_dir = os.path.join(test_prefix, 'tmp')
|
||||
if not os.path.exists(tmp_dir):
|
||||
os.mkdir(tmp_dir)
|
||||
- pyret = samba_utils.RUN_PYTHON_TESTS(
|
||||
- ['tests/python/api.py', 'tests/python/index.py'],
|
||||
- extra_env={'SELFTEST_PREFIX': test_prefix})
|
||||
+
|
||||
+ if env.HAVE_LMDB:
|
||||
+ pyret = samba_utils.RUN_PYTHON_TESTS(
|
||||
+ ['tests/python/api.py', 'tests/python/index.py'],
|
||||
+ extra_env={'SELFTEST_PREFIX': test_prefix})
|
||||
+ else:
|
||||
+ pyret = 0
|
||||
print("Python testsuite returned %d" % pyret)
|
||||
|
||||
cmocka_ret = 0
|
||||
@@ -572,7 +572,10 @@ def test(ctx):
|
||||
'ldb_tdb_guid_mod_op_test',
|
||||
'ldb_msg_test',
|
||||
'ldb_tdb_kv_ops_test',
|
||||
- 'ldb_tdb_test',
|
||||
+ 'ldb_tdb_test']
|
||||
+
|
||||
+ if env.HAVE_LMDB:
|
||||
+ test_exes += [
|
||||
'ldb_mdb_mod_op_test',
|
||||
'ldb_lmdb_test',
|
||||
# we don't want to run ldb_lmdb_size_test (which proves we can
|
||||
--
|
||||
2.20.1
|
||||
|
20
libldb.spec
20
libldb.spec
@ -9,13 +9,13 @@
|
||||
%global with_python3 1
|
||||
%endif
|
||||
|
||||
%global talloc_version 2.1.16
|
||||
%global tdb_version 1.3.18
|
||||
%global tevent_version 0.9.39
|
||||
%global talloc_version 2.2.0
|
||||
%global tdb_version 1.4.1
|
||||
%global tevent_version 0.10.0
|
||||
|
||||
Name: libldb
|
||||
Version: 1.5.5
|
||||
Release: 3%{?dist}
|
||||
Version: 2.0.5
|
||||
Release: 1%{?dist}
|
||||
Summary: A schema-less, ldap like, API and database
|
||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||
Requires: libtdb%{?_isa} >= %{tdb_version}
|
||||
@ -25,9 +25,7 @@ URL: http://ldb.samba.org/
|
||||
Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
|
||||
|
||||
# Patches
|
||||
Patch0001: 0002-ldb-Run-at-least-some-tests-on-32-bit-machines.patch
|
||||
Patch0002: waflib-python38-pyembed.diff
|
||||
Patch0004: 0003-wafsamba-Fix-few-SyntaxWarnings-caused-by-regular-ex.patch
|
||||
Patch0001: 0001-PATCH-wafsamba-Fix-few-SyntaxWarnings-caused-by-regu.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libtalloc-devel >= %{talloc_version}
|
||||
@ -189,7 +187,7 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
||||
%if 0%{?with_python3}
|
||||
%files -n python3-ldb
|
||||
%{python3_sitearch}/ldb.cpython-*.so
|
||||
%{_libdir}/libpyldb-util.cpython-*.so.1*
|
||||
%{_libdir}/libpyldb-util.cpython-*.so.2*
|
||||
%{python3_sitearch}/_ldb_text.py
|
||||
%{python3_sitearch}/__pycache__/_ldb_text.cpython-*.py*
|
||||
|
||||
@ -201,6 +199,10 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Aug 26 2019 Guenther Deschner <gdeschner@redhat.com> - 2.0.5-1
|
||||
- rhbz#1683147 - libldb-2.0.5 is available
|
||||
- rhbz#1737644 - libldb, libtalloc, libtevent, libtdb: Remove Python 2 subpackages from Fedora 31+
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.5.5-3
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ldb-1.5.5.tar.gz) = 562e08b3d6564d08fed80dc43ca299c38fbd958dbe27ed1400e5eb5c3df0f4c7b7eaf502b13eec5544b168f26c5e6537615f65e28dcaeb6473d2ff3c3c7a4e4b
|
||||
SHA512 (ldb-2.0.5.tar.gz) = de9325f8bdd9ac782b3f8633444780f4aaa030e2c74c643220e845d9a779f8c8e174f0b9d9d8668de028cb832eb9d81965cb8e4471d90f9344dc48877a3abbe8
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff --git a/third_party/waf/waflib/Tools/python.py b/third_party/waf/waflib/Tools/python.py
|
||||
index 52a05c6..79836bb 100644
|
||||
--- a/third_party/waf/waflib/Tools/python.py
|
||||
+++ b/third_party/waf/waflib/Tools/python.py
|
||||
@@ -338,7 +338,11 @@ def check_python_headers(conf, features='pyembed pyext'):
|
||||
|
||||
if 'pyembed' in features:
|
||||
for flags in all_flags:
|
||||
- conf.check_cfg(msg='Asking python-config for pyembed %r flags' % ' '.join(flags), path=env.PYTHON_CONFIG, package='', uselib_store='PYEMBED', args=flags)
|
||||
+ embedflags = flags + ['--embed']
|
||||
+ try:
|
||||
+ conf.check_cfg(msg='Asking python-config for pyembed %r flags' % ' '.join(embedflags), path=env.PYTHON_CONFIG, package='', uselib_store='PYEMBED', args=embedflags)
|
||||
+ except conf.errors.ConfigurationError:
|
||||
+ conf.check_cfg(msg='Asking python-config for pyembed %r flags' % ' '.join(flags), path=env.PYTHON_CONFIG, package='', uselib_store='PYEMBED', args=flags)
|
||||
|
||||
try:
|
||||
conf.test_pyembed(xx)
|
Loading…
Reference in New Issue
Block a user