parent
7673bbf2d4
commit
4e15be0451
BIN
fixed-guidindexpackv1.ldb
Normal file
BIN
fixed-guidindexpackv1.ldb
Normal file
Binary file not shown.
39
ldb-2.3.0-fix-tests-on-aarch64.patch
Normal file
39
ldb-2.3.0-fix-tests-on-aarch64.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
From e90817629f1f7049cc0fe48f1003f5fb1103acc3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Gary Lockyer <gary@catalyst.net.nz>
|
||||||
|
Date: Thu, 22 Apr 2021 10:03:53 +0200
|
||||||
|
Subject: [PATCH 1/2] lib:ldb: Use a 1MiB lmdb so the test also passes on
|
||||||
|
aarch64 CentOS stream
|
||||||
|
|
||||||
|
Signed-off-by: Gary Lockyer <gary@catalyst.net.nz>
|
||||||
|
Reviewed-by: Andreas Schneider <asn@samba.org>
|
||||||
|
---
|
||||||
|
lib/ldb/tests/ldb_lmdb_free_list_test.c | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/ldb/tests/ldb_lmdb_free_list_test.c b/lib/ldb/tests/ldb_lmdb_free_list_test.c
|
||||||
|
index 9b295460730..c87620e7a87 100644
|
||||||
|
--- a/tests/ldb_lmdb_free_list_test.c
|
||||||
|
+++ b/tests/ldb_lmdb_free_list_test.c
|
||||||
|
@@ -77,7 +77,7 @@
|
||||||
|
#endif /* TEST_BE */
|
||||||
|
|
||||||
|
const int RECORD_SIZE = 6144;
|
||||||
|
-const int ITERATIONS = 3;
|
||||||
|
+const int ITERATIONS = 192;
|
||||||
|
|
||||||
|
struct test_ctx {
|
||||||
|
struct tevent_context *ev;
|
||||||
|
@@ -155,9 +155,9 @@ static int setup(void **state)
|
||||||
|
"@IDX_DN_GUID: GUID\n"
|
||||||
|
"\n";
|
||||||
|
/*
|
||||||
|
- * Use a 64KiB DB for this test
|
||||||
|
+ * Use a 1MiB DB for this test
|
||||||
|
*/
|
||||||
|
- const char *options[] = {"lmdb_env_size:65536", NULL};
|
||||||
|
+ const char *options[] = {"lmdb_env_size:1048576", NULL};
|
||||||
|
|
||||||
|
noconn_setup((void **)&test_ctx);
|
||||||
|
|
||||||
|
--
|
||||||
|
2.31.1
|
13
libldb.spec
13
libldb.spec
@ -25,7 +25,7 @@
|
|||||||
|
|
||||||
Name: libldb
|
Name: libldb
|
||||||
Version: 2.3.0
|
Version: 2.3.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: A schema-less, ldap like, API and database
|
Summary: A schema-less, ldap like, API and database
|
||||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||||
Requires: libtdb%{?_isa} >= %{tdb_version}
|
Requires: libtdb%{?_isa} >= %{tdb_version}
|
||||||
@ -36,9 +36,14 @@ Source0: https://www.samba.org/ftp/ldb/ldb-%{version}.tar.gz
|
|||||||
Source1: https://www.samba.org/ftp/ldb/ldb-%{version}.tar.asc
|
Source1: https://www.samba.org/ftp/ldb/ldb-%{version}.tar.asc
|
||||||
# gpg2 --no-default-keyring --keyring ./ldb.keyring --recv-keys 9147A339719518EE9011BCB54793916113084025
|
# gpg2 --no-default-keyring --keyring ./ldb.keyring --recv-keys 9147A339719518EE9011BCB54793916113084025
|
||||||
Source2: ldb.keyring
|
Source2: ldb.keyring
|
||||||
|
# binary diffs are not supported
|
||||||
|
# https://gitlab.com/samba-team/samba/-/merge_requests/1920
|
||||||
|
Source3: fixed-guidindexpackv1.ldb
|
||||||
|
|
||||||
# Patches
|
# Patches
|
||||||
Patch0001: 0001-PATCH-wafsamba-Fix-few-SyntaxWarnings-caused-by-regu.patch
|
Patch0001: 0001-PATCH-wafsamba-Fix-few-SyntaxWarnings-caused-by-regu.patch
|
||||||
|
# https://gitlab.com/samba-team/samba/-/merge_requests/1920
|
||||||
|
Patch0002: ldb-2.3.0-fix-tests-on-aarch64.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libtalloc-devel >= %{talloc_version}
|
BuildRequires: libtalloc-devel >= %{talloc_version}
|
||||||
@ -126,6 +131,9 @@ Development files for the Python bindings for the LDB library
|
|||||||
%prep
|
%prep
|
||||||
%autosetup -n ldb-%{version} -p1
|
%autosetup -n ldb-%{version} -p1
|
||||||
|
|
||||||
|
# binary diffs are not supported
|
||||||
|
cp -f %{SOURCE3} tests/guidindexpackv1.ldb
|
||||||
|
|
||||||
%build
|
%build
|
||||||
zcat %{SOURCE0} | gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} -
|
zcat %{SOURCE0} | gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} -
|
||||||
|
|
||||||
@ -223,6 +231,9 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 21 2021 Andreas Schneider <asn@redhat.com> - 2.3.0-3
|
||||||
|
- resolves: #1951285 - Fix ldb tests on aarch64
|
||||||
|
|
||||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.3.0-2
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.3.0-2
|
||||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user