New upstream release 1.1.6
- Drop upstream patches - Required for upcoming Samba 4 beta - Explicitly build with tdb1 support
This commit is contained in:
parent
fa3d9ab0b8
commit
38a3c0aeac
@ -1,13 +0,0 @@
|
||||
diff -ruN ldb-1.1.4.orig/buildtools/wafsamba/samba_bundled.py ldb-1.1.4/buildtools/wafsamba/samba_bundled.py
|
||||
--- ldb-1.1.4.orig/buildtools/wafsamba/samba_bundled.py 2011-11-14 12:01:10.000000000 -0500
|
||||
+++ ldb-1.1.4/buildtools/wafsamba/samba_bundled.py 2011-12-07 07:33:40.685193659 -0500
|
||||
@@ -228,7 +228,8 @@
|
||||
try:
|
||||
version = m.__version__
|
||||
except AttributeError:
|
||||
- found = False
|
||||
+ Logs.warn('WARNING: Could not determine if %s is of version %s or later. Assuming it is.' % (libname, minversion))
|
||||
+ found = True
|
||||
else:
|
||||
found = tuple(version.split(".")) >= tuple(minversion.split("."))
|
||||
if not found and not conf.LIB_MAY_BE_BUNDLED(libname):
|
30
libldb.spec
30
libldb.spec
@ -4,12 +4,12 @@
|
||||
%endif
|
||||
|
||||
%define talloc_version 2.0.7
|
||||
%define tdb_version 1.2.9
|
||||
%define tevent_version 0.9.14
|
||||
%define tdb_version 1.2.10
|
||||
%define tevent_version 0.9.15
|
||||
|
||||
Name: libldb
|
||||
Version: 1.1.4
|
||||
Release: 2%{?dist}
|
||||
Version: 1.1.6
|
||||
Release: 1%{?dist}
|
||||
Group: Development/Libraries
|
||||
Summary: A schema-less, ldap like, API and database
|
||||
Requires: libtalloc >= %{talloc_version}
|
||||
@ -44,8 +44,6 @@ Provides: bundled(libccan)
|
||||
|
||||
# Patches
|
||||
|
||||
Patch1001: FED01-fix-tevent-check.patch
|
||||
|
||||
%description
|
||||
An extensible library that implements an LDAP like API to access remote LDAP
|
||||
servers, or use local tdb databases.
|
||||
@ -90,20 +88,22 @@ Development files for the Python bindings for the LDB library
|
||||
%prep
|
||||
%setup -q -n ldb-%{version}
|
||||
|
||||
%patch1001 -p1
|
||||
|
||||
%build
|
||||
|
||||
# tdb_compat and ccan have no upstream releases to link against yet and their
|
||||
# API is in flux. It is unsafe to make them public and shared at this time.
|
||||
# Fedora doesn't yet support tdb2, so build against tdb1 for now
|
||||
%configure --disable-rpath \
|
||||
--disable-rpath-install \
|
||||
--bundled-libraries=NONE \
|
||||
--builtin-libraries=tdb_compat,ccan,replace \
|
||||
--with-modulesdir=%{_libdir}/ldb/modules \
|
||||
--with-privatelibdir=%{_libdir}/ldb
|
||||
--with-privatelibdir=%{_libdir}/ldb \
|
||||
--disable-tdb2
|
||||
|
||||
make V=1 %{?_smp_mflags}
|
||||
# Don't build with multiple processors
|
||||
# It breaks due to a threading issue in WAF
|
||||
make V=1
|
||||
doxygen Doxyfile
|
||||
|
||||
%install
|
||||
@ -163,6 +163,7 @@ rm -rf %{buildroot}
|
||||
|
||||
%{_libdir}/pkgconfig/ldb.pc
|
||||
%{_mandir}/man3/ldb*.gz
|
||||
%{_mandir}/man3/ldif*.gz
|
||||
|
||||
%files -n pyldb
|
||||
%defattr(-,root,root,-)
|
||||
@ -180,9 +181,18 @@ rm -rf %{buildroot}
|
||||
%postun -n pyldb -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Tue May 22 2012 Stephen Gallagher <sgallagh@redhat.com> - 1.1.6-1
|
||||
- New upstream release 1.1.6
|
||||
- Drop upstream patches
|
||||
- Required for upcoming Samba 4 beta
|
||||
- Explicitly build with tdb1 support
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Dec 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1.1
|
||||
- Do not build with multiple CPUs
|
||||
|
||||
* Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
|
||||
- New upstream release
|
||||
- Add ldb_module_error() routine
|
||||
|
Loading…
Reference in New Issue
Block a user