New upstream release 1.4.2
This commit is contained in:
parent
ebafbb50b2
commit
171f707588
1
.gitignore
vendored
1
.gitignore
vendored
@ -37,3 +37,4 @@
|
||||
/ldb-1.3.3.tar.gz
|
||||
/ldb-1.4.0.tar.gz
|
||||
/ldb-1.4.1.tar.gz
|
||||
/ldb-1.4.2.tar.gz
|
||||
|
@ -1,9 +0,0 @@
|
||||
diff -up ldb-1.4.1/buildtools/bin/waf.envpy ldb-1.4.1/buildtools/bin/waf
|
||||
--- ldb-1.4.1/buildtools/bin/waf.envpy 2018-07-12 15:49:36.583918103 +0200
|
||||
+++ ldb-1.4.1/buildtools/bin/waf 2018-07-12 15:50:09.572115218 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python2
|
||||
# encoding: ISO-8859-1
|
||||
# Thomas Nagy, 2005-2010
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up ldb-1.4.1/buildtools/wafsamba/samba_abi.py.sym_hide ldb-1.4.1/buildtools/wafsamba/samba_abi.py
|
||||
--- ldb-1.4.1/buildtools/wafsamba/samba_abi.py.sym_hide 2018-07-12 15:55:14.973747103 +0200
|
||||
+++ ldb-1.4.1/buildtools/wafsamba/samba_abi.py 2018-07-12 15:55:42.205887380 +0200
|
||||
@@ -192,10 +192,12 @@ def abi_write_vscript(f, libname, curren
|
||||
f.write("\t\t%s;\n" % x)
|
||||
else:
|
||||
f.write("\t\t*;\n")
|
||||
- if abi_match != ["*"]:
|
||||
- f.write("\tlocal:\n")
|
||||
- for x in local_abi:
|
||||
- f.write("\t\t%s;\n" % x[1:])
|
||||
+ # Always hide symbols that must be local if exist
|
||||
+ local_abi.extend(["!_end", "!_bss_start", "!_edata"])
|
||||
+ f.write("\tlocal:\n")
|
||||
+ for x in local_abi:
|
||||
+ f.write("\t\t%s;\n" % x[1:])
|
||||
+ if global_abi != ["*"]:
|
||||
if len(global_abi) > 0:
|
||||
f.write("\t\t*;\n")
|
||||
f.write("};\n")
|
17
libldb.spec
17
libldb.spec
@ -13,8 +13,8 @@
|
||||
%global tevent_version 0.9.36
|
||||
|
||||
Name: libldb
|
||||
Version: 1.4.1
|
||||
Release: 2%{?dist}
|
||||
Version: 1.4.2
|
||||
Release: 1%{?dist}
|
||||
Summary: A schema-less, ldap like, API and database
|
||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||
Requires: libtdb%{?_isa} >= %{tdb_version}
|
||||
@ -49,9 +49,7 @@ BuildRequires: python3-tevent
|
||||
%endif
|
||||
|
||||
# Patches
|
||||
Patch0001: ldb-dont-use-usr-bin-env-python.patch
|
||||
Patch0002: 0002-ldb-Run-at-least-some-tests-on-32-bit-machines.patch
|
||||
Patch0003: ldb-hide-local-ABI-symbols.patch
|
||||
Patch0001: 0002-ldb-Run-at-least-some-tests-on-32-bit-machines.patch
|
||||
|
||||
%description
|
||||
An extensible library that implements an LDAP like API to access remote LDAP
|
||||
@ -137,9 +135,7 @@ Development files for the Python bindings for the LDB library
|
||||
|
||||
%prep
|
||||
%setup -q -n ldb-%{version}
|
||||
%patch0001 -p1
|
||||
%patch0002 -p3
|
||||
%patch0003 -p1
|
||||
%patch0001 -p3
|
||||
|
||||
%build
|
||||
|
||||
@ -152,6 +148,8 @@ PY3_CONFIG_FLAGS=""
|
||||
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1217376
|
||||
export python_LDFLAGS=""
|
||||
|
||||
pathfix.py -n -p -i %{__python2} buildtools/bin/waf
|
||||
|
||||
%configure --disable-rpath \
|
||||
--disable-rpath-install \
|
||||
--bundled-libraries=NONE \
|
||||
@ -255,6 +253,9 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Aug 16 2018 Lukas Slebodnik <lslebodn@fedoraproject.org> - 1.4.2-1
|
||||
- New upstream release 1.4.2
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ldb-1.4.1.tar.gz) = 0e5b3ad4fa49893c86ca422e44d53c0af062e85e5085de18cdcaf2f05f0769cb2ecb65bad20cf93c5c2e115116ac2e1ec7f2d767678a3fffc9591d9db25e6f61
|
||||
SHA512 (ldb-1.4.2.tar.gz) = f2b44cebd0f8c77926aa364d9ac4ea37da4a780b94e7f9fba7a55fef825e90e469a3230e56cd2b23ce4f6b528dda9041863e4af77bb0826a117e8317a0b79070
|
||||
|
Loading…
Reference in New Issue
Block a user