Fix FTBFS / Increase the over-estimation for sparse files in tests
This commit is contained in:
parent
69d51729c5
commit
154efe221b
44
1420.patch
Normal file
44
1420.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 0e4fd77c1e03fe6351d129f2161b0b3313f5fa3d Mon Sep 17 00:00:00 2001
|
||||
From: Mathieu Parent <math.parent@gmail.com>
|
||||
Date: Thu, 25 Jun 2020 09:48:04 +0200
|
||||
Subject: [PATCH] Fix FTBFS / Increase the over-estimation for sparse files
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=14418
|
||||
Signed-off-by: Mathieu Parent <math.parent@gmail.com>
|
||||
---
|
||||
tests/ldb_kv_ops_test.c | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/ldb/tests/ldb_kv_ops_test.c b/lib/ldb/tests/ldb_kv_ops_test.c
|
||||
index 30adebf1952..9db2212895f 100644
|
||||
--- a/tests/ldb_kv_ops_test.c
|
||||
+++ b/tests/ldb_kv_ops_test.c
|
||||
@@ -1717,8 +1717,11 @@ static void test_get_size(void **state)
|
||||
/*
|
||||
* The tdb implementation of get_size over estimates for sparse files
|
||||
* which is perfectly acceptable for it's intended use.
|
||||
+ * mipsel, ia64: 9994
|
||||
+ * ppc64el, powerpc, ppc64: 13369
|
||||
+ * sparc64: 5046
|
||||
*/
|
||||
- assert_in_range(size, 2500, 5000);
|
||||
+ assert_in_range(size, 2500, 15000);
|
||||
#endif
|
||||
|
||||
/*
|
||||
@@ -1746,8 +1749,11 @@ static void test_get_size(void **state)
|
||||
/*
|
||||
* The tdb implementation of get_size over estimates for sparse files
|
||||
* which is perfectly acceptable for it's intended use.
|
||||
+ * mipsel, ia64: 9994
|
||||
+ * ppc64el, powerpc, ppc64: 13369
|
||||
+ * sparc64: 5046
|
||||
*/
|
||||
- assert_in_range(size, 2500, 5000);
|
||||
+ assert_in_range(size, 2500, 15000);
|
||||
#endif
|
||||
talloc_free(tmp_ctx);
|
||||
}
|
||||
--
|
||||
GitLab
|
||||
|
17
libldb.spec
17
libldb.spec
@ -25,7 +25,7 @@
|
||||
|
||||
Name: libldb
|
||||
Version: 2.2.0
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Summary: A schema-less, ldap like, API and database
|
||||
Requires: libtalloc%{?_isa} >= %{talloc_version}
|
||||
Requires: libtdb%{?_isa} >= %{tdb_version}
|
||||
@ -39,6 +39,8 @@ Source2: ldb.keyring
|
||||
|
||||
# Patches
|
||||
Patch0001: 0001-PATCH-wafsamba-Fix-few-SyntaxWarnings-caused-by-regu.patch
|
||||
# Fix FTBFS / Increase the over-estimation for sparse files
|
||||
Patch0002: https://gitlab.com/samba-team/samba/-/merge_requests/1420.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libtalloc-devel >= %{talloc_version}
|
||||
@ -125,16 +127,6 @@ Development files for the Python bindings for the LDB library
|
||||
%prep
|
||||
%autosetup -n ldb-%{version} -p1
|
||||
|
||||
%ifarch ppc64le
|
||||
echo patching test_get_size in tests/ldb_kv_ops_test.c
|
||||
#[ RUN ] test_get_size
|
||||
#[ FAILED ] test_get_size
|
||||
#[==========] 13 test(s) run.
|
||||
#[ ERROR ] --- 13369 is not within the range 2500-5000
|
||||
#[ LINE ] --- ../../tests/ldb_kv_ops_test.c:1721: error: Failure!
|
||||
sed -e 's/5000/15000/' -i tests/ldb_kv_ops_test.c
|
||||
%endif
|
||||
|
||||
%build
|
||||
zcat %{SOURCE0} | gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} -
|
||||
|
||||
@ -232,6 +224,9 @@ rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 29 2020 Andreas Schneider <asn@redhat.com> - 2.2.0-7
|
||||
- Fix FTBFS / Increase the over-estimation for sparse files in tests
|
||||
|
||||
* Tue Oct 27 2020 Andreas Schneider <asn@redhat.com> - 2.2.0-6
|
||||
- Spec file cleanup and improvements
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user