import libkkc-0.3.5-12.el8
This commit is contained in:
commit
2c41315a10
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/libkkc-0.3.5.tar.gz
|
1
.libkkc.metadata
Normal file
1
.libkkc.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
cf4339d375c8e4098a1c50cd6679f29b6b896708 SOURCES/libkkc-0.3.5.tar.gz
|
66
SOURCES/README.md
Normal file
66
SOURCES/README.md
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
libkkc - Japanese Kana Kanji conversion library
|
||||||
|
======
|
||||||
|
[![Build Status](https://travis-ci.org/ueno/libkkc.svg?branch=master)](https://travis-ci.org/ueno/libkkc) [![Coverage Status](https://img.shields.io/coveralls/ueno/libkkc.svg)](https://coveralls.io/r/ueno/libkkc)
|
||||||
|
|
||||||
|
What's this?
|
||||||
|
------
|
||||||
|
|
||||||
|
libkkc provides a converter from Kana-string to
|
||||||
|
Kana-Kanji-mixed-string. It was named after kkc.el in GNU Emacs, a
|
||||||
|
simple Kana Kanji converter, while libkkc tries to convert sentences
|
||||||
|
in a bit more complex way using N-gram language models.
|
||||||
|
|
||||||
|
Install
|
||||||
|
------
|
||||||
|
|
||||||
|
1. compile and install [marisa-trie](https://code.google.com/p/marisa-trie/)
|
||||||
|
|
||||||
|
2. compile and install
|
||||||
|
|
||||||
|
```
|
||||||
|
$ ./autogen.sh
|
||||||
|
$ make
|
||||||
|
$ make install
|
||||||
|
```
|
||||||
|
|
||||||
|
3. run kkc program
|
||||||
|
|
||||||
|
```
|
||||||
|
$ kkc
|
||||||
|
Type kana sentence in the following form:
|
||||||
|
SENTENCE [N-BEST [SEGMENT-BOUNDARY...]]
|
||||||
|
|
||||||
|
>> わたしのなまえはなかのです
|
||||||
|
0: <わたし/わたし><の/の><名前/なまえ><は/は><中野/なかの><で/で><す/す>
|
||||||
|
|
||||||
|
# get 3 matches instead of 1
|
||||||
|
>> わたしのなまえはなかのです 3
|
||||||
|
0: <わたし/わたし><の/の><名前/なまえ><は/は><中野/なかの><で/で><す/す>
|
||||||
|
1: <私/わたし><の/の><名前/なまえ><は/は><中野/なかの><で/で><す/す>
|
||||||
|
2: <わたし/わたし><の/の><名前/なまえ><は/は><中野/なかの><デス/です>
|
||||||
|
|
||||||
|
# enlarge the second segment (の -> のな)
|
||||||
|
>> わたしのなまえはなかのです 1 3 5
|
||||||
|
0: <わたし/わたし><のな/のな><前/まえ><は/は><中野/なかの><で/で><す/す>
|
||||||
|
|
||||||
|
# shrink the fourth segment (なかの -> なか)
|
||||||
|
>> わたしのなまえはなかのです 1 3 4 7 8 10
|
||||||
|
0: <わたし/わたし><の/の><名前/なまえ><は/は><中/なか><の/の><で/で><す/す>
|
||||||
|
```
|
||||||
|
|
||||||
|
License
|
||||||
|
------
|
||||||
|
```
|
||||||
|
GPLv3+
|
||||||
|
|
||||||
|
Copyright (C) 2011-2014 Daiki Ueno <ueno@gnu.org>
|
||||||
|
Copyright (C) 2011-2014 Red Hat, Inc.
|
||||||
|
|
||||||
|
This file is free software; as a special exception the author gives
|
||||||
|
unlimited permission to copy and/or distribute it, with or without
|
||||||
|
modifications, as long as this notice is preserved.
|
||||||
|
|
||||||
|
This file is distributed in the hope that it will be useful, but
|
||||||
|
WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
|
||||||
|
implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
|
||||||
|
```
|
3377
SOURCES/libkkc-HEAD.patch
Normal file
3377
SOURCES/libkkc-HEAD.patch
Normal file
File diff suppressed because it is too large
Load Diff
6
SOURCES/libkkc-POT.skip.patch
Normal file
6
SOURCES/libkkc-POT.skip.patch
Normal file
@ -0,0 +1,6 @@
|
|||||||
|
--- libkkc-0.3.5/po/POTFILES.skip~ 2014-12-19 11:40:01.000000000 +0900
|
||||||
|
+++ libkkc-0.3.5/po/POTFILES.skip 2017-12-13 19:22:46.016914774 +0900
|
||||||
|
@@ -1,2 +1,3 @@
|
||||||
|
+libkkc/keymap.c
|
||||||
|
tools/kkc.c
|
||||||
|
tools/server.c
|
257
SPECS/libkkc.spec
Normal file
257
SPECS/libkkc.spec
Normal file
@ -0,0 +1,257 @@
|
|||||||
|
%global dataversion 1:0.2.7
|
||||||
|
|
||||||
|
Name: libkkc
|
||||||
|
Version: 0.3.5
|
||||||
|
Release: 12%{?dist}
|
||||||
|
Summary: Japanese Kana Kanji conversion library
|
||||||
|
|
||||||
|
License: GPLv3+
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
URL: https://github.com/ueno/libkkc
|
||||||
|
Source0: https://github.com/ueno/libkkc/releases/download/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
# remove for next release:
|
||||||
|
Source1: README.md
|
||||||
|
Patch0: libkkc-HEAD.patch
|
||||||
|
Patch1: libkkc-POT.skip.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: marisa-devel
|
||||||
|
BuildRequires: vala
|
||||||
|
# Needed when any of *.vala files changed
|
||||||
|
BuildRequires: vala-tools, vala-devel
|
||||||
|
BuildRequires: pkgconfig(gee-0.8)
|
||||||
|
BuildRequires: json-glib-devel
|
||||||
|
BuildRequires: gobject-introspection-devel
|
||||||
|
BuildRequires: intltool
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: python3-marisa
|
||||||
|
|
||||||
|
Requires: skkdic
|
||||||
|
Requires: %{name}-data >= %{dataversion}
|
||||||
|
Requires: %{name}-common = %{version}-%{release}
|
||||||
|
|
||||||
|
%description
|
||||||
|
libkkc provides a converter from Kana-string to
|
||||||
|
Kana-Kanji-mixed-string. It was named after kkc.el in GNU Emacs, a
|
||||||
|
simple Kana Kanji converter, while libkkc tries to convert sentences
|
||||||
|
in a bit more complex way using N-gram language models.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%package tools
|
||||||
|
Summary: Tools for %{name}
|
||||||
|
Group: Development/Tools
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description tools
|
||||||
|
The %{name}-tools package contains tools for developing applications
|
||||||
|
that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%package common
|
||||||
|
Summary: Common data files for %{name}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description common
|
||||||
|
The %{name}-common package contains the arch-independent data that
|
||||||
|
%{name} uses at run time.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1 -b .HEAD
|
||||||
|
%patch1 -p1 -b .orig
|
||||||
|
|
||||||
|
[ -f README.md ] || cp -p %SOURCE1 .
|
||||||
|
autoreconf -f
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static --disable-silent-rules PYTHON=python3
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
make check
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install INSTALL="install -p"
|
||||||
|
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%doc README data/rules/README.rules COPYING
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
%{_libdir}/girepository-1.0/*.typelib
|
||||||
|
|
||||||
|
%files common
|
||||||
|
%{_datadir}/libkkc
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc
|
||||||
|
%{_includedir}/*
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
%{_datadir}/gir-1.0/*.gir
|
||||||
|
%{_datadir}/vala/vapi/*
|
||||||
|
|
||||||
|
%files tools
|
||||||
|
%{_bindir}/kkc*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Aug 01 2018 Takao Fujiwara <fujiwara@redhat.com> - 0.3.5-12
|
||||||
|
- enable python3
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 15 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.3.5-10
|
||||||
|
- Update Python 2 dependency declarations to new packaging standards
|
||||||
|
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Dec 13 2017 Jens Petersen <petersen@redhat.com> - 0.3.5-8
|
||||||
|
- update to latest github (253fb06)
|
||||||
|
- fixes FTBFS
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.5-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Feb 17 2015 Daiki Ueno <dueno@redhat.com> - 0.3.5-2
|
||||||
|
- apply libkkc-try-all.patch for better candidate list
|
||||||
|
|
||||||
|
* Fri Dec 19 2014 Daiki Ueno <dueno@redhat.com> - 0.3.5-1
|
||||||
|
- new upstream release
|
||||||
|
- switch upstream source location to Github
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 22 2014 Kalev Lember <kalevlember@gmail.com> - 0.3.4-2
|
||||||
|
- Rebuilt for gobject-introspection 1.41.4
|
||||||
|
|
||||||
|
* Mon Jul 7 2014 Daiki Ueno <dueno@redhat.com> - 0.3.4-1
|
||||||
|
- new upstream release
|
||||||
|
- switch to libgee 0.8
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 1 2014 Daiki Ueno <dueno@redhat.com> - 0.3.3-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Tue Dec 17 2013 Daiki Ueno <dueno@redhat.com> - 0.3.2-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Fri Sep 20 2013 Daiki Ueno <dueno@redhat.com> - 0.3.1-2
|
||||||
|
- drop -data subpackage, which is now split into a separate source package
|
||||||
|
|
||||||
|
* Sun Sep 15 2013 Daiki Ueno <dueno@redhat.com> - 0.3.1-1
|
||||||
|
- new upstreamm release
|
||||||
|
- fix numeric conversion
|
||||||
|
- add minimum cost of backward search
|
||||||
|
|
||||||
|
* Wed Sep 11 2013 Daiki Ueno <dueno@redhat.com> - 0.3.0-1
|
||||||
|
- new upstream release (Closes: #970863)
|
||||||
|
|
||||||
|
* Mon Jul 29 2013 Daiki Ueno <dueno@redhat.com> - 0.2.7-1
|
||||||
|
- new upstream release
|
||||||
|
- enable make check on %%check
|
||||||
|
- drop buildroot cleanup
|
||||||
|
|
||||||
|
* Fri Jul 5 2013 Daiki Ueno <dueno@redhat.com> - 0.2.6-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Thu Jul 4 2013 Daiki Ueno <dueno@redhat.com> - 0.2.5-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Fri Jun 7 2013 Daiki Ueno <dueno@redhat.com> - 0.2.4-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Wed May 15 2013 Daiki Ueno <dueno@redhat.com> - 0.2.3-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Wed May 8 2013 Daiki Ueno <dueno@redhat.com> - 0.2.2-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Wed May 1 2013 Daiki Ueno <dueno@redhat.com> - 0.2.1-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Wed May 1 2013 Daiki Ueno <dueno@redhat.com> - 0.2.0-2
|
||||||
|
- synch with the latest upstream git master
|
||||||
|
|
||||||
|
* Tue Apr 30 2013 Daiki Ueno <dueno@redhat.com> - 0.2.0-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Tue Mar 19 2013 Daiki Ueno <dueno@redhat.com> - 0.1.10-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Tue Mar 12 2013 Daiki Ueno <dueno@redhat.com> - 0.1.9-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Fri Feb 22 2013 Daiki Ueno <dueno@redhat.com> - 0.1.7-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Sun Feb 10 2013 Daiki Ueno <dueno@redhat.com> - 0.1.5-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Fri Feb 8 2013 Daiki Ueno <dueno@redhat.com> - 0.1.3-1
|
||||||
|
- move arch-independent data files to -common subpackage
|
||||||
|
- remove unnecessary R: from -common and -data subpackages
|
||||||
|
- add BR: python2-devel
|
||||||
|
|
||||||
|
* Thu Feb 7 2013 Daiki Ueno <dueno@redhat.com> - 0.1.3-1
|
||||||
|
- new upstream release
|
||||||
|
- add BR: marisa-python to generate -data package
|
||||||
|
|
||||||
|
* Wed Feb 6 2013 Daiki Ueno <dueno@redhat.com> - 0.1.2-2
|
||||||
|
- add ChangeLog to -data subpackages's %%doc
|
||||||
|
- remove unnecessary BR: libfep-devel
|
||||||
|
|
||||||
|
* Tue Feb 5 2013 Daiki Ueno <dueno@redhat.com> - 0.1.2-1
|
||||||
|
- new upstream release
|
||||||
|
- fix description of -data subpackage
|
||||||
|
- use popd instead of "cd -"
|
||||||
|
|
||||||
|
* Mon Feb 4 2013 Daiki Ueno <dueno@redhat.com> - 0.1.1-1
|
||||||
|
- new upstream release
|
||||||
|
- disable silent rules
|
||||||
|
|
||||||
|
* Thu Jan 31 2013 Daiki Ueno <dueno@redhat.com> - 0.1.0-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Thu Jan 24 2013 Daiki Ueno <dueno@redhat.com> - 0.0.1-1
|
||||||
|
- initial packaging
|
||||||
|
|
Loading…
Reference in New Issue
Block a user