Add missing script to the 'tests' package

This commit is contained in:
Ondrej Mosnacek 2018-08-09 10:27:29 +02:00
parent 29c28aa0c9
commit bb258cf923
2 changed files with 29 additions and 4 deletions

View File

@ -1,7 +1,7 @@
From 7223cbef97f346026e29de73f547b7074d8f5b94 Mon Sep 17 00:00:00 2001
From: Ondrej Mosnacek <omosnace@redhat.com>
Date: Mon, 6 Aug 2018 15:47:15 +0200
Subject: [PATCH 1/3] test: Remove an unnecessary hack
Subject: [PATCH 1/4] test: Remove an unnecessary hack
---
test/libtest.sh | 2 --
@ -24,7 +24,7 @@ index d969277..2a90d91 100644
From 0bc71e19b51a45dbcc6c3710d3d4ffed0707e68a Mon Sep 17 00:00:00 2001
From: Ondrej Mosnacek <omosnace@redhat.com>
Date: Tue, 7 Aug 2018 09:51:08 +0200
Subject: [PATCH 2/3] test: Allow running tests outside of build environment
Subject: [PATCH 2/4] test: Allow running tests outside of build environment
This patch slightly refactors the test scripts so they can be installed
along with the binaries and ran on the installed system. The old way of
@ -916,7 +916,7 @@ index c4a5c01..64c5d22 100755
From c7707ad1ddcbaa6f6722862cb4de9d3a3ea133b5 Mon Sep 17 00:00:00 2001
From: Ondrej Mosnacek <omosnace@redhat.com>
Date: Tue, 7 Aug 2018 18:43:08 +0200
Subject: [PATCH 3/3] test: Fix platform detection
Subject: [PATCH 3/4] test: Fix platform detection
---
test/libtest.sh | 12 ++++++++++--
@ -963,3 +963,25 @@ index 4a90a00..67be2d1 100644
local binlocation="$(find_app_binary $app)"
if ! [ -x "$binlocation" ]
then
From 291d62a006945a365645889aabf55549215c1304 Mon Sep 17 00:00:00 2001
From: Ondrej Mosnacek <omosnace@redhat.com>
Date: Thu, 9 Aug 2018 10:24:32 +0200
Subject: [PATCH 4/4] Makefile.am: Add missing test script
---
Makefile.am | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile.am b/Makefile.am
index c922f4e..635ccfd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,6 +117,7 @@ pkglibexec_SCRIPTS = test/libtest.sh \
test/kcapi-enc-test-large.sh \
test/kcapi-dgst-test.sh \
test/kcapi-convenience.sh \
+ test/kcapi-fuzz-test.sh \
test/hasher-test.sh \
test/compile-test.sh \
test/virttest.sh \

View File

@ -97,7 +97,7 @@ bin/kcapi-hasher -n fipshmac -d "$lib_path"/fipscheck \\\
Name: libkcapi
Version: %{vmajor}.%{vminor}.%{vpatch}
Release: 13%{?dist}
Release: 14%{?dist}
Summary: User space interface to the Linux Kernel Crypto API
License: BSD or GPLv2
@ -447,6 +447,9 @@ popd
%changelog
* Thu Aug 09 2018 Ondrej Mosnáček <omosnace@redhat.com> - 1.1.1-14
- Add missing script to the 'tests' package
* Wed Aug 08 2018 Ondrej Mosnáček <omosnace@redhat.com> - 1.1.1-13
- Add missing requires to the 'tests' subpackage