Add patch for proper pkgconfig location

This commit is contained in:
Björn Esser 2018-04-01 14:35:12 +02:00
parent 92ee9f5750
commit 250b716f2e
No known key found for this signature in database
GPG Key ID: F52E98007594C21D
2 changed files with 40 additions and 5 deletions

View File

@ -0,0 +1,39 @@
From f2ea3459e4d9e2f989bbc5fa5045bdac1742af9b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Sat, 31 Mar 2018 15:28:06 +0200
Subject: [PATCH] Makefile: Do not clobber pkgconfig-dir from configure
---
Makefile.am | 2 +-
configure.ac | 5 +++++
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index 8e195b6..15eadb1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,7 @@ man_MANS =
DOC_TARGETS =
-pkgconfigdir=$(libdir)/pkgconfig
+pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = libkcapi.pc
if DISABLE_LIB_SYM
diff --git a/configure.ac b/configure.ac
index aa89eef..b9554d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,6 +122,11 @@ if test "$with_lib_kpp" = "yes"; then
fi
PKG_INSTALLDIR
+if test "x$pkgconfigdir" = "x"; then
+ pkgconfigdir = "${libdir}/pkgconfig"
+fi
+AC_SUBST([pkgconfigdir], [$pkgconfigdir])
+
AC_CONFIG_FILES([libkcapi.pc])
AC_OUTPUT

View File

@ -88,6 +88,7 @@ Source0: http://www.chronox.de/%{name}/%{name}-%{version}.tar.xz
Source1: http://www.chronox.de/%{name}/%{name}-%{version}.tar.xz.asc
Patch0: %{giturl}/compare/v1.0.3...master.patch#/%{name}-1.0.3-to_master.patch
Patch1: %{giturl}/pull/48.patch#/%{name}-1.0.3-Makefile_Do_not_clobber_pkgconfig-dir_from_configure.patch
BuildRequires: clang
BuildRequires: coreutils
@ -312,10 +313,6 @@ EOF
%{__rm} -f %{buildroot}%{_bindir}/sha*hmac
%endif
# Move pkgconfig-dir to proper location.
%{__mkdir_p} %{buildroot}%{_libdir}
%{__mv} -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}
# We don't ship autocrap dumplings.
%{_bindir}/find %{buildroot} -type f -name '*.la' -print -delete
@ -431,7 +428,6 @@ popd
%changelog
* Sat Mar 31 2018 Björn Esser <besser82@fedoraproject.org> - 1.0.3-10
- Replace single patches with a monolitic one from upstream
- Move pkgconfig-dir to proper location
- Obsolete replacements subpackage
* Thu Mar 08 2018 Ondrej Mosnáček <omosnace@redhat.com> - 1.0.3-9