Update to 1.2.80 snapshot (#854695)
- run `make test` during build Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
b88bb6a47b
commit
cf6cdf69ef
@ -1,12 +1,14 @@
|
||||
%global snap 20130204svn922
|
||||
|
||||
Name: libjpeg-turbo
|
||||
Version: 1.2.1
|
||||
Release: 6%{?dist}
|
||||
Version: 1.2.90
|
||||
Release: 0.1.%{snap}%{?dist}
|
||||
Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: IJG
|
||||
URL: http://sourceforge.net/projects/libjpeg-turbo
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}-%{snap}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
@ -89,7 +91,7 @@ This package contains header files necessary for developing programs which
|
||||
will manipulate JPEG files using the TurboJPEG library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n %{name}-%{version}-%{snap}
|
||||
|
||||
%patch0 -p1 -b .noinst
|
||||
|
||||
@ -116,9 +118,15 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/libturbojpeg.a
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%post -n turbojpeg -p /sbin/ldconfig
|
||||
%postun -n turbojpeg -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc README README-turbo.txt change.log ChangeLog.txt
|
||||
@ -152,12 +160,17 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/libjpeg.a
|
||||
|
||||
%files -n turbojpeg
|
||||
%{_libdir}/libturbojpeg.so
|
||||
%{_libdir}/libturbojpeg.so.0*
|
||||
|
||||
%files -n turbojpeg-devel
|
||||
%{_includedir}/turbojpeg.h
|
||||
%{_libdir}/libturbojpeg.so
|
||||
|
||||
%changelog
|
||||
* Mon Feb 04 2013 Adam Tkac <atkac redhat com> 1.2.90-0.1.20130204svn922
|
||||
- update to 1.2.80 snapshot (#854695)
|
||||
- run `make test` during build
|
||||
|
||||
* Fri Jan 18 2013 Adam Tkac <atkac redhat com> 1.2.1-6
|
||||
- build with jpeg6 API/ABI (jpeg8-ABI feature was dropped)
|
||||
|
||||
|
@ -1,20 +1,20 @@
|
||||
diff -up libjpeg-turbo-1.2.0/Makefile.am.noinst_tjbench libjpeg-turbo-1.2.0/Makefile.am
|
||||
--- libjpeg-turbo-1.2.0/Makefile.am.noinst_tjbench 2012-02-10 04:47:55.000000000 +0100
|
||||
+++ libjpeg-turbo-1.2.0/Makefile.am 2012-03-08 15:56:43.081230011 +0100
|
||||
@@ -72,8 +72,8 @@ libjpeg_la_SOURCES += jsimd_none.c
|
||||
diff -up libjpeg-turbo-1.2.90-20130204svn922/Makefile.am.noinst libjpeg-turbo-1.2.90-20130204svn922/Makefile.am
|
||||
--- libjpeg-turbo-1.2.90-20130204svn922/Makefile.am.noinst 2013-01-19 02:06:46.000000000 +0100
|
||||
+++ libjpeg-turbo-1.2.90-20130204svn922/Makefile.am 2013-02-04 15:55:18.824110574 +0100
|
||||
@@ -89,9 +89,7 @@ noinst_PROGRAMS = jcstest
|
||||
|
||||
endif
|
||||
if WITH_TURBOJPEG
|
||||
|
||||
-bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom tjbench
|
||||
-noinst_PROGRAMS = tjunittest jcstest
|
||||
+bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom
|
||||
+noinst_PROGRAMS = tjunittest jcstest tjbench
|
||||
-bin_PROGRAMS += tjbench
|
||||
-
|
||||
-noinst_PROGRAMS += tjunittest
|
||||
+noinst_PROGRAMS += tjbench tjunittest
|
||||
|
||||
tjbench_SOURCES = tjbench.c bmp.h bmp.c tjutil.h tjutil.c rdbmp.c rdppm.c \
|
||||
wrbmp.c wrppm.c
|
||||
@@ -123,14 +123,6 @@ dist_man1_MANS = cjpeg.1 djpeg.1 jpegtra
|
||||
DOCS= install.txt coderules.txt filelist.txt jconfig.txt change.log \
|
||||
rdrle.c wrrle.c BUILDING.txt ChangeLog.txt
|
||||
@@ -144,14 +142,6 @@ dist_man1_MANS = cjpeg.1 djpeg.1 jpegtra
|
||||
DOCS= coderules.txt jconfig.txt change.log rdrle.c wrrle.c BUILDING.txt \
|
||||
ChangeLog.txt
|
||||
|
||||
-docdir = $(datadir)/doc
|
||||
-dist_doc_DATA = README README-turbo.txt libjpeg.txt structure.txt usage.txt \
|
||||
@ -24,6 +24,6 @@ diff -up libjpeg-turbo-1.2.0/Makefile.am.noinst_tjbench libjpeg-turbo-1.2.0/Make
|
||||
-dist_example_DATA = example.c
|
||||
-
|
||||
-
|
||||
EXTRA_DIST = win release $(DOCS) testimages CMakeLists.txt \
|
||||
EXTRA_DIST = win release $(DOCS) testimages md5cmp CMakeLists.txt \
|
||||
sharedlib/CMakeLists.txt cmakescripts libjpeg.map.in doc doxygen.config \
|
||||
jccolext.c jdcolext.c jdmrgext.c
|
||||
|
Loading…
Reference in New Issue
Block a user