Update to 1.2.0
Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
d9af4b2691
commit
78aa2b7718
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ libjpeg-turbo-1.0.0.tar.gz
|
||||
/libjpeg-turbo-1.0.90.tar.gz
|
||||
/libjpeg-turbo-1.1.0.tar.gz
|
||||
/libjpeg-turbo-1.1.1.tar.gz
|
||||
/libjpeg-turbo-1.2.0.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: libjpeg-turbo
|
||||
Version: 1.1.1
|
||||
Release: 4%{?dist}
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -21,7 +21,7 @@ Obsoletes: libjpeg < 6b-47
|
||||
# java-1.6.0-openjdk (#rh607554) -- atkac
|
||||
Provides: libjpeg = 6b-47
|
||||
|
||||
Patch0: libjpeg-turbo11-noinst_jpgtest.patch
|
||||
Patch0: libjpeg-turbo12-noinst.patch
|
||||
|
||||
%description
|
||||
The libjpeg-turbo package contains a library of functions for manipulating
|
||||
@ -88,7 +88,7 @@ will manipulate JPEG files using the TurboJPEG library.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .noinst_jpgtest
|
||||
%patch0 -p1 -b .noinst
|
||||
|
||||
%build
|
||||
autoreconf -fiv
|
||||
@ -118,7 +118,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc README README-turbo.txt change.log ChangeLog.txt LGPL.txt LICENSE.txt
|
||||
%doc README README-turbo.txt change.log ChangeLog.txt
|
||||
%{_libdir}/libjpeg.so.62.0.0
|
||||
%{_libdir}/libjpeg.so.62
|
||||
|
||||
@ -156,6 +156,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/turbojpeg.h
|
||||
|
||||
%changelog
|
||||
* Thu Mar 08 2012 Adam Tkac <atkac redhat com> 1.2.0-1
|
||||
- update to 1.2.0
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up libjpeg-turbo-1.1.0/Makefile.am.noinst_jpgtest libjpeg-turbo-1.1.0/Makefile.am
|
||||
--- libjpeg-turbo-1.1.0/Makefile.am.noinst_jpgtest 2011-03-01 14:40:04.291829489 +0100
|
||||
+++ libjpeg-turbo-1.1.0/Makefile.am 2011-03-01 14:40:13.081814233 +0100
|
||||
@@ -58,8 +58,8 @@ endif
|
||||
|
||||
TSTHDRS = rrutil.h rrtimer.h
|
||||
|
||||
-bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom jpgtest
|
||||
-noinst_PROGRAMS = jpegut
|
||||
+bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom
|
||||
+noinst_PROGRAMS = jpegut jpgtest
|
||||
|
||||
jpgtest_SOURCES = $(TSTHDRS) jpgtest.c bmp.h bmp.c
|
||||
|
29
libjpeg-turbo12-noinst.patch
Normal file
29
libjpeg-turbo12-noinst.patch
Normal file
@ -0,0 +1,29 @@
|
||||
diff -up libjpeg-turbo-1.2.0/Makefile.am.noinst_tjbench libjpeg-turbo-1.2.0/Makefile.am
|
||||
--- libjpeg-turbo-1.2.0/Makefile.am.noinst_tjbench 2012-02-10 04:47:55.000000000 +0100
|
||||
+++ libjpeg-turbo-1.2.0/Makefile.am 2012-03-08 15:56:43.081230011 +0100
|
||||
@@ -72,8 +72,8 @@ libjpeg_la_SOURCES += jsimd_none.c
|
||||
|
||||
endif
|
||||
|
||||
-bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom tjbench
|
||||
-noinst_PROGRAMS = tjunittest jcstest
|
||||
+bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom
|
||||
+noinst_PROGRAMS = tjunittest jcstest tjbench
|
||||
|
||||
tjbench_SOURCES = tjbench.c bmp.h bmp.c tjutil.h tjutil.c rdbmp.c rdppm.c \
|
||||
wrbmp.c wrppm.c
|
||||
@@ -123,14 +123,6 @@ dist_man1_MANS = cjpeg.1 djpeg.1 jpegtra
|
||||
DOCS= install.txt coderules.txt filelist.txt jconfig.txt change.log \
|
||||
rdrle.c wrrle.c BUILDING.txt ChangeLog.txt
|
||||
|
||||
-docdir = $(datadir)/doc
|
||||
-dist_doc_DATA = README README-turbo.txt libjpeg.txt structure.txt usage.txt \
|
||||
- wizard.txt
|
||||
-
|
||||
-exampledir = $(datadir)/doc
|
||||
-dist_example_DATA = example.c
|
||||
-
|
||||
-
|
||||
EXTRA_DIST = win release $(DOCS) testimages CMakeLists.txt \
|
||||
sharedlib/CMakeLists.txt cmakescripts libjpeg.map.in doc doxygen.config \
|
||||
jccolext.c jdcolext.c jdmrgext.c
|
Loading…
Reference in New Issue
Block a user