Initial import of libisoburn

This commit is contained in:
Robert Scheck 2011-10-07 23:38:13 +02:00
parent 329332884f
commit 2cb3afd62a
5 changed files with 177 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
libisoburn-1.1.2.tar.gz

View File

@ -0,0 +1,22 @@
Patch by Robert Scheck <robert@fedoraproject.org> for libisoburn >= 1.0.8, which solves multilib/
multiarch problem by removing the timestamp within the footer from the doxygen generated files.
--- libisoburn-1.0.8/doc/doxygen.conf.in 2011-02-23 14:43:07.000000000 +0100
+++ libisoburn-1.0.8/doc/doxygen.conf.in.multilib 2011-04-17 20:31:16.872988140 +0200
@@ -689,7 +689,7 @@
# each generated HTML page. If it is left blank doxygen will generate a
# standard footer.
-HTML_FOOTER =
+HTML_FOOTER = doc/footer_no_timestamp.html
# The HTML_STYLESHEET tag can be used to specify a user-defined cascading
# style sheet that is used by each HTML page. It can be used to
--- libisoburn-1.0.8/doc/footer_no_timestamp.html 1970-01-01 01:00:00.000000000 +0100
+++ libisoburn-1.0.8/doc/footer_no_timestamp.html.multilib 2011-04-17 20:31:27.817044448 +0200
@@ -0,0 +1,5 @@
+<hr size="1"><address style="text-align: right;"><small>Generated for $projectname by&nbsp;
+<a href="http://www.doxygen.org/index.html">
+<img src="doxygen.png" alt="doxygen" align="middle" border="0"></a> $doxygenversion </small></address>
+</body>
+</html>

139
libisoburn.spec Normal file
View File

@ -0,0 +1,139 @@
%global with_kde 1
Summary: Library to enable creation and expansion of ISO-9660 filesystems
Name: libisoburn
Version: 1.1.2
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Libraries
URL: http://libburnia-project.org/
Source0: http://files.libburnia-project.org/releases/%{name}-%{version}.tar.gz
Source1: xorriso_servicemenu.desktop
Patch0: libisoburn-1.0.8-multilib.patch
BuildRequires: libacl-devel, zlib-devel, doxygen, graphviz
BuildRequires: libburn-devel >= 1.1.0, libisofs-devel >= 1.1.2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
Libisoburn is a front-end for libraries libburn and libisofs which
enables creation and expansion of ISO-9660 filesystems on all CD/
DVD/BD media supported by libburn. This includes media like DVD+RW,
which do not support multi-session management on media level and
even plain disk files or block devices. Price for that is thorough
specialization on data files in ISO-9660 filesystem images. And so
libisoburn is not suitable for audio (CD-DA) or any other CD layout
which does not entirely consist of ISO-9660 sessions.
%package devel
Summary: Development files for libisoburn
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}, pkgconfig
%description devel
The libisoburn-devel package contains libraries and header files for
developing applications that use libisoburn.
%package -n xorriso
Summary: ISO-9660 and Rock Ridge image manipulation tool
Group: Applications/Archiving
URL: http://scdbackup.sourceforge.net/xorriso_eng.html
%if (%with_kde && 0%{?rhel}%{?fedora} > 5)
Requires: kde-filesystem >= 4
%endif
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
%description -n xorriso
Xorriso is a program which copies file objects from POSIX compliant
filesystems into Rock Ridge enhanced ISO-9660 filesystems and allows
session-wise manipulation of such filesystems. It can load management
information of existing ISO images and it writes the session results
to optical media or to filesystem objects. Vice versa xorriso is able
to copy file objects out of ISO-9660 filesystems.
Filesystem manipulation capabilities surpass those of mkisofs. Xorriso
is especially suitable for backups, because of its high fidelity of
file attribute recording and its incremental update sessions. Optical
supported media: CD-R, CD-RW, DVD-R, DVD-RW, DVD+R, DVD+R DL, DVD+RW,
DVD-RAM, BD-R and BD-RE.
%prep
%setup -q
%patch0 -p1 -b .multilib
%build
%configure --disable-static
sed -e 's/^hardcode_libdir_flag_spec=.*/hardcode_libdir_flag_spec=""/g' -i libtool
sed -e 's/^runpath_var=LD_RUN_PATH/runpath_var=DIE_RPATH_DIE/g' -i libtool
make %{?_smp_mflags}
doxygen doc/doxygen.conf
%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' install
# Don't install any libtool .la files
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}.la
# Install the KDE service menu handler
%if (%with_kde && 0%{?rhel}%{?fedora} > 5)
mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/ServiceMenus/
install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/kde4/services/ServiceMenus/
%endif
# Some file cleanups
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%post -n xorriso
/sbin/install-info %{_infodir}/xorriso.info.gz %{_infodir}/dir || :
/sbin/install-info %{_infodir}/xorrisofs.info.gz %{_infodir}/dir || :
%preun -n xorriso
if [ $1 = 0 ]; then
/sbin/install-info --delete %{_infodir}/xorriso.info.gz %{_infodir}/dir || :
/sbin/install-info --delete %{_infodir}/xorrisofs.info.gz %{_infodir}/dir || :
fi
%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING COPYRIGHT README ChangeLog
%{_libdir}/%{name}*.so.*
%files devel
%defattr(-,root,root,-)
%doc doc/html
%{_includedir}/%{name}
%{_libdir}/%{name}.so
%{_libdir}/pkgconfig/%{name}*.pc
%files -n xorriso
%defattr(-,root,root,-)
%{_bindir}/osirrox
%{_bindir}/xorrecord
%{_bindir}/xorriso
%{_bindir}/xorrisofs
%{_mandir}/man1/xorriso.1*
%{_mandir}/man1/xorrisofs.1*
%{_infodir}/xorriso.info*
%{_infodir}/xorrisofs.info*
%if (%with_kde && 0%{?rhel}%{?fedora} > 5)
%{_datadir}/kde4/services/ServiceMenus/xorriso_servicemenu.desktop
%endif
%changelog
* Sun Jul 10 2011 Robert Scheck <robert@fedoraproject.org> 1.1.2-1
- Upgrade to 1.1.2
* Mon May 02 2011 Robert Scheck <robert@fedoraproject.org> 1.0.8-2
- Added forgotten documentation files to %%files (#697326 #c1)
* Sun Apr 17 2011 Robert Scheck <robert@fedoraproject.org> 1.0.8-1
- Upgrade to 1.0.8
- Initial spec file for Fedora and Red Hat Enterprise Linux

View File

@ -0,0 +1 @@
07a8531e8693b8ad4093b12184da6d1c libisoburn-1.1.2.tar.gz

View File

@ -0,0 +1,14 @@
[Desktop Entry]
Type=Service
ServiceTypes=KonqPopupMenu/Plugin
MimeType=application/x-cd-image;
Actions=xorrisoExtractHere;
X-KDE-Priority=TopLevel
X-KDE-StartupNotify=false
[Desktop Action xorrisoExtractHere]
Name=Xorriso: extract ISO-image here
Name[de]=Xorriso: ISO-Abbild hier entpacken
Name[fi]=Xorriso: Pura ISO tiedosto tähän
Icon=media-optical
Exec=/bin/nice -n 19 ionice -n7 -c3 xorriso -indev "%F" -osirrox on -cp_rx "*" "$(dirname %F)"