libinput 1.12.902

This commit is contained in:
Peter Hutterer 2019-03-21 17:30:41 +10:00
parent c358832c15
commit b0b7bd9a11
3 changed files with 6 additions and 71 deletions

View File

@ -1,66 +0,0 @@
From b8123db0df7f1d358bcd2a1cc984095f4091fe61 Mon Sep 17 00:00:00 2001
From: Peter Hutterer <peter.hutterer@who-t.net>
Date: Fri, 15 Mar 2019 10:23:25 +1000
Subject: [PATCH libinput] meson.build: make valgrind optional
Now that we're providing the test suite as installed option, distributions
will likely include it as a test package. valgrind is only used for the
meson-specifc test setup. So let's make it optional.
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
---
.gitlab-ci.yml | 8 +++++---
meson.build | 30 +++++++++++++++++-------------
2 files changed, 22 insertions(+), 16 deletions(-)
diff --git a/meson.build b/meson.build
index 6e1e5590..cb3218b2 100644
--- a/meson.build
+++ b/meson.build
@@ -665,7 +665,6 @@ endif
# dependencies
if get_option('tests')
dep_check = dependency('check', version : '>= 0.9.10')
- valgrind = find_program('valgrind')
leftover_rules = find_program('test/check-leftover-udev-rules.sh')
test('leftover-rules', leftover_rules, is_parallel : false)
@@ -865,18 +864,23 @@ if get_option('tests')
libinput_test_runner,
args: ['--filter-deviceless'])
- valgrind_env = environment()
- valgrind_env.set('CK_FORK', 'no')
- valgrind_env.set('USING_VALGRIND', '1')
- valgrind_suppressions_file = join_paths(dir_src_test, 'valgrind.suppressions')
- add_test_setup('valgrind',
- exe_wrapper : [ valgrind,
- '--leak-check=full',
- '--gen-suppressions=all',
- '--error-exitcode=3',
- '--suppressions=' + valgrind_suppressions_file ],
- env : valgrind_env,
- timeout_multiplier : 100)
+ valgrind = find_program('valgrind', required : false)
+ if valgrind.found()
+ valgrind_env = environment()
+ valgrind_env.set('CK_FORK', 'no')
+ valgrind_env.set('USING_VALGRIND', '1')
+ valgrind_suppressions_file = join_paths(dir_src_test, 'valgrind.suppressions')
+ add_test_setup('valgrind',
+ exe_wrapper : [ valgrind,
+ '--leak-check=full',
+ '--gen-suppressions=all',
+ '--error-exitcode=3',
+ '--suppressions=' + valgrind_suppressions_file ],
+ env : valgrind_env,
+ timeout_multiplier : 100)
+ else
+ message('valgrind not found, disabling valgrind test suite')
+ endif
configure_file(output : 'litest-config.h',
install : false,
configuration : litest_config_h)
--
2.20.1

View File

@ -4,8 +4,8 @@
%global gitversion 58abea394
Name: libinput
Version: 1.12.901
Release: 3%{?gitdate:.%{gitdate}git%{gitversion}}%{?dist}
Version: 1.12.902
Release: 1%{?gitdate:.%{gitdate}git%{gitversion}}%{?dist}
Summary: Input device library
License: MIT
@ -18,8 +18,6 @@ Source2: commitid
Source0: http://www.freedesktop.org/software/libinput/libinput-%{version}.tar.xz
%endif
Patch01: 0001-meson.build-make-valgrind-optional.patch
BuildRequires: git-core
BuildRequires: gcc gcc-c++
BuildRequires: meson
@ -133,6 +131,9 @@ pathfix.py -i %{__python3} -p -n $(git grep -l '#!/usr/bin/.*python3')
%{_mandir}/man1/libinput-test-suite.1*
%changelog
* Thu Mar 21 2019 Peter Hutterer <peter.hutterer@redhat.com> 1.12.902-1
- libinput 1.12.902
* Thu Mar 21 2019 Peter Hutterer <peter.hutterer@redhat.com> 1.12.901-3
- Package the tests suite as subpackage

View File

@ -1 +1 @@
SHA512 (libinput-1.12.901.tar.xz) = 98801fc25cf56126d25d17128f7f344371a0edee5b762709dac22e272abcdf134d69d83fa9c014007fbc193079d447cd20b12563ae8a8c6844b3e3d191663f25
SHA512 (libinput-1.12.902.tar.xz) = f87379e95b057312b9c908f4b5948b93bc7d6b7cafae2fa6156e2dadd912361fc9a8f50c44419b9941b24e28765bbaab83e16af10caf7d59fd9dd489644aa075