import libindicator-12.10.1-14.el8

This commit is contained in:
CentOS Sources 2020-12-24 12:08:56 +00:00 committed by Andrew Lukoshko
commit ebf37393a4
4 changed files with 297 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/libindicator-12.10.1.tar.gz

1
.libindicator.metadata Normal file
View File

@ -0,0 +1 @@
25c8a0a150651ee6b2198df3f36fcbb49f0295c2 SOURCES/libindicator-12.10.1.tar.gz

67
SOURCES/covscan.patch Normal file
View File

@ -0,0 +1,67 @@
diff -up libindicator-12.10.1/libindicator/indicator-object.c.covscan libindicator-12.10.1/libindicator/indicator-object.c
--- libindicator-12.10.1/libindicator/indicator-object.c.covscan 2012-09-19 17:38:04.953839560 +0200
+++ libindicator-12.10.1/libindicator/indicator-object.c 2018-10-10 07:17:21.864398587 +0200
@@ -539,6 +539,7 @@ get_all_entries (IndicatorObject * io)
g_return_val_if_fail(INDICATOR_IS_OBJECT(io), NULL);
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_val_if_fail(INDICATOR_IS_OBJECT_CLASS(class), NULL);
if (class->get_entries == NULL)
g_error("No get_entries function on object. It must have been deleted?!?!");
@@ -635,6 +636,7 @@ indicator_object_get_location (Indicator
{
g_return_val_if_fail(INDICATOR_IS_OBJECT(io), 0);
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_val_if_fail(INDICATOR_IS_OBJECT_CLASS(class), 0);
if (class->get_location) {
return class->get_location(io, entry);
@@ -659,6 +661,7 @@ indicator_object_get_show_now (Indicator
{
g_return_val_if_fail(INDICATOR_IS_OBJECT(io), 0);
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_val_if_fail(INDICATOR_IS_OBJECT_CLASS(class), 0);
if (class->get_show_now) {
return class->get_show_now(io, entry);
@@ -688,6 +691,7 @@ indicator_object_entry_activate_window (
{
g_return_if_fail(INDICATOR_IS_OBJECT(io));
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_if_fail(INDICATOR_IS_OBJECT_CLASS(class));
if (class->entry_activate_window != NULL) {
return class->entry_activate_window(io, entry, windowid, timestamp);
@@ -714,6 +718,7 @@ indicator_object_entry_activate (Indicat
{
g_return_if_fail(INDICATOR_IS_OBJECT(io));
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_if_fail(INDICATOR_IS_OBJECT_CLASS(class));
if (class->entry_activate != NULL) {
return class->entry_activate(io, entry, timestamp);
@@ -736,6 +741,7 @@ indicator_object_entry_close (IndicatorO
{
g_return_if_fail(INDICATOR_IS_OBJECT(io));
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_if_fail(INDICATOR_IS_OBJECT_CLASS(class));
if (class->entry_close != NULL) {
return class->entry_close(io, entry, timestamp);
@@ -749,6 +755,7 @@ indicator_object_entry_being_removed (In
{
g_return_if_fail(INDICATOR_IS_OBJECT(io));
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_if_fail(INDICATOR_IS_OBJECT_CLASS(class));
entry_get_private (io, entry)->visibility = ENTRY_INVISIBLE;
@@ -766,6 +773,7 @@ indicator_object_entry_was_added (Indica
{
g_return_if_fail(INDICATOR_IS_OBJECT(io));
IndicatorObjectClass * class = INDICATOR_OBJECT_GET_CLASS(io);
+ g_return_if_fail(INDICATOR_IS_OBJECT_CLASS(class));
entry_get_private (io, entry)->visibility = ENTRY_VISIBLE;

228
SPECS/libindicator.spec Normal file
View File

@ -0,0 +1,228 @@
Name: libindicator
Version: 12.10.1
Release: 14%{?dist}
Summary: Shared functions for Ayatana indicators
License: GPLv3
URL: https://launchpad.net/libindicator
Source0: https://launchpad.net/libindicator/12.10/12.10.1/+download/%{name}-%{version}.tar.gz
Patch0: covscan.patch
BuildRequires: chrpath
BuildRequires: gtk-doc
BuildRequires: libtool
BuildRequires: pkgconfig
BuildRequires: dbus-glib-devel
BuildRequires: gtk3-devel
BuildRequires: gnome-common
%description
A set of symbols and convenience functions that all Ayatana indicators are
likely to use.
%package gtk3
Summary: GTK+3 build of %{name}
%description gtk3
A set of symbols and convenience functions that all Ayatana indicators
are likely to use. This is the GTK+ 3 build of %{name}, for use
by GTK+ 3 apps.
%package gtk3-devel
Summary: Development files for %{name}-gtk3
Requires: %{name}-gtk3%{?_isa} = %{version}-%{release}
Requires: pkgconfig
%description gtk3-devel
The %{name}-gtk3-devel package contains libraries and header files for
developing applications that use %{name}-gtk3.
%package gtk3-tools
Summary: Shared functions for Ayatana indicators - GTK3 Tools
Requires: %{name}-gtk3%{?_isa} = %{version}-%{release}
Requires: pkgconfig
%description gtk3-tools
This package contains tools used by the %{name}-gtk3 package, the
Ayatana indicators system. This package contains the builds of the
tools for the GTK+3 build of %{name}.
%prep
%setup -q
%patch0 -p1 -b .covscan
sed -i.addvar configure.ac \
-e '\@LIBINDICATOR_LIBS@s|\$LIBM| \$LIBM|'
# http://bazaar.launchpad.net/~indicator-applet-developers/libindicator/trunk.12.10/view/head:/autogen.sh
cat > autogen.sh <<EOF
#!/bin/sh
PKG_NAME="libindicator"
which gnome-autogen.sh || {
echo "You need gnome-common from GNOME SVN"
exit 1
}
USE_GNOME2_MACROS=1 \
. gnome-autogen.sh
EOF
NOCONFIGURE=1 \
sh autogen.sh
%build
export CFLAGS="%{optflags} -Wno-error=deprecated-declarations"
%configure --with-gtk=3 --disable-static --disable-silent-rules
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags}
%install
%make_install
(
PKG_CONFIG_PATH=%{buildroot}%{_libdir}/pkgconfig
export PKG_CONFIG_PATH
for var in \
iconsdir \
indicatordir \
%{nil}
do
vardir=$(pkg-config --variable=${var} indicator3-0.4)
mkdir -p %{buildroot}${vardir}
done
)
# Ubuntu doesn't package the dummy indicator
rm -f %{buildroot}%{_libdir}/libdummy-indicator*.so
rm -f %{buildroot}%{_datadir}/libindicator/80indicator-debugging
# Remove libtool files
find %{buildroot} -type f -name '*.la' -delete
%ldconfig_scriptlets gtk3
%files gtk3
%doc AUTHORS COPYING NEWS ChangeLog
%{_libdir}/libindicator3.so.*
%dir %{_datadir}/libindicator/
%dir %{_datadir}/libindicator/icons/
%{_libdir}/indicators3/
%files gtk3-devel
%dir %{_includedir}/libindicator3-0.4/
%dir %{_includedir}/libindicator3-0.4/libindicator/
%{_includedir}/libindicator3-0.4/libindicator/*.h
%{_libdir}/libindicator3.so
%{_libdir}/pkgconfig/indicator3-0.4.pc
%files gtk3-tools
%{_libexecdir}/indicator-loader3
%changelog
* Tue Oct 09 2018 Tomas Popela <tpopela@redhat.com> - 12.10.1-14
- Fix the Coverity scan warnings
- Resolves: rhbz#1637530
* Thu Jun 07 2018 Tomas Popela <tpopela@redhat.com> - 12.10.1-13
- Drop the gtk2 support
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 12.10.1-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 12.10.1-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 12.10.1-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 12.10.1-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Tue Nov 15 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 12.10.1-8
- Create and own indicatordir, iconsdir (bug 1392864)
* Thu Feb 4 2016 Mamoru TASAKA <mtasaka@fedoraproject.org> - 12.10.1-7
- F-24: fix FTBFS (variable expansion: perhaps due to bash behavior change)
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 12.10.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12.10.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12.10.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12.10.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12.10.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Thu May 30 2013 Eduardo Echeverria <echevemaster@gmail.com> - 12.10.1-1
- Update to 12.10.1
- Add GTK2 support
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.94-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.94-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Sat Mar 31 2012 Tom Callaway <spot@fedoraproject.org> - 0.4.94-2
- fix typo causing dep issues
* Sat Mar 31 2012 Tom Callaway <spot@fedoraproject.org> - 0.4.94-1
- Update to 0.4.94
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.22-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 0.3.22-2
- Rebuild for new libpng
* Wed Mar 23 2011 Adam Williamson <awilliam@redhat.com> - 0.3.22-1
- new release 0.3.22
* Mon Mar 07 2011 Adam Williamson <awilliam@redhat.com> - 0.3.20-1
- new release 0.3.20
* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> - 0.3.17-4
Rebuild against newer gtk3
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.17-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Wed Feb 2 2011 Matthias Clasen <mclasen@redhat.com> - 0.3.17-2
Rebuild against newer gtk3
* Sun Jan 23 2011 Adam Williamson <awilliam@redhat.com> - 0.3.17-1
- new version 0.3.17
- drop both patches (upstream)
- no need for autoreconf any more
* Mon Jan 10 2011 Matthias Clasen <mclasen@redhat.com> - 0.3.15-2
- Rebuild against newer gtk3
* Fri Dec 03 2010 Adam Williamson <awilliam@redhat.com> - 0.3.15-1
- initial package