Upgrade to 0.16 (#1416642)
This commit is contained in:
parent
6be7860e0f
commit
bc1d041468
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
libidn2-*.tar.gz
|
/libidn2-*.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
Patch by Robert Scheck <robert@fedoraproject.org> for libidn2 >= 0.3, which works
|
Patch by Robert Scheck <robert@fedoraproject.org> for libidn2 >= 0.16, which works
|
||||||
around the broken libtool of Debian. Multilib/multiarch systems like Fedora or Red
|
around the broken libtool of Debian. Multilib/multiarch systems like Fedora or Red
|
||||||
Hat Enterprise Linux are using /usr/lib64 for 64 bit libraries and /usr/lib is used
|
Hat Enterprise Linux are using /usr/lib64 for 64 bit libraries and /usr/lib is used
|
||||||
for 32 bit libraries. That allows to run 32 bit software on 64 bit systems. Debian
|
for 32 bit libraries. That allows to run 32 bit software on 64 bit systems. Debian
|
||||||
@ -26,7 +26,7 @@ hunks are runtime-only if configure file has been already generated) or by runni
|
|||||||
the following sed command after each aclocal run within the upstream build system:
|
the following sed command after each aclocal run within the upstream build system:
|
||||||
|
|
||||||
sed -e 's@\(# Append ld.so.conf contents to the search path\)@# Add ABI-specific directories to the system library path.\n sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"\n\n \1@' \
|
sed -e 's@\(# Append ld.so.conf contents to the search path\)@# Add ABI-specific directories to the system library path.\n sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"\n\n \1@' \
|
||||||
-e 's@/lib /usr/lib $lt_ld_extra@$sys_lib_dlsearch_path_spec $lt_ld_extra@' -i libidn2-0.3/m4/libtool.m4
|
-e 's@/lib /usr/lib $lt_ld_extra@$sys_lib_dlsearch_path_spec $lt_ld_extra@' -i libidn2-0.16/m4/libtool.m4
|
||||||
|
|
||||||
More information regarding this topic can be found for example at:
|
More information regarding this topic can be found for example at:
|
||||||
|
|
||||||
@ -34,9 +34,9 @@ More information regarding this topic can be found for example at:
|
|||||||
- http://lists.gnu.org/archive/html/libtool/2009-01/msg00039.html
|
- http://lists.gnu.org/archive/html/libtool/2009-01/msg00039.html
|
||||||
- http://thread.gmane.org/gmane.comp.gnu.libtool.general/8339/focus=8345
|
- http://thread.gmane.org/gmane.comp.gnu.libtool.general/8339/focus=8345
|
||||||
|
|
||||||
--- libidn2-0.3/configure 2011-04-20 01:23:30.000000000 +0200
|
--- libidn2-0.16/configure 2017-01-16 08:44:58.000000000 +0100
|
||||||
+++ libidn2-0.3/configure.rpath 2011-05-07 20:23:02.606829209 +0200
|
+++ libidn2-0.16/configure.rpath 2017-01-27 01:33:19.957032530 +0100
|
||||||
@@ -10703,10 +10703,13 @@
|
@@ -12363,10 +12363,13 @@
|
||||||
# before this can be enabled.
|
# before this can be enabled.
|
||||||
hardcode_into_libs=yes
|
hardcode_into_libs=yes
|
||||||
|
|
||||||
@ -51,26 +51,9 @@ More information regarding this topic can be found for example at:
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||||
--- libidn2-0.3/src/configure 2011-04-20 01:23:54.000000000 +0200
|
--- libidn2-0.16/m4/libtool.m4 2017-01-16 08:44:18.000000000 +0100
|
||||||
+++ libidn2-0.3/src/configure.rpath 2011-05-07 20:24:25.959753622 +0200
|
+++ libidn2-0.16/m4/libtool.m4.rpath 2017-01-27 01:34:19.469749808 +0100
|
||||||
@@ -10486,10 +10486,13 @@
|
@@ -2672,10 +2672,13 @@
|
||||||
# before this can be enabled.
|
|
||||||
hardcode_into_libs=yes
|
|
||||||
|
|
||||||
+ # Add ABI-specific directories to the system library path.
|
|
||||||
+ sys_lib_dlsearch_path_spec="/lib64 /usr/lib64 /lib /usr/lib"
|
|
||||||
+
|
|
||||||
# Append ld.so.conf contents to the search path
|
|
||||||
if test -f /etc/ld.so.conf; then
|
|
||||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
|
||||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
|
||||||
+ sys_lib_dlsearch_path_spec="$sys_lib_dlsearch_path_spec $lt_ld_extra"
|
|
||||||
fi
|
|
||||||
|
|
||||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
|
||||||
--- libidn2-0.3/m4/libtool.m4 2011-04-20 01:23:26.000000000 +0200
|
|
||||||
+++ libidn2-0.3/m4/libtool.m4.rpath 2011-05-07 20:23:47.214717341 +0200
|
|
||||||
@@ -2474,10 +2474,13 @@
|
|
||||||
# before this can be enabled.
|
# before this can be enabled.
|
||||||
hardcode_into_libs=yes
|
hardcode_into_libs=yes
|
||||||
|
|
17
libidn2.spec
17
libidn2.spec
@ -1,12 +1,13 @@
|
|||||||
Summary: Library to support IDNA2008 internationalized domain names
|
Summary: Library to support IDNA2008 internationalized domain names
|
||||||
Name: libidn2
|
Name: libidn2
|
||||||
Version: 0.11
|
Version: 0.16
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: (GPLv2+ or LGPLv3+) and GPLv3+
|
License: (GPLv2+ or LGPLv3+) and GPLv3+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.gnu.org/software/libidn/#libidn2
|
URL: https://www.gnu.org/software/libidn/#libidn2
|
||||||
Source: http://alpha.gnu.org/gnu/libidn/%{name}-%{version}.tar.gz
|
Source: https://alpha.gnu.org/gnu/libidn/%{name}-%{version}.tar.gz
|
||||||
Patch0: libidn2-0.3-rpath.patch
|
Patch0: libidn2-0.16-rpath.patch
|
||||||
|
BuildRequires: libunistring-devel
|
||||||
Requires(post): /sbin/install-info, /sbin/ldconfig
|
Requires(post): /sbin/install-info, /sbin/ldconfig
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
Requires(postun): /sbin/ldconfig
|
Requires(postun): /sbin/ldconfig
|
||||||
@ -15,8 +16,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|||||||
|
|
||||||
%description
|
%description
|
||||||
Libidn2 is an implementation of the IDNA2008 specifications in RFC
|
Libidn2 is an implementation of the IDNA2008 specifications in RFC
|
||||||
5890, 5891, 5892 and 5893 for internationalized domain names (IDN).
|
5890, 5891, 5892, 5893 and TR46 for internationalized domain names
|
||||||
It is a standalone library, without any dependency on libidn.
|
(IDN). It is a standalone library, without any dependency on libidn.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Development files for libidn2
|
Summary: Development files for libidn2
|
||||||
@ -31,7 +32,6 @@ developing applications that use libidn2.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .rpath
|
%patch0 -p1 -b .rpath
|
||||||
touch -c -r configure.rpath configure
|
touch -c -r configure.rpath configure
|
||||||
touch -c -r src/configure.rpath src/configure
|
|
||||||
touch -c -r m4/libtool.m4.rpath m4/libtool.m4
|
touch -c -r m4/libtool.m4.rpath m4/libtool.m4
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -91,6 +91,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/gtk-doc/
|
%{_datadir}/gtk-doc/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 27 2017 Robert Scheck <robert@fedoraproject.org> 0.16-1
|
||||||
|
- Upgrade to 0.16 (#1416642)
|
||||||
|
|
||||||
* Mon Nov 21 2016 Robert Scheck <robert@fedoraproject.org> 0.11-1
|
* Mon Nov 21 2016 Robert Scheck <robert@fedoraproject.org> 0.11-1
|
||||||
- Upgrade to 0.11
|
- Upgrade to 0.11
|
||||||
- Reflect dual-licensing of library in license tag (#1397021)
|
- Reflect dual-licensing of library in license tag (#1397021)
|
||||||
|
Loading…
Reference in New Issue
Block a user