parent
373aa1e469
commit
8437cec6c1
@ -1,117 +0,0 @@
|
||||
https://gitlab.com/libidn/libidn2/commit/204dd34f2ce95b71a7f56ffe97b9019fb91db49c
|
||||
|
||||
--- libidn2-2.0.3/configure.ac 2017-07-24 10:53:59.000000000 +0200
|
||||
+++ libidn2-2.0.3/configure.ac.docs 2017-08-01 00:27:44.000000000 +0200
|
||||
@@ -95,17 +95,6 @@
|
||||
enable_doc=$enableval, enable_doc=yes)
|
||||
AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" != "no")
|
||||
|
||||
-if test "$enable_doc" = "yes"; then
|
||||
- AC_CHECK_PROG([RONN], [ronn], [ronn], [:])
|
||||
- if test "$ac_cv_prog_RONN" = ":"; then
|
||||
- AC_MSG_ERROR([You need the 'ronn' tool to generate the idn2.1 man page])
|
||||
- fi
|
||||
- AC_CHECK_PROG([MAKEINFO], [makeinfo], [makeinfo], [:])
|
||||
- if test "$ac_cv_prog_MAKEINFO" = ":"; then
|
||||
- AC_MSG_ERROR([You need the 'makeinfo' tool to generate the info pages])
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
if test "$ac_cv_libunistring" = "yes";then
|
||||
AC_SEARCH_LIBS(uc_joining_type, unistring, [], [ac_cv_libunistring=no])
|
||||
fi
|
||||
--- libidn2-2.0.3/configure 2017-07-24 11:05:20.000000000 +0200
|
||||
+++ libidn2-2.0.3/configure.docs 2017-08-01 00:28:21.000000000 +0200
|
||||
@@ -28283,92 +28283,6 @@
|
||||
ENABLE_DOC_FALSE=
|
||||
fi
|
||||
|
||||
-
|
||||
-if test "$enable_doc" = "yes"; then
|
||||
- # Extract the first word of "ronn", so it can be a program name with args.
|
||||
-set dummy ronn; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_prog_RONN+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- if test -n "$RONN"; then
|
||||
- ac_cv_prog_RONN="$RONN" # Let the user override the test.
|
||||
-else
|
||||
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
- ac_cv_prog_RONN="ronn"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
- test -z "$ac_cv_prog_RONN" && ac_cv_prog_RONN=":"
|
||||
-fi
|
||||
-fi
|
||||
-RONN=$ac_cv_prog_RONN
|
||||
-if test -n "$RONN"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $RONN" >&5
|
||||
-$as_echo "$RONN" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
- if test "$ac_cv_prog_RONN" = ":"; then
|
||||
- as_fn_error $? "You need the 'ronn' tool to generate the idn2.1 man page" "$LINENO" 5
|
||||
- fi
|
||||
- # Extract the first word of "makeinfo", so it can be a program name with args.
|
||||
-set dummy makeinfo; ac_word=$2
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
||||
-$as_echo_n "checking for $ac_word... " >&6; }
|
||||
-if ${ac_cv_prog_MAKEINFO+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- if test -n "$MAKEINFO"; then
|
||||
- ac_cv_prog_MAKEINFO="$MAKEINFO" # Let the user override the test.
|
||||
-else
|
||||
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
||||
-for as_dir in $PATH
|
||||
-do
|
||||
- IFS=$as_save_IFS
|
||||
- test -z "$as_dir" && as_dir=.
|
||||
- for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
- ac_cv_prog_MAKEINFO="makeinfo"
|
||||
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
- break 2
|
||||
- fi
|
||||
-done
|
||||
- done
|
||||
-IFS=$as_save_IFS
|
||||
-
|
||||
- test -z "$ac_cv_prog_MAKEINFO" && ac_cv_prog_MAKEINFO=":"
|
||||
-fi
|
||||
-fi
|
||||
-MAKEINFO=$ac_cv_prog_MAKEINFO
|
||||
-if test -n "$MAKEINFO"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $MAKEINFO" >&5
|
||||
-$as_echo "$MAKEINFO" >&6; }
|
||||
-else
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
-$as_echo "no" >&6; }
|
||||
-fi
|
||||
-
|
||||
-
|
||||
- if test "$ac_cv_prog_MAKEINFO" = ":"; then
|
||||
- as_fn_error $? "You need the 'makeinfo' tool to generate the info pages" "$LINENO" 5
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
if test "$ac_cv_libunistring" = "yes";then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing uc_joining_type" >&5
|
||||
$as_echo_n "checking for library containing uc_joining_type... " >&6; }
|
@ -1,6 +1,6 @@
|
||||
Summary: Library to support IDNA2008 internationalized domain names
|
||||
Name: libidn2
|
||||
Version: 2.0.3
|
||||
Version: 2.0.4
|
||||
Release: 1%{?dist}
|
||||
License: (GPLv2+ or LGPLv3+) and GPLv3+
|
||||
Group: System Environment/Libraries
|
||||
@ -8,7 +8,6 @@ URL: https://www.gnu.org/software/libidn/#libidn2
|
||||
Source0: https://ftp.gnu.org/gnu/libidn/%{name}-%{version}.tar.gz
|
||||
Source1: https://ftp.gnu.org/gnu/libidn/%{name}-%{version}.tar.gz.sig
|
||||
Patch0: libidn2-2.0.0-rpath.patch
|
||||
Patch1: libidn2-2.0.3-docs.patch
|
||||
BuildRequires: libunistring-devel
|
||||
Requires(post): /sbin/install-info, /sbin/ldconfig
|
||||
Requires(preun): /sbin/install-info
|
||||
@ -33,8 +32,6 @@ developing applications that use libidn2.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .rpath
|
||||
%patch1 -p1 -b .docs
|
||||
touch -c -r configure.ac.docs configure.ac
|
||||
touch -c -r configure.rpath configure
|
||||
touch -c -r m4/libtool.m4.rpath m4/libtool.m4
|
||||
|
||||
@ -93,6 +90,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/gtk-doc/
|
||||
|
||||
%changelog
|
||||
* Wed Aug 30 2017 Robert Scheck <robert@fedoraproject.org> 2.0.4-1
|
||||
- Upgrade to 2.0.4 (#1486881, #1486882)
|
||||
|
||||
* Tue Aug 01 2017 Robert Scheck <robert@fedoraproject.org> 2.0.3-1
|
||||
- Upgrade to 2.0.3 (#1468608, #1474324)
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (libidn2-2.0.3.tar.gz) = 1a9f20ff1b57e69d78fe4c3e4b235bda41d6ce963f7604e3604c1164ec10d3e3069bcdf78cef820bf2e8bf481fd4ebae5571d4be66bece1b43d006e1acb7622b
|
||||
SHA512 (libidn2-2.0.3.tar.gz.sig) = b28f3d3ac57db72693e4e300b2a0774b583e33525cb615d53d3db4da216bb6b193aeaaf6c5b6d5b5ec990a49cde7b0b7fc7d110f1da55d151464ecbb5ecbd21d
|
||||
SHA512 (libidn2-2.0.4.tar.gz) = 1e51bd4b8f8907531576291f1c2a8865d17429b4105418b4c98754eb982cd1cbb3adbeab4ec0c1c561d2dba11d876c7c09e5dc5b315c55a2c24986d7a2a3b4d2
|
||||
SHA512 (libidn2-2.0.4.tar.gz.sig) = 8b30f47837ed451b9ee0ab1bf474861691084205012763f5a9219adb5f06f02cc7b4e6e9dc2e3a980c92c0e27877c03db57e585f88ba4cadbdcd1a4f68264951
|
||||
|
Loading…
Reference in New Issue
Block a user