- Fixed linkage problems and disabled parallel build till upstream accepts
fix.
This commit is contained in:
parent
3f419a32e1
commit
ac80e7de3d
32
libical-0.31-makefile.patch
Normal file
32
libical-0.31-makefile.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff -urNp libical-0.31.orig/src/libical/Makefile.in libical-0.31/src/libical/Makefile.in
|
||||||
|
--- libical-0.31.orig/src/libical/Makefile.in 2008-07-27 16:32:25.000000000 +0530
|
||||||
|
+++ libical-0.31/src/libical/Makefile.in 2008-07-27 16:55:45.000000000 +0530
|
||||||
|
@@ -105,7 +105,7 @@ am_libical_la_OBJECTS = $(am__objects_2)
|
||||||
|
icalduration.lo icalperiod.lo icaltypes.lo icalvalue.lo pvl.lo \
|
||||||
|
sspm.lo vsnprintf.lo icallangbind.lo caldate.lo
|
||||||
|
libical_la_OBJECTS = $(am_libical_la_OBJECTS)
|
||||||
|
-libical_cxx_la_LIBADD =
|
||||||
|
+libical_cxx_la_LIBADD = $(PTHREAD_LIBS)
|
||||||
|
am__libical_cxx_la_SOURCES_DIST = icalderivedparameter.h \
|
||||||
|
icalderivedproperty.h icalderivedvalue.h \
|
||||||
|
icalderivedparameter.c icalderivedproperty.c icalrestriction.c \
|
||||||
|
diff -urNp libical-0.31.orig/src/libicalss/Makefile.in libical-0.31/src/libicalss/Makefile.in
|
||||||
|
--- libical-0.31.orig/src/libicalss/Makefile.in 2008-07-27 16:32:25.000000000 +0530
|
||||||
|
+++ libical-0.31/src/libicalss/Makefile.in 2008-07-27 17:18:55.000000000 +0530
|
||||||
|
@@ -103,7 +103,6 @@ am_libicalss_la_OBJECTS = icalcalendar.l
|
||||||
|
icalset.lo icalspanlist.lo icalmessage.lo $(am__objects_1) \
|
||||||
|
$(am__objects_2)
|
||||||
|
libicalss_la_OBJECTS = $(am_libicalss_la_OBJECTS)
|
||||||
|
-libicalss_cxx_la_LIBADD =
|
||||||
|
am__libicalss_cxx_la_SOURCES_DIST = icalspanlist_cxx.h \
|
||||||
|
icalspanlist_cxx.cpp
|
||||||
|
@WITH_CXX_BINDINGS_TRUE@am_libicalss_cxx_la_OBJECTS = \
|
||||||
|
@@ -352,6 +351,8 @@ COMBINEDHEADERS = \
|
||||||
|
$(srcdir)/icalspanlist.h \
|
||||||
|
$(srcdir)/icalmessage.h
|
||||||
|
|
||||||
|
+libicalss_cxx_la_LIBADD = ./.libs/libicalss.la
|
||||||
|
+libicalss_cxx_la_DEPENDENCIES = ./.libs/libicalss.la
|
||||||
|
@WITH_CXX_BINDINGS_TRUE@libicalss_cxx_la_SOURCES = \
|
||||||
|
@WITH_CXX_BINDINGS_TRUE@ $(libicalss_evolution_la_SOURCES) \
|
||||||
|
@WITH_CXX_BINDINGS_TRUE@ icalspanlist_cxx.h \
|
18
libical.spec
18
libical.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libical
|
Name: libical
|
||||||
Version: 0.31
|
Version: 0.31
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Reference implementation of the iCalendar data type and serialization format
|
Summary: Reference implementation of the iCalendar data type and serialization format
|
||||||
Summary(pl): Implementacja formatu iCalendar
|
Summary(pl): Implementacja formatu iCalendar
|
||||||
|
|
||||||
@ -9,6 +9,8 @@ License: LGPLv2 or MPLv1.1
|
|||||||
URL: http://freeassociation.sourceforge.net/
|
URL: http://freeassociation.sourceforge.net/
|
||||||
Source0: http://downloads.sourceforge.net/freeassociation/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/freeassociation/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
|
Patch0: %{name}-%{version}-makefile.patch
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -35,14 +37,21 @@ korzystających z libical.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static --enable-reentrant --enable-cxx
|
%configure --disable-static -enable-cxx --enable-reentrant
|
||||||
|
|
||||||
# Omit unused direct shared library dependencies.
|
# Omit unused direct shared library dependencies.
|
||||||
sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
|
sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
|
||||||
|
|
||||||
make %{?_smp_mflags}
|
# PATCH0 breaks parallel build.
|
||||||
|
# Parallel make does not work.
|
||||||
|
make
|
||||||
|
|
||||||
|
%check
|
||||||
|
# make check
|
||||||
|
# Fails on x86_64 and ppc64.
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -89,6 +98,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/libicalvcal.so
|
%{_libdir}/libicalvcal.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jul 27 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.31-2
|
||||||
|
- Fixed linkage problems and disabled parallel build till upstream accepts fix.
|
||||||
|
|
||||||
* Thu Jul 17 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-1
|
* Thu Jul 17 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-1
|
||||||
- Version bump to 0.31.
|
- Version bump to 0.31.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user