Use CMake macros for the build; Change how python tests are invoked (RH bug #1865924)

This commit is contained in:
Milan Crha 2020-08-04 18:27:52 +02:00
parent 3481343e86
commit a1c69b81ac
2 changed files with 22 additions and 7 deletions

View File

@ -0,0 +1,12 @@
diff -up libical-3.0.8/src/test/libical-glib/CMakeLists.txt.test-patch libical-3.0.8/src/test/libical-glib/CMakeLists.txt
--- libical-3.0.8/src/test/libical-glib/CMakeLists.txt.test-patch 2020-03-07 15:42:42.000000000 +0100
+++ libical-3.0.8/src/test/libical-glib/CMakeLists.txt 2020-08-04 17:18:13.961171044 +0200
@@ -31,7 +31,7 @@ if(PYTHON3)
add_test(
NAME ${test_name}
- COMMAND ${PYTHON3} ${CMAKE_CURRENT_SOURCE_DIR}/${test_file}
+ COMMAND ${PYTHON3} -I ${CMAKE_CURRENT_SOURCE_DIR}/${test_file}
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)

View File

@ -1,4 +1,4 @@
%global __cmake_in_source_build 1 %undefine __cmake_in_source_build
Summary: Reference implementation of the iCalendar data type and serialization format Summary: Reference implementation of the iCalendar data type and serialization format
Name: libical Name: libical
@ -9,6 +9,7 @@ URL: https://libical.github.io/libical/
Source: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz Source: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch01: libical-3.0.3-load-builtin-timezone.patch Patch01: libical-3.0.3-load-builtin-timezone.patch
Patch02: libical-3.0.8-invoke-python-tests.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: gcc-c++ BuildRequires: gcc-c++
@ -67,24 +68,22 @@ Development files needed for building things which link against %{name}-glib.
%setup -q %setup -q
%patch01 -p1 -b .load-builtin-timezone %patch01 -p1 -b .load-builtin-timezone
%patch02 -p1 -b .invoke-python-tests
%build %build
mkdir -p %{_target_platform} %{cmake} \
pushd %{_target_platform}
%{cmake} .. \
-DUSE_INTEROPERABLE_VTIMEZONES:BOOL=true \ -DUSE_INTEROPERABLE_VTIMEZONES:BOOL=true \
-DICAL_ALLOW_EMPTY_PROPERTIES:BOOL=true \ -DICAL_ALLOW_EMPTY_PROPERTIES:BOOL=true \
-DGOBJECT_INTROSPECTION:BOOL=true \ -DGOBJECT_INTROSPECTION:BOOL=true \
-DICAL_GLIB:BOOL=true \ -DICAL_GLIB:BOOL=true \
-DICAL_GLIB_VAPI:BOOL=true \ -DICAL_GLIB_VAPI:BOOL=true \
-DSHARED_ONLY:BOOL=true -DSHARED_ONLY:BOOL=true
popd
# avoid parallel-builds, gir generatation fails on slower archs # avoid parallel-builds, gir generatation fails on slower archs
%make_build -j1 -C %{_target_platform} %cmake_build -j1
%install %install
make install/fast DESTDIR=%{buildroot} -C %{_target_platform} %cmake_install
%check %check
make test ARGS="-V" -C %{_target_platform} make test ARGS="-V" -C %{_target_platform}
@ -136,6 +135,10 @@ make test ARGS="-V" -C %{_target_platform}
%{_datadir}/gtk-doc/html/%{name}-glib %{_datadir}/gtk-doc/html/%{name}-glib
%changelog %changelog
* Tue Aug 04 2020 Milan Crha <mcrha@redhat.com> - 3.0.8-5
- Use CMake macros for the build
- Change how python tests are invoked (RH bug #1865924)
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.8-5 * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.8-5
- Second attempt - Rebuilt for - Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild