- Version bump to 0.43.
- Added patch to fix implicit pointer conversion from Debian. Fixes Debian BTS bug #511598. - Upstream has switched off ICAL_ERRORS_ARE_FATAL by default. This behaviour is being retained across all distributions, including Fedora 11. - Added 'Requires: tzdata'. - Enabled backtrace dumps in the syslog.
This commit is contained in:
parent
83cc56bef0
commit
3a1a5bc7d0
@ -1 +1 @@
|
||||
libical-0.41.tar.gz
|
||||
libical-0.43.tar.gz
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -urNp libical-0.41.orig/configure libical-0.41/configure
|
||||
--- libical-0.41.orig/configure 2009-01-08 00:38:26.000000000 +0530
|
||||
+++ libical-0.41/configure 2009-01-08 00:43:43.000000000 +0530
|
||||
@@ -20519,17 +20519,17 @@ fi;
|
||||
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
-#define ICAL_ERRORS_ARE_FATAL 1
|
||||
+#define ICAL_ERRORS_ARE_FATAL 0
|
||||
_ACEOF
|
||||
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
-#define NO_WARN_DEPRECATED 1
|
||||
+#define NO_WARN_DEPRECATED 0
|
||||
_ACEOF
|
||||
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
-#define NO_WARN_ICAL_MALFORMEDDATA_ERROR_HACK 1
|
||||
+#define NO_WARN_ICAL_MALFORMEDDATA_ERROR_HACK 0
|
||||
_ACEOF
|
||||
|
||||
|
12
libical-0.43-implicit-pointer-conversion.patch
Normal file
12
libical-0.43-implicit-pointer-conversion.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urNp libical-0.43.orig/src/test/regression.c libical-0.43/src/test/regression.c
|
||||
--- libical-0.43.orig/src/test/regression.c 2009-01-13 09:34:39.000000000 +0530
|
||||
+++ libical-0.43/src/test/regression.c 2009-01-13 09:54:37.000000000 +0530
|
||||
@@ -34,6 +34,8 @@
|
||||
#include <libical/ical.h>
|
||||
#include <libical/icalss.h>
|
||||
#include <libicalvcal/vobject.h>
|
||||
+#include <libicalvcal/icalvcal.h>
|
||||
+#include <libicalvcal/vcc.h>
|
||||
|
||||
#include "regression.h"
|
||||
|
@ -1,9 +1,10 @@
|
||||
--- libical-0.41.orig/src/libicalss/Makefile.in 2008-11-24 06:07:14.045235428 +0530
|
||||
+++ libical-0.41/src/libicalss/Makefile.in 2008-11-24 06:20:40.970235883 +0530
|
||||
diff -urNp libical-0.43.orig/src/libicalss/Makefile.in libical-0.43/src/libicalss/Makefile.in
|
||||
--- libical-0.43.orig/src/libicalss/Makefile.in 2009-01-13 09:34:39.000000000 +0530
|
||||
+++ libical-0.43/src/libicalss/Makefile.in 2009-01-13 09:52:10.000000000 +0530
|
||||
@@ -308,7 +308,7 @@ INCLUDES = \
|
||||
$(BDB_INCLUDE)
|
||||
|
||||
libicalss_la_LDFLAGS = -version-info 41:0:41
|
||||
libicalss_la_LDFLAGS = -version-info 43:0:43
|
||||
-libicalss_la_LIBADD = $(BDB_LIBFILES)
|
||||
+libicalss_la_LIBADD = $(BDB_LIBFILES) ../libical/libical.la
|
||||
@DEV_FALSE@libicalss_la_DEVSOURCES = icalsslexer.c icalssyacc.c
|
29
libical.spec
29
libical.spec
@ -1,6 +1,6 @@
|
||||
Name: libical
|
||||
Version: 0.41
|
||||
Release: 2%{?dist}
|
||||
Version: 0.43
|
||||
Release: 1%{?dist}
|
||||
Summary: Reference implementation of the iCalendar data type and serialization format
|
||||
Summary(pl): Implementacja formatu iCalendar
|
||||
|
||||
@ -9,15 +9,14 @@ License: LGPLv2 or MPLv1.1
|
||||
URL: http://freeassociation.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/freeassociation/%{name}-%{version}.tar.gz
|
||||
|
||||
%if 0%{?fc11}
|
||||
%else
|
||||
Patch0: %{name}-%{version}-configure.patch
|
||||
%endif
|
||||
|
||||
# http://bugs.debian.org/511598
|
||||
Patch0: %{name}-%{version}-implicit-pointer-conversion.patch
|
||||
Patch1: %{name}-%{version}-makefile.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
Requires: tzdata
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: byacc
|
||||
BuildRequires: flex
|
||||
@ -47,16 +46,11 @@ korzystających z libical.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%if 0%{?fc11}
|
||||
%else
|
||||
%patch0 -p1
|
||||
%endif
|
||||
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure --disable-static --enable-reentrant
|
||||
%configure --disable-static --enable-reentrant --with-backtrace
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -110,6 +104,15 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/%{name}/vobject.h
|
||||
|
||||
%changelog
|
||||
* Tue Jan 13 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.43-1
|
||||
- Version bump to 0.43.
|
||||
- Added patch to fix implicit pointer conversion from Debian. Fixes Debian BTS
|
||||
bug #511598.
|
||||
- Upstream has switched off ICAL_ERRORS_ARE_FATAL by default. This behaviour
|
||||
is being retained across all distributions, including Fedora 11.
|
||||
- Added 'Requires: tzdata'.
|
||||
- Enabled backtrace dumps in the syslog.
|
||||
|
||||
* Thu Jan 08 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.41-2
|
||||
- Switched off ICAL_ERRORS_ARE_FATAL for all distributions, except Fedora 11.
|
||||
Closes Red Hat Bugzilla bug #478331.
|
||||
|
Loading…
Reference in New Issue
Block a user