- Version bump to 0.41. Closes Red Hat Bugzilla bug #469252.

- Disabled C++ bindings.
This commit is contained in:
Debarshi Ray 2008-11-25 08:50:48 +00:00
parent ad1c8ebbed
commit 0972db63c3
6 changed files with 20 additions and 143 deletions

View File

@ -1 +1 @@
libical-0.40.tar.gz
libical-0.41.tar.gz

View File

@ -1,81 +0,0 @@
--- trunk/libical/src/libical/icalvalue.c 2008/10/27 16:19:27 890
+++ trunk/libical/src/libical/icalvalue.c 2008/10/27 23:20:34 891
@@ -948,24 +948,29 @@
void print_time_to_string(char* str, const struct icaltimetype *data)
{
char temp[20];
+ str[0] = '\0';
- if (icaltime_is_utc(*data)){
- snprintf(temp,sizeof(temp),"%02d%02d%02dZ",data->hour,data->minute,data->second);
- } else {
- snprintf(temp,sizeof(temp),"%02d%02d%02d",data->hour,data->minute,data->second);
- }
-
- strcat(str,temp);
+ if (data != 0) {
+ if (icaltime_is_utc(*data)){
+ snprintf(temp,sizeof(temp),"%02d%02d%02dZ",data->hour,data->minute,data->second);
+ strncat(str,temp,7);
+ } else {
+ snprintf(temp,sizeof(temp),"%02d%02d%02d",data->hour,data->minute,data->second);
+ strncat(str,temp,6);
+ }
+ }
}
void print_date_to_string(char* str, const struct icaltimetype *data)
{
char temp[20];
+ str[0] = '\0';
- snprintf(temp,sizeof(temp),"%04d%02d%02d",data->year,data->month,data->day);
-
- strcat(str,temp);
+ if (data != 0) {
+ snprintf(temp,sizeof(temp),"%04d%02d%02d",data->year,data->month,data->day);
+ strncat(str,temp,8);
+ }
}
static char* icalvalue_date_as_ical_string_r(const icalvalue* value) {
@@ -977,7 +982,7 @@
str = (char*)icalmemory_new_buffer(9);
- str[0] = 0;
+ str[0] = '\0';
print_date_to_string(str,&data);
return str;
@@ -985,10 +990,17 @@
void print_datetime_to_string(char* str, const struct icaltimetype *data)
{
- print_date_to_string(str,data);
- if ( !data->is_date ) {
- strcat(str,"T");
- print_time_to_string(str,data);
+ char temp[20];
+ str[0] = '\0';
+
+ if (data != 0) {
+ print_date_to_string(str,data);
+ if ( !data->is_date ) {
+ strncat(str,"T",19);
+ temp[0] = '\0';
+ print_time_to_string(temp,data);
+ strncat(str,temp,19);
+ }
}
}
@@ -1013,7 +1025,6 @@
str = (char*)icalmemory_new_buffer(20);
str[0] = 0;
-
print_datetime_to_string(str,&data);
return str;

View File

@ -1,41 +0,0 @@
diff -ur libical-0.40/src/libical/Makefile.in libical-0.40-makefile/src/libical/Makefile.in
--- libical-0.40/src/libical/Makefile.in 2008-10-06 04:43:31.000000000 +0200
+++ libical-0.40-makefile/src/libical/Makefile.in 2008-10-28 06:17:21.000000000 +0100
@@ -105,7 +105,7 @@
icalduration.lo icalperiod.lo icaltypes.lo icalvalue.lo pvl.lo \
sspm.lo vsnprintf.lo icallangbind.lo caldate.lo
libical_la_OBJECTS = $(am_libical_la_OBJECTS)
-libical_cxx_la_LIBADD =
+libical_cxx_la_LIBADD = $(PTHREAD_LIBS)
am__libical_cxx_la_SOURCES_DIST = icalderivedparameter.h \
icalderivedproperty.h icalderivedvalue.h \
icalderivedparameter.c icalderivedproperty.c icalrestriction.c \
diff -ur libical-0.40/src/libicalss/Makefile.in libical-0.40-makefile/src/libicalss/Makefile.in
--- libical-0.40/src/libicalss/Makefile.in 2008-10-06 04:43:33.000000000 +0200
+++ libical-0.40-makefile/src/libicalss/Makefile.in 2008-10-28 06:18:49.000000000 +0100
@@ -102,7 +102,6 @@
icalset.lo icalspanlist.lo icalmessage.lo $(am__objects_1) \
$(am__objects_2)
libicalss_la_OBJECTS = $(am_libicalss_la_OBJECTS)
-libicalss_cxx_la_LIBADD =
am__libicalss_cxx_la_SOURCES_DIST = icalspanlist_cxx.h \
icalspanlist_cxx.cpp
@WITH_CXX_BINDINGS_TRUE@am_libicalss_cxx_la_OBJECTS = \
@@ -308,7 +307,7 @@
$(BDB_INCLUDE)
libicalss_la_LDFLAGS = -version-info 40:0:40
-libicalss_la_LIBADD = $(BDB_LIBFILES)
+libicalss_la_LIBADD = $(BDB_LIBFILES) ../libical/libical.la
@DEV_FALSE@libicalss_la_DEVSOURCES = icalsslexer.c icalssyacc.c
@DEV_TRUE@libicalss_la_DEVSOURCES = icalsslexer.l icalssyacc.y
libicalss_la_SOURCES = \
@@ -351,6 +350,8 @@
$(srcdir)/icalspanlist.h \
$(srcdir)/icalmessage.h
+libicalss_cxx_la_LIBADD = ./libicalss.la ../libical/libical_cxx.la
+libicalss_cxx_la_DEPENDENCIES = ./libicalss.la ../libical/libical_cxx.la
@WITH_CXX_BINDINGS_TRUE@libicalss_cxx_la_SOURCES = \
@WITH_CXX_BINDINGS_TRUE@ $(libicalss_evolution_la_SOURCES) \
@WITH_CXX_BINDINGS_TRUE@ icalspanlist_cxx.h \

View File

@ -0,0 +1,11 @@
--- libical-0.41.orig/src/libicalss/Makefile.in 2008-11-24 06:07:14.045235428 +0530
+++ libical-0.41/src/libicalss/Makefile.in 2008-11-24 06:20:40.970235883 +0530
@@ -308,7 +308,7 @@ INCLUDES = \
$(BDB_INCLUDE)
libicalss_la_LDFLAGS = -version-info 41:0:41
-libicalss_la_LIBADD = $(BDB_LIBFILES)
+libicalss_la_LIBADD = $(BDB_LIBFILES) ../libical/libical.la
@DEV_FALSE@libicalss_la_DEVSOURCES = icalsslexer.c icalssyacc.c
@DEV_TRUE@libicalss_la_DEVSOURCES = icalsslexer.l icalssyacc.y
libicalss_la_SOURCES = \

View File

@ -1,5 +1,5 @@
Name: libical
Version: 0.40
Version: 0.41
Release: 1%{?dist}
Summary: Reference implementation of the iCalendar data type and serialization format
Summary(pl): Implementacja formatu iCalendar
@ -10,9 +10,6 @@ URL: http://freeassociation.sourceforge.net/
Source0: http://downloads.sourceforge.net/freeassociation/%{name}-%{version}.tar.gz
Patch0: %{name}-%{version}-makefile.patch
# patch from upstream to fix crash in icalvalue.c:
# http://freeassociation.svn.sourceforge.net/viewvc/freeassociation?view=rev&revision=891
Patch1: libical-0.40-icalvalue-crash.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
@ -46,13 +43,9 @@ korzystających z libical.
%prep
%setup -q
%patch0 -p1
%patch1 -p2
%build
%configure --disable-static -enable-cxx --enable-reentrant
# Omit unused direct shared library dependencies.
sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
%configure --disable-static --enable-reentrant
make %{?_smp_mflags}
@ -75,7 +68,6 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc AUTHORS
%doc ChangeLog
%doc COPYING
%doc LICENSE
@ -84,9 +76,7 @@ rm -rf $RPM_BUILD_ROOT
%doc THANKS
%doc TODO
%{_libdir}/%{name}.so.*
%{_libdir}/%{name}_cxx.so.*
%{_libdir}/libicalss.so.*
%{_libdir}/libicalss_cxx.so.*
%{_libdir}/libicalvcal.so.*
%files devel
@ -94,29 +84,27 @@ rm -rf $RPM_BUILD_ROOT
%doc doc/UsingLibical.txt
%{_includedir}/ical.h
%{_libdir}/%{name}.so
%{_libdir}/%{name}_cxx.so
%{_libdir}/libicalss.so
%{_libdir}/libicalss_cxx.so
%{_libdir}/libicalvcal.so
%{_libdir}/pkgconfig/libical.pc
%dir %{_includedir}/%{name}
#%{_includedir}/%{name}/ical.h
%{_includedir}/%{name}/ical*.h
%{_includedir}/%{name}/icptrholder.h
%{_includedir}/%{name}/pvl.h
%{_includedir}/%{name}/sspm.h
%{_includedir}/%{name}/vcomponent.h
#%{_includedir}/%{name}/icalvcal.h
%{_includedir}/%{name}/port.h
%{_includedir}/%{name}/vcaltmp.h
%{_includedir}/%{name}/vcc.h
%{_includedir}/%{name}/vobject.h
%changelog
* Sun Nov 23 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.41-1
- Version bump to 0.41. Closes Red Hat Bugzilla bug #469252.
- Disabled C++ bindings.
* Tue Oct 28 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.40-1
- Update to 0.40.
- Version bump to 0.40. Closes Red Hat Bugzilla bug #466359.
- Add patch from upstream to fix crash in icalvalue.c.
- Update makefile patch, remove the test part (already applied).
- Package libical.pc, add Requires: pkgconfig to -devel.

View File

@ -1 +1 @@
bbf9579135ce9b0be2979d104a8dc2fe libical-0.40.tar.gz
981731f5618c7f1944e0262babdcc910 libical-0.41.tar.gz