update to 2.3.0
This commit is contained in:
parent
4b36cb4c9e
commit
f215cdfc9c
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ libica-2.0.3.tar.gz
|
|||||||
/libica-2.1.0.tar.gz
|
/libica-2.1.0.tar.gz
|
||||||
/libica-2.1.1.tar.gz
|
/libica-2.1.1.tar.gz
|
||||||
/libica-2.2.0.tar.gz
|
/libica-2.2.0.tar.gz
|
||||||
|
/libica-2.3.0.tar.gz
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
From 80e1b201031a00a712e7036972aa186d4f4eee27 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
|
||||||
Date: Mon, 4 Jul 2011 17:19:28 +0200
|
|
||||||
Subject: [PATCH] use a new variable for tracking the API version
|
|
||||||
|
|
||||||
---
|
|
||||||
configure.in | 3 +++
|
|
||||||
src/Makefile.am | 2 +-
|
|
||||||
2 files changed, 4 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.in b/configure.in
|
|
||||||
index 3850ccc..429f858 100644
|
|
||||||
--- a/configure.in
|
|
||||||
+++ b/configure.in
|
|
||||||
@@ -3,6 +3,9 @@
|
|
||||||
|
|
||||||
AC_INIT(libica, 2.2.0, hd@linux.vnet.ibm.com)
|
|
||||||
|
|
||||||
+LIBICA_API=2.0
|
|
||||||
+AC_SUBST(LIBICA_API)
|
|
||||||
+
|
|
||||||
cmdline_CFLAGS="$CFLAGS"
|
|
||||||
|
|
||||||
# Compute $target
|
|
||||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
||||||
index 822f228..df4ee1b 100644
|
|
||||||
--- a/src/Makefile.am
|
|
||||||
+++ b/src/Makefile.am
|
|
||||||
@@ -2,7 +2,7 @@ INCLUDES = -I ./include -I ../include
|
|
||||||
|
|
||||||
lib_LTLIBRARIES = libica.la
|
|
||||||
|
|
||||||
-libica_la_LDFLAGS = -release $(PACKAGE_VERSION) -lrt -lcrypto
|
|
||||||
+libica_la_LDFLAGS = -release $(LIBICA_API) -lrt -lcrypto
|
|
||||||
|
|
||||||
libica_la_SOURCES = icalinux.c ica_api.c init.c icastats_shared.c \
|
|
||||||
s390_rsa.c s390_crypto.c s390_common.c s390_des.c \
|
|
||||||
--
|
|
||||||
1.7.7.6
|
|
||||||
|
|
25
libica-2.3-version.patch
Normal file
25
libica-2.3-version.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff -up libica-2.3.0/configure.in.version libica-2.3.0/configure.in
|
||||||
|
--- libica-2.3.0/configure.in.version 2013-03-20 10:58:27.000000000 +0100
|
||||||
|
+++ libica-2.3.0/configure.in 2013-05-03 10:08:28.000000000 +0200
|
||||||
|
@@ -3,6 +3,9 @@
|
||||||
|
|
||||||
|
AC_INIT(libica, 2.3.0, ingo.tuchscherer@linux.vnet.ibm.com)
|
||||||
|
|
||||||
|
+LIBICA_API=2.0
|
||||||
|
+AC_SUBST(LIBICA_API)
|
||||||
|
+
|
||||||
|
cmdline_CFLAGS="$CFLAGS"
|
||||||
|
|
||||||
|
# Compute $target
|
||||||
|
diff -up libica-2.3.0/src/Makefile.am.version libica-2.3.0/src/Makefile.am
|
||||||
|
--- libica-2.3.0/src/Makefile.am.version 2012-04-23 15:07:21.000000000 +0200
|
||||||
|
+++ libica-2.3.0/src/Makefile.am 2013-05-03 10:08:03.000000000 +0200
|
||||||
|
@@ -2,7 +2,7 @@ INCLUDES = -I ./include -I ../include
|
||||||
|
|
||||||
|
lib_LTLIBRARIES = libica.la
|
||||||
|
|
||||||
|
-libica_la_LDFLAGS = -release $(PACKAGE_VERSION) -lrt -lcrypto
|
||||||
|
+libica_la_LDFLAGS = -release $(LIBICA_API) -lrt -lcrypto
|
||||||
|
|
||||||
|
libica_la_SOURCES = icalinux.c ica_api.c init.c icastats_shared.c \
|
||||||
|
s390_rsa.c s390_crypto.c s390_common.c s390_des.c \
|
23
libica.spec
23
libica.spec
@ -1,14 +1,13 @@
|
|||||||
Summary: Library for accessing ICA hardware crypto on IBM zSeries
|
Summary: Library for accessing ICA hardware crypto on IBM zSeries
|
||||||
Name: libica
|
Name: libica
|
||||||
Version: 2.2.0
|
Version: 2.3.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: CPL
|
License: CPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://sourceforge.net/projects/opencryptoki/
|
URL: http://sourceforge.net/projects/opencryptoki/
|
||||||
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tar.gz
|
||||||
# soname backwards compatibility
|
# soname backwards compatibility
|
||||||
Patch0: %{name}-2.2-version.patch
|
Patch0: %{name}-2.3-version.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: autoconf automake libtool
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
@ -33,13 +32,16 @@ IBM zSeries.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-2.2
|
%setup -q -n %{name}-%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .version
|
%patch0 -p1 -b .version
|
||||||
|
|
||||||
# fix EOLs
|
# fix EOLs
|
||||||
sed -i -e 's/\r//g' LICENSE
|
sed -i -e 's/\r//g' LICENSE
|
||||||
|
|
||||||
|
# cleanup source archive
|
||||||
|
rm src/*.o src/*.la
|
||||||
|
|
||||||
sh ./bootstrap.sh
|
sh ./bootstrap.sh
|
||||||
|
|
||||||
|
|
||||||
@ -50,35 +52,30 @@ make AM_CFLAGS="-fno-strict-aliasing"
|
|||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
rm $RPM_BUILD_ROOT%{_libdir}/libica.la
|
rm $RPM_BUILD_ROOT%{_libdir}/libica.la
|
||||||
|
|
||||||
|
|
||||||
%clean
|
|
||||||
rm -rf $RPM_BUILD_ROOT
|
|
||||||
|
|
||||||
|
|
||||||
%post -p /sbin/ldconfig
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%doc AUTHORS LICENSE
|
%doc AUTHORS LICENSE
|
||||||
%{_bindir}/icainfo
|
%{_bindir}/icainfo
|
||||||
%{_bindir}/icastats
|
%{_bindir}/icastats
|
||||||
%{_libdir}/libica-2.0.so
|
%{_libdir}/libica-2.0.so
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_libdir}/libica.so
|
%{_libdir}/libica.so
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 03 2013 Dan Horák <dan[at]danny.cz> - 2.3.0-1
|
||||||
|
- updated to 2.3.0
|
||||||
|
|
||||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user