- updated to 2.6.1
This commit is contained in:
parent
f6ee0c223f
commit
ece8baa21a
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ libica-2.0.3.tar.gz
|
|||||||
/libica-2.2.0.tar.gz
|
/libica-2.2.0.tar.gz
|
||||||
/libica-2.3.0.tar.gz
|
/libica-2.3.0.tar.gz
|
||||||
/libica-2.4.2.tgz
|
/libica-2.4.2.tgz
|
||||||
|
/libica-2.6.1.tgz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -up libica-2.3.0/src/include/s390_rsa.h.zcrypt libica-2.3.0/src/include/s390_rsa.h
|
|
||||||
--- libica-2.3.0/src/include/s390_rsa.h.zcrypt 2014-05-29 11:28:24.000000000 +0200
|
|
||||||
+++ libica-2.3.0/src/include/s390_rsa.h 2014-05-29 11:28:32.000000000 +0200
|
|
||||||
@@ -14,6 +14,7 @@
|
|
||||||
#ifndef S390_RSA_H
|
|
||||||
#define S390_RSA_H
|
|
||||||
|
|
||||||
+#include <stdint.h>
|
|
||||||
#include <openssl/bn.h>
|
|
||||||
#include <asm/zcrypt.h>
|
|
||||||
#include "ica_api.h"
|
|
@ -1,4 +1,4 @@
|
|||||||
From 3edb86b1057f98bb70017f7998532c62e60ead12 Mon Sep 17 00:00:00 2001
|
From 2d53de6d9ca485bc851aad08eee4bbc39833905e Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
Date: Mon, 4 Jul 2011 17:19:28 +0200
|
Date: Mon, 4 Jul 2011 17:19:28 +0200
|
||||||
Subject: [libica PATCH] use a new variable for tracking the API version
|
Subject: [libica PATCH] use a new variable for tracking the API version
|
||||||
@ -9,12 +9,12 @@ Subject: [libica PATCH] use a new variable for tracking the API version
|
|||||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
2 files changed, 4 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/configure.in b/configure.in
|
diff --git a/configure.in b/configure.in
|
||||||
index 241ab0d..caa17bc 100644
|
index e0cd36e..1ac15be 100644
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -3,6 +3,9 @@
|
@@ -3,6 +3,9 @@
|
||||||
|
|
||||||
AC_INIT(libica, 2.4.0, ingo.tuchscherer@linux.vnet.ibm.com)
|
AC_INIT(libica, 2.6.1, ingo.tuchscherer@linux.vnet.ibm.com)
|
||||||
|
|
||||||
+LIBICA_API=2.0
|
+LIBICA_API=2.0
|
||||||
+AC_SUBST(LIBICA_API)
|
+AC_SUBST(LIBICA_API)
|
||||||
@ -23,18 +23,18 @@ index 241ab0d..caa17bc 100644
|
|||||||
|
|
||||||
# Compute $target
|
# Compute $target
|
||||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
index 98fe2e8..df4ee1b 100644
|
index 74da268..d9ee00b 100644
|
||||||
--- a/src/Makefile.am
|
--- a/src/Makefile.am
|
||||||
+++ b/src/Makefile.am
|
+++ b/src/Makefile.am
|
||||||
@@ -2,7 +2,7 @@ INCLUDES = -I ./include -I ../include
|
@@ -2,7 +2,7 @@ INCLUDES = -I ./include -I ../include
|
||||||
|
|
||||||
lib_LTLIBRARIES = libica.la
|
lib_LTLIBRARIES = libica.la
|
||||||
|
|
||||||
-libica_la_LDFLAGS = -version-number 2:4:0 $(PACKAGE_VERSION) -lrt -lcrypto
|
-libica_la_LDFLAGS = -version-number 2:6:1 $(PACKAGE_VERSION) -lrt -lcrypto
|
||||||
+libica_la_LDFLAGS = -release $(LIBICA_API) -lrt -lcrypto
|
+libica_la_LDFLAGS = -release $(LIBICA_API) -lrt -lcrypto
|
||||||
|
|
||||||
libica_la_SOURCES = icalinux.c ica_api.c init.c icastats_shared.c \
|
libica_la_SOURCES = icalinux.c ica_api.c init.c icastats_shared.c \
|
||||||
s390_rsa.c s390_crypto.c s390_common.c s390_des.c \
|
s390_rsa.c s390_crypto.c s390_common.c \
|
||||||
|
s390_prng.c s390_sha.c opencryptoki_api.c \
|
||||||
--
|
--
|
||||||
1.9.3
|
2.4.3
|
||||||
|
|
14
libica.spec
14
libica.spec
@ -1,20 +1,16 @@
|
|||||||
Summary: Library for accessing ICA hardware crypto on IBM zSeries
|
Summary: Library for accessing ICA hardware crypto on IBM zSeries
|
||||||
Name: libica
|
Name: libica
|
||||||
Version: 2.4.2
|
Version: 2.6.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: CPL
|
License: CPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://sourceforge.net/projects/opencryptoki/
|
URL: http://sourceforge.net/projects/opencryptoki/
|
||||||
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tgz
|
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tgz
|
||||||
# soname backwards compatibility
|
# soname backwards compatibility
|
||||||
Patch0: %{name}-2.4-version.patch
|
Patch0: %{name}-2.6-version.patch
|
||||||
# fix build with recent kernels
|
|
||||||
Patch2: %{name}-2.3-zcrypt.patch
|
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: autoconf automake libtool
|
||||||
ExclusiveArch: s390 s390x
|
ExclusiveArch: s390 s390x
|
||||||
Provides: %{name}-utils = 2.0.2-2
|
|
||||||
Obsoletes: %{name}-utils < 2.0.2-2
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A library of functions and utilities for accessing ICA hardware crypto on
|
A library of functions and utilities for accessing ICA hardware crypto on
|
||||||
@ -37,7 +33,6 @@ IBM zSeries.
|
|||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
|
||||||
%patch0 -p1 -b .version
|
%patch0 -p1 -b .version
|
||||||
%patch2 -p1 -b .zcrypt
|
|
||||||
|
|
||||||
# fix EOLs
|
# fix EOLs
|
||||||
sed -i -e 's/\r//g' LICENSE
|
sed -i -e 's/\r//g' LICENSE
|
||||||
@ -75,6 +70,9 @@ rm $RPM_BUILD_ROOT%{_libdir}/libica.la
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 17 2016 Dan Horák <dan[at]danny.cz> - 2.6.1-1
|
||||||
|
- updated to 2.6.1
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.2-3
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.2-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user