- updated to 3.7.0
This commit is contained in:
parent
07ec02972b
commit
b4ac2128e4
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@ libica-2.0.3.tar.gz
|
|||||||
/libica-3.5.0.tar.gz
|
/libica-3.5.0.tar.gz
|
||||||
/libica-3.6.0.tar.gz
|
/libica-3.6.0.tar.gz
|
||||||
/libica-3.6.1.tar.gz
|
/libica-3.6.1.tar.gz
|
||||||
|
/libica-3.7.0.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From c69c32061cb864e8934041bb48f3c241a78cb05f Mon Sep 17 00:00:00 2001
|
From cdc316c106722d4107961315d809232f5801338d Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
Date: Tue, 25 Sep 2018 13:44:32 +0200
|
Date: Tue, 25 Sep 2018 13:44:32 +0200
|
||||||
Subject: [PATCH] add build note to assembler sources
|
Subject: [PATCH] add build note to assembler sources
|
||||||
@ -25,10 +25,10 @@ Signed-off-by: Dan Horák <dan@danny.cz>
|
|||||||
3 files changed, 6 insertions(+), 2 deletions(-)
|
3 files changed, 6 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
diff --git a/configure.ac b/configure.ac
|
||||||
index 48f8242..18df2b0 100644
|
index e401afb..071a0e6 100644
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -80,12 +80,16 @@ if test "x$enable_coverage" = xno && test "x$enable_debug" = xno && test "x$enab
|
@@ -92,12 +92,16 @@ if test "x$enable_coverage" = xno && test "x$enable_debug" = xno && test "x$enab
|
||||||
FLAGS="$FLAGS -O3 -D_FORTIFY_SOURCE=2"
|
FLAGS="$FLAGS -O3 -D_FORTIFY_SOURCE=2"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -46,7 +46,7 @@ index 48f8242..18df2b0 100644
|
|||||||
AC_OUTPUT
|
AC_OUTPUT
|
||||||
|
|
||||||
diff --git a/libica.spec b/libica.spec
|
diff --git a/libica.spec b/libica.spec
|
||||||
index 022f6c2..66d82cf 100644
|
index f28651f..f6f3e8b 100644
|
||||||
--- a/libica.spec
|
--- a/libica.spec
|
||||||
+++ b/libica.spec
|
+++ b/libica.spec
|
||||||
@@ -9,7 +9,7 @@ URL: https://github.com/opencryptoki/libica
|
@@ -9,7 +9,7 @@ URL: https://github.com/opencryptoki/libica
|
||||||
@ -59,7 +59,7 @@ index 022f6c2..66d82cf 100644
|
|||||||
%description
|
%description
|
||||||
Interface library on Linux for IBM System z to utilize CPACF
|
Interface library on Linux for IBM System z to utilize CPACF
|
||||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||||
index c7cecf6..a21ba00 100644
|
index 5e69dab..3a42258 100644
|
||||||
--- a/src/Makefile.am
|
--- a/src/Makefile.am
|
||||||
+++ b/src/Makefile.am
|
+++ b/src/Makefile.am
|
||||||
@@ -8,7 +8,7 @@ lib_LTLIBRARIES = libica.la
|
@@ -8,7 +8,7 @@ lib_LTLIBRARIES = libica.la
|
||||||
@ -68,9 +68,9 @@ index c7cecf6..a21ba00 100644
|
|||||||
-fvisibility=hidden -pthread
|
-fvisibility=hidden -pthread
|
||||||
-libica_la_CCASFLAGS = ${AM_CFLAGS}
|
-libica_la_CCASFLAGS = ${AM_CFLAGS}
|
||||||
+libica_la_CCASFLAGS = ${AM_CFLAGS} ${ICA_ASFLAGS}
|
+libica_la_CCASFLAGS = ${AM_CFLAGS} ${ICA_ASFLAGS}
|
||||||
libica_la_LIBADD = @LIBS@ -lrt -lcrypto
|
libica_la_LIBADD = @LIBS@ -lrt -lcrypto -ldl
|
||||||
libica_la_LDFLAGS = -Wl,--version-script=${srcdir}/../libica.map \
|
libica_la_LDFLAGS = -Wl,--version-script=${srcdir}/../libica.map \
|
||||||
-version-number ${VERSION}
|
-version-number ${VERSION}
|
||||||
--
|
--
|
||||||
2.14.5
|
2.26.2
|
||||||
|
|
@ -1,14 +1,14 @@
|
|||||||
Summary: Library for accessing ICA hardware crypto on IBM z Systems
|
Summary: Library for accessing ICA hardware crypto on IBM z Systems
|
||||||
Name: libica
|
Name: libica
|
||||||
Version: 3.6.1
|
Version: 3.7.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: CPL
|
License: CPL
|
||||||
URL: https://github.com/opencryptoki/
|
URL: https://github.com/opencryptoki/
|
||||||
Source0: https://github.com/opencryptoki/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/opencryptoki/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
# annotate assembler source
|
# annotate assembler source
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1630582
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1630582
|
||||||
# https://github.com/opencryptoki/libica/pull/24
|
# https://github.com/opencryptoki/libica/pull/24
|
||||||
Patch0: %{name}-3.4.0-annotate.patch
|
Patch0: %{name}-3.7.0-annotate.patch
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
@ -77,6 +77,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 15 2020 Dan Horák <dan[at]danny.cz> - 3.7.0-1
|
||||||
|
- updated to 3.7.0
|
||||||
|
|
||||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.1-2
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.1-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libica-3.6.1.tar.gz) = 35e67254888d9b4a2face9978d71f6582bfe2633b40f87c46edccdc5fd98e33719288726383d31d00734c8604de4eb7082a17863ccb991a66d46f25d7f5a7abf
|
SHA512 (libica-3.7.0.tar.gz) = dfb3be2b6e745c19af916acee5ad7fdefdae35d8d0758289f11a5c427455fcb56b193a1c0c7c7a168076bc108120b8d68a811df322d321a2c6911899e93add9e
|
||||||
|
Loading…
Reference in New Issue
Block a user