updated to 2.2.0
This commit is contained in:
parent
6bd3acc8f2
commit
a26927887b
@ -1,34 +0,0 @@
|
||||
From e4d6efb9159a97c02e0569e91b47fbedd85fdbe7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Tue, 9 Nov 2010 09:50:19 +0100
|
||||
Subject: [PATCH] return a zero is missing in old_api_sha_test() in libica_sha1_test
|
||||
|
||||
The libica_sha1_test fails with an error although the actual test were
|
||||
successful:
|
||||
|
||||
...
|
||||
All SHA1 tests completed successfully
|
||||
old_api_sha_test failed with rc = 446276480
|
||||
|
||||
The reason is missing "return 0;" at the end of the old_api_sha_test()
|
||||
function.
|
||||
---
|
||||
src/tests/libica_sha1_test.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/src/tests/libica_sha1_test.c b/src/tests/libica_sha1_test.c
|
||||
index 4e21ff4..d4b613b 100644
|
||||
--- a/src/tests/libica_sha1_test.c
|
||||
+++ b/src/tests/libica_sha1_test.c
|
||||
@@ -217,7 +217,7 @@ int old_api_sha_test(void)
|
||||
|
||||
icaCloseAdapter(adapter_handle);
|
||||
|
||||
-
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
int new_api_sha_test(void)
|
||||
--
|
||||
1.7.3.2
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 40d49d04da662c8ef27959fd50af51aa606e8046 Mon Sep 17 00:00:00 2001
|
||||
From 80e1b201031a00a712e7036972aa186d4f4eee27 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Mon, 4 Jul 2011 17:19:28 +0200
|
||||
Subject: [PATCH] use a new variable for tracking the API version
|
||||
@ -9,12 +9,12 @@ Subject: [PATCH] use a new variable for tracking the API version
|
||||
2 files changed, 4 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index fc67245..663075f 100644
|
||||
index 3850ccc..429f858 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3,6 +3,9 @@
|
||||
|
||||
AC_INIT(libica, 2.1.1, hd@linux.vnet.ibm.com)
|
||||
AC_INIT(libica, 2.2.0, hd@linux.vnet.ibm.com)
|
||||
|
||||
+LIBICA_API=2.0
|
||||
+AC_SUBST(LIBICA_API)
|
||||
@ -23,7 +23,7 @@ index fc67245..663075f 100644
|
||||
|
||||
# Compute $target
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index f1873b3..5903f27 100644
|
||||
index 822f228..df4ee1b 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -2,7 +2,7 @@ INCLUDES = -I ./include -I ../include
|
||||
@ -34,7 +34,7 @@ index f1873b3..5903f27 100644
|
||||
+libica_la_LDFLAGS = -release $(LIBICA_API) -lrt -lcrypto
|
||||
|
||||
libica_la_SOURCES = icalinux.c ica_api.c init.c icastats_shared.c \
|
||||
s390_rsa.c s390_crypto.c s390_des.c \
|
||||
s390_rsa.c s390_crypto.c s390_common.c s390_des.c \
|
||||
--
|
||||
1.7.4.4
|
||||
1.7.7.6
|
||||
|
11
libica.spec
11
libica.spec
@ -1,13 +1,13 @@
|
||||
Summary: Library for accessing ICA hardware crypto on IBM zSeries
|
||||
Name: libica
|
||||
Version: 2.1.1
|
||||
Release: 2%{?dist}
|
||||
Version: 2.2.0
|
||||
Release: 1%{?dist}
|
||||
License: CPL
|
||||
Group: System Environment/Libraries
|
||||
URL: http://sourceforge.net/projects/opencryptoki/
|
||||
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tar.gz
|
||||
# soname backwards compatibility
|
||||
Patch0: %{name}-2.1-version.patch
|
||||
Patch0: %{name}-2.2-version.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: autoconf automake libtool
|
||||
@ -33,7 +33,7 @@ IBM zSeries.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-2.1
|
||||
%setup -q -n %{name}-2.2
|
||||
|
||||
%patch0 -p1 -b .version
|
||||
|
||||
@ -79,6 +79,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Aug 16 2012 Dan Horák <dan[at]danny.cz> - 2.2.0-1
|
||||
- updated to 2.2.0
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user