- updated to 4.1.0
This commit is contained in:
parent
39f053cfe6
commit
84ee9e3ed4
@ -1,33 +0,0 @@
|
||||
From 56b6ca219ecd37ba2c7e520ddac83eb801ce76ad Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Mon, 16 May 2022 15:44:06 +0200
|
||||
Subject: [libica PATCH] FIPS specific openssl config is not required in
|
||||
RHEL/Fedora
|
||||
|
||||
---
|
||||
src/fips.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/fips.c b/src/fips.c
|
||||
index 129a1a7..6466133 100644
|
||||
--- a/src/fips.c
|
||||
+++ b/src/fips.c
|
||||
@@ -235,12 +235,15 @@ fips_init(void)
|
||||
FIPS_mode_set(1);
|
||||
#else
|
||||
fips = 0;
|
||||
+ /* FIPS specific openssl config is not required in RHEL/Fedora */
|
||||
+#if 0
|
||||
if (!OSSL_LIB_CTX_load_config(openssl_libctx, LIBICA_FIPS_CONFIG)) {
|
||||
syslog(LOG_ERR, "Libica failed to load openssl fips config %s\n",
|
||||
LIBICA_FIPS_CONFIG);
|
||||
fips |= ICA_FIPS_INTEGRITY;
|
||||
return;
|
||||
}
|
||||
+#endif
|
||||
|
||||
openssl_provider = OSSL_PROVIDER_load(openssl_libctx, "fips");
|
||||
if (openssl_provider == NULL) {
|
||||
--
|
||||
2.34.3
|
||||
|
12
libica.spec
12
libica.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Summary: Library for accessing ICA hardware crypto on IBM z Systems
|
||||
Name: libica
|
||||
Version: 4.0.3
|
||||
Version: 4.1.0
|
||||
Release: 1%{?dist}
|
||||
License: CPL
|
||||
URL: https://github.com/opencryptoki/
|
||||
@ -11,9 +11,6 @@ Source0: https://github.com/opencryptoki/%{name}/archive/v%{version}/%{name}-%{v
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1630582
|
||||
# https://github.com/opencryptoki/libica/pull/24
|
||||
Patch0: %{name}-4.0.0-annotate.patch
|
||||
# FIPS openssl config is not needed on RHEL/Fedora
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2084097
|
||||
Patch1: %{name}-no-fips-config.patch
|
||||
BuildRequires: gcc
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: openssl
|
||||
@ -49,6 +46,10 @@ sh ./bootstrap.sh
|
||||
|
||||
|
||||
%build
|
||||
# FIPS openssl config is not needed on RHEL/Fedora
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2084097
|
||||
CPPFLAGS=-DNO_FIPS_CONFIG_LOAD
|
||||
export CPPFLAGS
|
||||
%configure --disable-static \
|
||||
%if %{with_fips}
|
||||
--enable-fips
|
||||
@ -106,6 +107,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Sep 30 2022 Dan Horák <dan[at]danny.cz> - 4.1.0-1
|
||||
- updated to 4.1.0
|
||||
|
||||
* Tue Aug 16 2022 Dan Horák <dan[at]danny.cz> - 4.0.3-1
|
||||
- updated to 4.0.3
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libica-4.0.3.tar.gz) = 19b6267c68e0c4b70ad9690bd7615ee2c082f3f08a2275dc9abece16207abff0136e973eab668d8698e7f1d647e945646f1c19939f1f4afe764d9b0283dd9d35
|
||||
SHA512 (libica-4.1.0.tar.gz) = e6a89b894263fc16a36675609cf477bdf00138695b4886f12be034f7b83607efe76fefbe70d3e7e0e098c162679ec08809cd83dce6799e39636963847ce0fa05
|
||||
|
Loading…
Reference in New Issue
Block a user