- updated to 3.0.1

This commit is contained in:
Dan Horák 2017-01-13 12:17:06 +01:00
parent b61ecca6b7
commit 5098c803da
5 changed files with 46 additions and 50 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@ libica-2.0.3.tar.gz
/libica-2.4.2.tgz
/libica-2.6.1.tgz
/libica-2.6.2.tgz
/libica-3.0.1.tgz

View File

@ -1,40 +0,0 @@
From b8a400c510cc7965badf85fbc2f674c166dd6ae8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 4 Jul 2011 17:19:28 +0200
Subject: [libica PATCH] use a new variable for tracking the API version
---
configure.in | 3 +++
src/Makefile.am | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/configure.in b/configure.in
index c43dc8c..2fa2273 100644
--- a/configure.in
+++ b/configure.in
@@ -3,6 +3,9 @@
AC_INIT(libica, 2.6.2, ingo.tuchscherer@linux.vnet.ibm.com)
+LIBICA_API=2.0
+AC_SUBST(LIBICA_API)
+
cmdline_CFLAGS="$CFLAGS"
# Compute $target
diff --git a/src/Makefile.am b/src/Makefile.am
index 5902c60..d9ee00b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,7 +2,7 @@ INCLUDES = -I ./include -I ../include
lib_LTLIBRARIES = libica.la
-libica_la_LDFLAGS = -version-number 2:6:2 $(PACKAGE_VERSION) -lrt -lcrypto
+libica_la_LDFLAGS = -release $(LIBICA_API) -lrt -lcrypto
libica_la_SOURCES = icalinux.c ica_api.c init.c icastats_shared.c \
s390_rsa.c s390_crypto.c s390_common.c \
s390_prng.c s390_sha.c opencryptoki_api.c \
--
2.4.11

27
libica-3.0.1-tests.patch Normal file
View File

@ -0,0 +1,27 @@
From 0702b18313b923243749f5167423067d8347f688 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Fri, 13 Jan 2017 11:00:13 +0100
Subject: [libica PATCH] make suite.out user-friendly
Put some separators to the test cases outputs so suite.out
is more readable.
---
src/tests/suite.run | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/tests/suite.run b/src/tests/suite.run
index bcf74de..0fba736 100755
--- a/src/tests/suite.run
+++ b/src/tests/suite.run
@@ -58,6 +58,8 @@ echo -ne "" &> $out;
for (( i=1; i <= ${#testcases[@]}; i++ ))
do
echo -ne "Running libica test suite (writing to "$out") ... "$i"/"${#testcases[@]}"\r";
+ echo "Running '${testcases[i-1]}' ..." >> $out;
./${testcases[i-1]} >> $out 2>&1;
+ echo -ne "... done\n\n" >> $out;
done
echo -ne "\n";
--
2.7.4

View File

@ -1,13 +1,13 @@
Summary: Library for accessing ICA hardware crypto on IBM zSeries
Name: libica
Version: 2.6.2
Version: 3.0.1
Release: 1%{?dist}
License: CPL
Group: System Environment/Libraries
URL: http://sourceforge.net/projects/opencryptoki/
Source0: http://downloads.sourceforge.net/opencryptoki/%{name}-%{version}.tgz
# soname backwards compatibility
Patch0: %{name}-2.6-version.patch
# https://sourceforge.net/p/opencryptoki/mailman/message/35601508/
Patch0: %{name}-3.0.1-tests.patch
BuildRequires: openssl-devel
BuildRequires: autoconf automake libtool
ExclusiveArch: s390 s390x
@ -31,8 +31,7 @@ IBM zSeries.
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .version
%patch0 -p1
# fix EOLs
sed -i -e 's/\r//g' LICENSE
@ -41,9 +40,8 @@ sh ./bootstrap.sh
%build
%configure --disable-static
# paralell make doesn't work
make AM_CFLAGS="-fno-strict-aliasing"
%configure --disable-static --enable-fips --enable-testcases
make %{?_smp_mflags}
%install
@ -51,6 +49,13 @@ make install DESTDIR=$RPM_BUILD_ROOT
rm $RPM_BUILD_ROOT%{_libdir}/libica.la
%check
pushd src/tests
LD_LIBRARY_PATH=../.libs PATH=..:$PATH ./suite.run -v
cat suite.out
popd
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
@ -60,7 +65,7 @@ rm $RPM_BUILD_ROOT%{_libdir}/libica.la
%doc AUTHORS LICENSE
%{_bindir}/icainfo
%{_bindir}/icastats
%{_libdir}/libica-2.0.so
%{_libdir}/libica.so.*
%{_mandir}/man1/icainfo.1*
%{_mandir}/man1/icastats.1*
@ -70,6 +75,9 @@ rm $RPM_BUILD_ROOT%{_libdir}/libica.la
%changelog
* Fri Jan 13 2017 Dan Horák <dan[at]danny.cz> - 3.0.1-1
- updated to 3.0.1
* Tue Apr 12 2016 Dan Horák <dan[at]danny.cz> - 2.6.2-1
- updated to 2.6.2

View File

@ -1 +1 @@
0381595f668016e4010d860cf6105b19 libica-2.6.2.tgz
SHA512 (libica-3.0.1.tgz) = 9002dde2db154d710953995deffd939e739237fd22ac6edc26216c95a5a13ab6c6de60e9c01c0776f2cef6140f80f3be2ed097b67d785030081295f1df407f1d