Import rpm: c8s
This commit is contained in:
commit
2642da86c1
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
||||
SOURCES/libhbaapi-2.2.9.tar.gz
|
||||
/libhbaapi-2.2.9.tar.gz
|
13
libhbaapi-2.2.9-dl-linking.patch
Normal file
13
libhbaapi-2.2.9-dl-linking.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 7d41812..27501c1 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -6,6 +6,8 @@ AM_INIT_AUTOMAKE([-Wall -Werror foreign])
|
||||
AC_PROG_CC
|
||||
AC_PROG_LIBTOOL
|
||||
|
||||
+AC_CHECK_LIB(dl, dlopen)
|
||||
+
|
||||
AC_CONFIG_FILES([Makefile HBAAPI.pc])
|
||||
AC_OUTPUT
|
||||
|
44
libhbaapi-2.2.9-portspeed.patch
Normal file
44
libhbaapi-2.2.9-portspeed.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From e135ff849b6538814096401d1b40159091505d14 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Leech <cleech@redhat.com>
|
||||
Date: Wed, 17 Sep 2014 06:03:14 +0000
|
||||
Subject: [PATCH] libhbaapi: Add new HBA_PORTSPEED definitions.
|
||||
|
||||
These extend the defined port speed API out to 40 GBit/sec, matching the
|
||||
FDMI values from the latest FC-GS-7 draft.
|
||||
|
||||
Signed-off-by: Chris Leech <cleech@redhat.com>
|
||||
Signed-off-by: Vasu Dev <vasu.dev@intel.com>
|
||||
---
|
||||
hbaapi.h | 16 +++++++++++-----
|
||||
1 file changed, 11 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/hbaapi.h b/hbaapi.h
|
||||
index 58098e0..b94703b 100644
|
||||
--- a/hbaapi.h
|
||||
+++ b/hbaapi.h
|
||||
@@ -229,11 +229,17 @@ typedef HBA_UINT32 HBA_PORTSTATE;
|
||||
|
||||
|
||||
typedef HBA_UINT32 HBA_PORTSPEED;
|
||||
-#define HBA_PORTSPEED_UNKNOWN 0 /* Unknown - transceiver incable
|
||||
- * of reporting */
|
||||
-#define HBA_PORTSPEED_1GBIT 1 /* 1 GBit/sec */
|
||||
-#define HBA_PORTSPEED_2GBIT 2 /* 2 GBit/sec */
|
||||
-#define HBA_PORTSPEED_10GBIT 4 /* 10 GBit/sec */
|
||||
+#define HBA_PORTSPEED_UNKNOWN 0x0000 /* Unknown - transceiver incable
|
||||
+ * of reporting */
|
||||
+#define HBA_PORTSPEED_1GBIT 0x0001 /* 1 GBit/sec */
|
||||
+#define HBA_PORTSPEED_2GBIT 0x0002 /* 2 GBit/sec */
|
||||
+#define HBA_PORTSPEED_10GBIT 0x0004 /* 10 GBit/sec */
|
||||
+#define HBA_PORTSPEED_4GBIT 0x0008 /* 4 GBit/sec */
|
||||
+#define HBA_PORTSPEED_8GBIT 0x0010 /* 8 GBit/sec */
|
||||
+#define HBA_PORTSPEED_16GBIT 0x0020 /* 16 GBit/sec */
|
||||
+#define HBA_PORTSPEED_32GBIT 0x0040 /* 32 GBit/sec */
|
||||
+#define HBA_PORTSPEED_20GBIT 0x0080 /* 20 GBit/sec */
|
||||
+#define HBA_PORTSPEED_40GBIT 0x0100 /* 40 GBit/sec */
|
||||
#define HBA_PORTSPEED_NOT_NEGOTIATED (1 << 15) /* Speed not established */
|
||||
|
||||
|
||||
--
|
||||
1.9.3
|
||||
|
148
libhbaapi.spec
Normal file
148
libhbaapi.spec
Normal file
@ -0,0 +1,148 @@
|
||||
Name: libhbaapi
|
||||
Version: 2.2.9
|
||||
Release: 13%{?dist}
|
||||
Summary: SNIA HBAAPI library
|
||||
Group: System Environment/Libraries
|
||||
License: SNIA
|
||||
URL: http://open-fcoe.org/
|
||||
# This source was cloned from upstream git (libHBAAPI)
|
||||
Source: %{name}-%{version}.tar.gz
|
||||
Patch0: libhbaapi-2.2.9-dl-linking.patch
|
||||
Patch1: libhbaapi-2.2.9-portspeed.patch
|
||||
BuildRequires: automake libtool
|
||||
|
||||
%description
|
||||
The SNIA HBA API library. C-level project to manage
|
||||
Fibre Channel Host Bus Adapters.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup
|
||||
%patch0 -p1 -b .ld-linking
|
||||
%patch1 -p1 -b .portspeed
|
||||
|
||||
%build
|
||||
./bootstrap.sh
|
||||
%configure --disable-static
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%doc COPYING
|
||||
%config(noreplace) %{_sysconfdir}/hba.conf
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/*
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
|
||||
%changelog
|
||||
* Fri Mar 22 2019 Chris Leech <cleech@redhat.com> - 2.2.9-13
|
||||
- Rebuilt to pick up missing -devel package BZ#1688313
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.9-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.9-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.9-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.9-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.9-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.9-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Oct 07 2014 Chris Leech <cleech@redhat.com> - 2.2.9-6
|
||||
- sync with upstream, adds new portspeed definitions
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.9-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.9-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed Jul 31 2013 Petr Šabata <contyk@redhat.com> - 2.2.9-3
|
||||
- Make the devel subpackage arch-dependent
|
||||
|
||||
* Thu Jul 11 2013 Petr Šabata <contyk@redhat.com> - 2.2.9-2
|
||||
- Link against libdl
|
||||
|
||||
* Tue Jun 04 2013 Petr Šabata <contyk@redhat.com> - 2.2.9-1
|
||||
- 2.2.9 bump
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Oct 04 2012 Petr Šabata <contyk@redhat.com> - 2.2.6-1
|
||||
- Migrate to the Open-FCoE.org fork
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Jan 26 2012 Petr Šabata <contyk@redhat.com> - 2.2-14
|
||||
- Update to hbaapi_build 2.2.5
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu Jul 07 2011 Petr Sabata <contyk@redhat.com> - 2.2-12
|
||||
- Update to hbaapi_build 2.2.4
|
||||
- Remove now obsolete Buildroot and defattr
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Mar 16 2010 Jan Zeleny <jzeleny@redhat.com> - 2.2-10
|
||||
- updated hbaapi_build to 2.2.2
|
||||
|
||||
* Wed Nov 04 2009 Jan Zeleny <jzeleny@redhat.com> - 2.2-9
|
||||
- fixed linking with libdl
|
||||
|
||||
* Thu Jul 30 2009 Jan Zeleny <jzeleny@redhat.com> - 2.2-8
|
||||
- added libtool to BuildRequires
|
||||
|
||||
* Thu Jul 30 2009 Jan Zeleny <jzeleny@redhat.com> - 2.2-7
|
||||
- added automake to BuildRequires
|
||||
|
||||
* Thu Jul 30 2009 Jan Zeleny <jzeleny@redhat.com> - 2.2-6
|
||||
- rebase of hbaapi_build code
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Apr 01 2009 Jan Zeleny <jzeleny@redhat.com> - 2.2-4
|
||||
- added some info to description line
|
||||
- replaced unoficial build source tarball with official one
|
||||
|
||||
* Tue Mar 31 2009 Jan Zeleny <jzeleny@redhat.com> - 2.2-3
|
||||
- minor changes in spec file - filenames change, removal of
|
||||
duplicate patch files (included in build source tarball)
|
||||
|
||||
* Thu Mar 12 2009 Jan Zeleny <jzeleny@redhat.com> - 2.2-2
|
||||
- correction of patches' names to correct format
|
||||
|
||||
* Tue Feb 24 2009 Chris Leech <christopher.leech@intel.com> - 2.2-1
|
||||
- initial packaging of hbaapi 2.2
|
Loading…
Reference in New Issue
Block a user